cancel
Showing results for 
Search instead for 
Did you mean: 
EV9 - Moving Indexes to a New Server

Just a write-up of my EV9 Indexing Service move to a new dedicated Indexing server.

My situation was Server1 was getting overwhelmed with both Storage and Indexing Services running. The Indexes folder was getting large (1.2 TB) too. (Separating the Services will help with our EV10 upgrade as we are hardware constrained.)

Proposed solution was to build a new dedicated Indexing server, Server2. Create new Open Indexes on Server2, Closing Indexes on Server1, then move all of the existing Server1 Indexes to Server2.

All EV9.0.5 on VM servers with virtual RDM storage.

  • Server 2 was built and joined to the existing Site, following http://www.symantec.com/docs/TECH50844. Virtual RDM added for new Indexes as F:.
  • Added the “Enterprise Vault Indexing Service” to Server 2 from the VAC, Servers, Server Name, right-click Services and open the Properties.
  • Created new Open Indexes on Server2 (F:), updated the "Override the inherited Index Service" on each of my Provisioning Groups to Server2 and Closed Indexes on Server1 (E:). (as documented, an EV9 Closed Index continues to be updated and only new Indexes are created in the Open Index.)
  • Following http://www.symantec.com/docs/TECH51450. I then had Server1 E: drive moved to Server2 as E: and updated the IndexPathRootEntry table as per the query provided in Step 5.

Took a fair bit of research to get to the above (thanks to a few Symantec Connect members) but the actual move process only took about 15 minutes to complete. The Help Files and Technotes* are all excellent I just wanted to connect them together in case it ever helps anyone in the future.

*Technote 51450 could be clearer, see https://www-secure.symantec.com/connect/ideas/ev9-moving-indexes-technote-confusion