cancel
Showing results for 
Search instead for 
Did you mean: 

Billing Account diferent from Exchange Mailbox

Hi,

When a Person change user, we disconnect the mailbox from the old account and attach to the new account, after enterprise vault runs provisioning tasks and sync the mailbox everything is running OK.

When I look at archive property the billing account is still the old one.

Example:

A person with the user KK00001 change to KK00009 (Test user). When look at the archive I found this:

ArchiveNamePrimeiro Penultimo Kk00009
SIDS-1-5-21-498953675-673808096-3040172915-458270
SID - AD SamAccountNameKK00001
  

 

What is the best method to correct this? using automation script, I don't want to do this by hand.

Please don't suggest stop change user, I can't do anything about that. 

Thanks You

Exchange 2010 SP3

Enterprise Vault 10.0.4

SQL 2008 R2

2 Solutions

Accepted Solutions
Accepted Solution!

Re: Billing Account diferent from Exchange Mailbox

Clear OwningTrusteeIdentity in SQL and auto populate??

PopulateBillingAccount
HKEY_LOCAL_MACHINE \SOFTWARE \Wow6432Node \KVS \Enterprise Vault \Agents
Location
DWORD. 0 — Do not repopulate the Billing Owner field on archives where it is blank. (Default.) 1 — Repopulate the Billing Owner field on archives where it is blank.
Content
Inarchivesforwhichnobillingownerisspecified,letsyouspecifyone by synchronizing with the mailbox.

View solution in original post

Accepted Solution!

Re: Billing Account diferent from Exchange Mailbox

Even if you could clear it in EVPM, you'd have to specify a Archive section for each and every existing archive.  Not an easy prospect, but it could be done... assuming EVPM would set that field with ''.

If you're going for the SQL route, keep in mind that this is a reference between the Root and Trustee tables.  Check out this article for a similar issue/solution:

https://vox.veritas.com/t5/Enterprise-Vault/Script-for-billing-account-change/m-p/568879#M81072

It's likely that all you'll need to do is set the OwningTrusteeIdentity to Null for all entries where the ContainerRootIdentity is Null.  Again, it's a good idea to start out small, however.  Try out one archive, make sure it works before moving forward.

 

View solution in original post

5 Replies
Accepted Solution!

Re: Billing Account diferent from Exchange Mailbox

Clear OwningTrusteeIdentity in SQL and auto populate??

PopulateBillingAccount
HKEY_LOCAL_MACHINE \SOFTWARE \Wow6432Node \KVS \Enterprise Vault \Agents
Location
DWORD. 0 — Do not repopulate the Billing Owner field on archives where it is blank. (Default.) 1 — Repopulate the Billing Owner field on archives where it is blank.
Content
Inarchivesforwhichnobillingownerisspecified,letsyouspecifyone by synchronizing with the mailbox.

View solution in original post

Re: Billing Account diferent from Exchange Mailbox

Thank you dcVAST,

Do also know what is the best way to clear the billing account? is with an SQL query? Can I do with EVPM?

Thank António

 

Re: Billing Account diferent from Exchange Mailbox

Yeah clearing in SQL works. Start small first and test.

With EVPM you can specify BillingOwner in the Archive section but I do not think you can clear it. I haven't tested leaving it blank though.

Accepted Solution!

Re: Billing Account diferent from Exchange Mailbox

Even if you could clear it in EVPM, you'd have to specify a Archive section for each and every existing archive.  Not an easy prospect, but it could be done... assuming EVPM would set that field with ''.

If you're going for the SQL route, keep in mind that this is a reference between the Root and Trustee tables.  Check out this article for a similar issue/solution:

https://vox.veritas.com/t5/Enterprise-Vault/Script-for-billing-account-change/m-p/568879#M81072

It's likely that all you'll need to do is set the OwningTrusteeIdentity to Null for all entries where the ContainerRootIdentity is Null.  Again, it's a good idea to start out small, however.  Try out one archive, make sure it works before moving forward.

 

View solution in original post

Re: Billing Account diferent from Exchange Mailbox

I got the query working in the LAB environment, just need a little work to fix production.