cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot delete archive from Centera

We migrated to Centera last month and I've just come to delete an archive for the first time.  I get the following events logged and the archive just stays on 'marked for deletion'
 
Error opening EMC Centera C-Clip
Function call: NetworkPacket.checkControl(18)<HPPReadBlobTransaction.readBytes(HPPImportData&)<HPPReadBlobTransaction.run()<Cluster.readBlob<ClusterCloud::readBlob(FPBasicGenericStream*,AB2J3THC8PBTReCAN5BVJ05FS5O,,0,-1,-1,0)<FPClip:Smiley Surprisedpen(pool, AB2J3THC8PBTReCAN5BVJ05FS5O, 1)<FPClip_Open(-,AB2J3THC8PBTReCAN5BVJ05FS5O,1)
Status: FP_OPERATION_NOT_ALLOWED (-10204)
Reason: The use of this operation is restricted (transid='vault1/18/READ_CLIP')
Pool Address: 101.29.1.1:3218,101.29.1.2:3218
 
Followed by:
 
Delete Vault failed
Reason: Error opening EMC Centera C-Clip   Function call:    Status:  ()   Reason:    Pool Address:    [0xc0041a69]
Vault Name: Fred Bloggs
Vault Store: Mailbox Vault Store
Vault Id: 14A357727D6A57A48BE9339DFFE8EDB6C1110000Vault
 
I've checked pool and profile permissions on the Centera.  I did find that the cluster mask didn't have privileged delete so I granted this but the error is still the same. 
 
Have tested the PEA file in centeraverify and everything looks good.  It's the fact that it's the fpclip_open that is failing that I find strange.  Are there any roles required on the profile or does anyone have any ideas?
 
Also, have checked the partition and retention is set to 'Never' on the compliance page.
 
Thanks
 
1 Solution

Accepted Solutions
Accepted Solution!

Re: Cannot delete archive from Centera

Before you waste months on this issue like I just did, do you use a PEA for your Centera? Do you have anonymous profile turned off on the Centera? If so, then there is a bug in the Enterprise Vault code that does NOT send the PEA to Centera when deleting a vault. I worked for months on this aggravating issue and finally the boys in the UK found it in a code review after some SDK logging showed very strange commands being sent to the Cetera.


Your event logs look identical to the ones I had on my systems. I bet if you use a tool from EMC (the name escapes me right now) it'll delete that same ClipID no problem at all and the delete will replicate to your other Centera nicely.

EV 7.0 SP3 will have a fix for it and EV2007 SP1 will have a fix too. I don't know if they'll put a fix in for 6.x or not.


For the time being on your EV servers set an environment variable named CENTERA_PEA_LOCATION. The value is whatever the disk path is to your PEA file. Something like



CENTERA_PEA_LOCATION D:\PEA_FIle\MyPEAFile.pea


That will force the system to pass the PEA to Centera.


If you talk to Symantec support, tell them you think you are being affected by the same Vault Delete issue that support ticket '281-124-984' had.


We also have two Centeras that replicate between each other. You may now also have orphaned clips on your Centera now. We found even though Enterprise Vault gets an error that will not let it delete from Centera, it WOULD still delete rows of items from the SQL tables. If you stop and start the Storage process enough times, you'll eventually see the vault disappear from Enterprise Vault Admin Console. It'll be gone from EV, but the data is still on Centera.

You'll want to work with support with a tool called 'EVCenteraChecker' to scan your Centera for Orphaned Clips and get rid of them.

Message Edited by Brian Day on 07-23-200708:45 AM

View solution in original post

11 Replies

Re: Cannot delete archive from Centera

I found the knowledge base article about retention periods.  Basically our environment is behaving exactly like it should do on a compliance mode centera, but we only have basic compliance mode which as I understand it should allow me to delete the archives if need be?
 
Or am I missing the point here?

Re: Cannot delete archive from Centera

Hi,
 
Do you have a replica Centera as well?
 

Re: Cannot delete archive from Centera

We do yes, is it something to to with the replication?
Accepted Solution!

Re: Cannot delete archive from Centera

Before you waste months on this issue like I just did, do you use a PEA for your Centera? Do you have anonymous profile turned off on the Centera? If so, then there is a bug in the Enterprise Vault code that does NOT send the PEA to Centera when deleting a vault. I worked for months on this aggravating issue and finally the boys in the UK found it in a code review after some SDK logging showed very strange commands being sent to the Cetera.


Your event logs look identical to the ones I had on my systems. I bet if you use a tool from EMC (the name escapes me right now) it'll delete that same ClipID no problem at all and the delete will replicate to your other Centera nicely.

EV 7.0 SP3 will have a fix for it and EV2007 SP1 will have a fix too. I don't know if they'll put a fix in for 6.x or not.


For the time being on your EV servers set an environment variable named CENTERA_PEA_LOCATION. The value is whatever the disk path is to your PEA file. Something like



CENTERA_PEA_LOCATION D:\PEA_FIle\MyPEAFile.pea


That will force the system to pass the PEA to Centera.


If you talk to Symantec support, tell them you think you are being affected by the same Vault Delete issue that support ticket '281-124-984' had.


We also have two Centeras that replicate between each other. You may now also have orphaned clips on your Centera now. We found even though Enterprise Vault gets an error that will not let it delete from Centera, it WOULD still delete rows of items from the SQL tables. If you stop and start the Storage process enough times, you'll eventually see the vault disappear from Enterprise Vault Admin Console. It'll be gone from EV, but the data is still on Centera.

You'll want to work with support with a tool called 'EVCenteraChecker' to scan your Centera for Orphaned Clips and get rid of them.

Message Edited by Brian Day on 07-23-200708:45 AM

View solution in original post

Re: Cannot delete archive from Centera

Hi Brian,
 
I'm one of those UK guys.  I agree it sounds like your issue which is why I asked about the replica.
Hope all is well with your system now?
 

Re: Cannot delete archive from Centera

Deleting vaults works like a charm now! Smiley Happy You have no idea how much of a relief it was once we found that. We have some other smaller issues, but are working with support to try and work them out.

Re: Cannot delete archive from Centera

I cannot thank you enough for letting me in on this priceless information.  I can only guess how much time you've saved me.  I changed the environment variable and restarted the services and everything worked a treat.  I'm on holiday from the end of this week so I'm going to look at getting hold of the evcenterachecker when I get back.  I've read about it before but never got round to giving it a go.  We don't have masses of data so I'm not expecting to find many clips that have been orphaned.
 
Once again, thanks very much for your help.
 
Chris

Re: Cannot delete archive from Centera

Sweet! I'm glad to hear there is at least 1 other person this little bug affected. I was feeling lonely! Smiley Very Happy

Re: Cannot delete archive from Centera

Hi there
 
we seen to be having a similar problem, what is this environment variable and how should this be configured in EV?
 
SK

Re: Cannot delete archive from Centera

Thanks for the info, this is another issue I have fixed through the EV forums.
 
One question I do have is that one of our EV servers has access to 2 pools on the Centera and therefore 2 PEA files. I'm hoping I don't have to delete any archives from it, however can I have multiple variables? On the other had, if I was to add the variable just for one pool to allow an archive to be deleted , would this stop access to the other pool whilst the variable existed?
 
Thanks again.
 
 

Re: Cannot delete archive from Centera



@JUNIOR B wrote:
Thanks for the info, this is another issue I have fixed through the EV forums.
 
One question I do have is that one of our EV servers has access to 2 pools on the Centera and therefore 2 PEA files. I'm hoping I don't have to delete any archives from it, however can I have multiple variables? On the other had, if I was to add the variable just for one pool to allow an archive to be deleted , would this stop access to the other pool whilst the variable existed?
 
Thanks again.
 
 





Junior,

First, I'm glad you got something fixed and didn't have to go through the headache we did. Smiley Happy

I don't think you can do multiple variables. I'm only going on a hunch saying that, I have no real answer.

Have you considered having EMC merge your PEA file so that it is good for both pools and giving you access to modify the content of both as well?