cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

EV Dashboard 0.21 available for download.

Hi all,

I have just uploaded a new version of EV Dashboard to www.evdiscuss.net/download.

It includes a new Singe Instance Storage Report. Thanks go to JesusWept2 for providing the SQL query, which I have wrapped up in some ASP.

A new table needs to be created 'SISReport', within the EVDashboard database. The code to create the table is in the /sql/EVDashboard Database Creation/CreateTables.sql.

Enjoy,

Jeremy.

31 Replies
Highlighted

I know I promised...

But have not had time yet.

However, next week I might have a few days to play. Will report.

Seeing you added a SIS report, I assume this one is for EV8?

Thanks.

Regards. Gertjan
Highlighted

Hi GertjanA, I would not say

Hi GertjanA,

I would not say this version is specifically for version 8.0 and newer. Just the SISReport only applies if people have single instance storage enabled on version 8.0 or newer.

Everything else will run as it always has done on EV installations of earlier versions. However I have only ever tried it with 7.5, not earlier. If anyone has an earlier version and has EVD up and running I would be interested to hear about it.

Thanks,

Jeremy.

Highlighted

Hey JP,   I've just got done

Hey JP,

 

I've just got done running through the installation of EVDashboard and everything looks great... However I can't get the test connectivity page to connect to the EVDashboard database from the console. I can however create a ODBC connection and successfully connect over to the SQL server, and I can also telnet to the 1433 port on the SQL server. I've even tried using the SA account to connect to a database from the connectivity testing window but it stills gives me the following:

 

Error Number -2147467259: [Microsoft][ODBC SQL Server Driver][SQL Server]Cannot open database "EVDashboard,1433" requested by the login. The login failed.

 

This is strange because I have numerous other applications connecting to my production SQL server via the same method... any ideas?

Highlighted

the user you're running that

the user you're running that script as, does it have access to that database?

https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

Yea absolutely, it's the db

Yea absolutely, it's the db owner of the evdashboard DB.
Highlighted

Anymore input by chance? This

Anymore input by chance? This is a Windows 2008 box which is connecting to another Win 2008 box that is running SQL 2005. All other methods of connection work to the database, except within EV Dashboard itself.

Highlighted

it could be that its trying

it could be that its trying to connect through named pipes on the Server you're trying to run it from and the SQL server only allows for TCP/IP connections, it could also be the windows firewall on 2008 that is blocking it

https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

Thanks for the futher

Thanks for the futher input..

 

However the Firewall on this 2008 box is disabled, as EV is connecting to the same SQL production server just fine. And the fact that the ODBC administration can connect to the EV database successfully also, I am starting to think that this may reside inside the app itself.. Is it possibly trying to call an old SQL driver that 2008 doesn't use?

Highlighted

i'll download the VBS that he

i'll download the VBS that he uses and give you a bunch of connection strings, i'm pretty sure its trying to use named pipes, ODBC and ADO use different connection methods

https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

awesome thanks... I just

awesome thanks... I just can't seem to figure it out.

Highlighted

Hi Guys, Sorry I have only

Hi Guys,

Sorry I have only just come back to this thread. Unfortunately I have not had anyone test out SQL 2008. The connect strings I use are from SQL 2000/2005 (I am currently using SQL 2005 SP3 with no problems).

I wish I could be more help in this area.

Please let me know if you manage to get this working. I will see if 2008 does use newer connection strings or methods and post back if I find anything.

Jeremy.

Highlighted

SQL 2008 & EV Dashboard....?

Hi all,

Has anyone out there managed to get SQL 2008 and EV Dashboard running together?

If you do please post here, so we know it can be done.

Thanks,

Jeremy.

Highlighted

i'll test it for you mate in

i'll test it for you mate in a bit, i'm absolutely sure that we need to add "Network Library=DBMSSOCN"
This will force a TCP/IP connection and not named pipes

https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

Thanks JW. It will certainly

Thanks JW.

It will certainly be useful to have this future proofing.

Jeremy.

Highlighted

Ok so I have SQL 2005 SP3 and

Ok so I have SQL 2005 SP3 and EV 9 , installed and configured everything per the document (the only thing I didnt understand was the reference to the 'trigger' file ? )

 

When i go to evserver/evdashboard some information comes up but not much.  If i run any of the reports like Enabled Mailboxes it comes back blank.

 

Yet I used the EVD_User and EVRO_User, i've double checked their mappings.  Run i run the .cmd to gather data it seems to process normally no errors in the log file. 

 

What am I missing ? Thank you !

Highlighted

Followup info, there is an

Followup info, there is an error in the log and i get the same thing with test sql

 

2010.11.01 05:55:27: Processing Organisation Archiving History.
2010.11.01 05:55:27: Processing Organisation Archiving History - EnterpriseVaultDirectory.
2010.11.01 05:55:27: [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name 'Saveset'.
2010.11.01 05:55:28: Error creating connection to database server miasql / evdashboard.  Check your connection string or database server name/IP and try again.
 

 

which seems to be a similar error gentleman above is getting but i am using sql 2005 not 2008. 

Highlighted

One more followup, i created

One more followup, i created an ODBC connection from the IIS server where evdashboard is installed to my sql server, and it tests fine using the ebd_user account.

 

Microsoft SQL Server ODBC Driver Version 06.01.7600

Running connectivity tests...

Attempting connection
Connection established
Verifying option settings
Disconnecting from server

TESTS COMPLETED SUCCESSFULLY!

Highlighted

well jp is getting login

well jp is getting login failed

yours is because its trying to query a table that doesnt exist or doesnt have access to the database (most likely a vault store database)

https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

Ok ... well none of my

Ok ... well none of my reports are retrieving any data, and running the process command even with the server time set to < 8:30am it runs in 1 second.  Something isn't right ..