EV Upgrade for multiple servers

Hi All,

This is an upgrade question.

All the EV Servers are part of the same EV site. However each server has Vault Store DB located on SQL Servers at the local locations. Current EV version is EV 11.0.0. OS of EV server is Windows Server 2008 R2. I am assuming that I would first need to upgrade EV in-place to 11.0.1 before migration to new server running EV 12.4

The goal is to upgrade EV to latest version (EV 12). In order to perform this upgrade, is it possible that the upgrade can be done one server at a time? - for example, migrate one server to a new server running EV 12 on Windows Server 2016 and upgrade its relevant VS DBs and then finaly perform the migration of the Directory Server to EV 12 once all other servers are done? I would like to perform the upgrade in phases spread across weeks instead of all at once if possible.

 

Thanks!

Regards,
VJ

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: EV Upgrade for multiple servers

Hi,

they way would be:

inplace upgrade ALL to 11.0.1 on Win 2008

move server to Win 2012 (directly to 2016 is possible although not supported for Version 12 - not recommended)

Upgrade to ALL to 12.5

Move to Win 2016 or newer, or keep 2012 aslong as it isupported.

Mixed configurations, like 11.0.1 and 12.5 will not work, since you will have different database schemes.

regards

 

View solution in original post

4 Replies
Highlighted

Re: EV Upgrade for multiple servers

First, be sure to read the EV Compatibility Guide. The type of upgrade you are referring to is called a Transitional Migration - Upgrading EV and migrating to new servers. If all servers belong to the same Archiving Site, you will need to down the entire environment (stop and disable services). If you are doing a Transitional Migration on SQL as well, very important that you record names and locations of all databases and transaction logs as well as the SQL collation value. You should make a local copy of the Directory Store database and transaction log before beginning. Note that you must progress through each iteration of EV because database schema updates will take place at each version. You must do each server 1 at a time and only bringing each server fully online when each server has completed the schema updates. I've done this work all over North America so, let me know if you have further questions. I'm the former EV Specialist in Canada.
Rick Grigg
rgrigg@odysseypsg.com
Highlighted

Re: EV Upgrade for multiple servers

Thanks for reply... would like to know more about what you have mentioned in this line "Note that you must progress through each iteration of EV because database schema updates will take place at each version. " Is it not possible to migrate directly from EV 11.0.0 to EV 12.4.1? I understand that Server Settings Migration Wizard will not be compatible as it requires minimium of EV 11.0.1. I was thinking of manual migration method. 

 

Highlighted

Re: EV Upgrade for multiple servers

Hello,

As far as I know, you can go from 11.0 to 12.4 directly. I'm not sure about using SMW to do this, but the SMW documentation should have this information. 

12.4.1 is a 'maintenance release' (like a Service Pack), and requires EV to be on the 12.4 release first. 

I always had the impression you could not mix EV versions on servers if you were using 1 site with a number of EV servers. 1 site = 1 Directory database. The upgrade would upgrade ALL EV databases (no matter where they are located) to the new version. This does mean the EV binaries also will need to be upgraded. In your situation, the complexity with also needing an OS upgrade makes it more difficult. 

Perhaps you can have Rick assist as consultant :-)

 

Regards. Gertjan
Highlighted
Accepted Solution!

Re: EV Upgrade for multiple servers

Hi,

they way would be:

inplace upgrade ALL to 11.0.1 on Win 2008

move server to Win 2012 (directly to 2016 is possible although not supported for Version 12 - not recommended)

Upgrade to ALL to 12.5

Move to Win 2016 or newer, or keep 2012 aslong as it isupported.

Mixed configurations, like 11.0.1 and 12.5 will not work, since you will have different database schemes.

regards

 

View solution in original post