cancel
Showing results for 
Search instead for 
Did you mean: 

EV Version mix up - which is correct

Hello All,

 

I'm starting on a project to upgrade an EV8 installation to EV11. Before I start in earnest on the live setup I have been given a test domain to play with, this was the original system that someone else installed many many moons past.

The first thing I did was check the version currently installed, and this is where my first point of confusion started. Can anyone help me work out which version is installed please.

In the EV console Help - About EV it tells me I have version 9.0.5.1067

In Control Panel - Add/Remove software - it tells me I have version 9.0.5.1067

The executables in the Program Files folder again show :

EVPM.exe = 9.0.5.1067

DTrace.exe = 9.0.5.1067

 

So it looks very much like I am looking at 9.0.5.1067

However the Registry key : [HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Install] "Version" shows 8.0.5.1048 for Version and Full Version.

 

Which is correct? Has anyone seen a version mismatch like this before? I was intending to upgrade this to version 9 but most of the information I can see tells me that I am probably already on version 9.0.5 other than the registry which tells me it is version 8 which is what I was expecting.

Which is correct and any ideas on how this happened?

thanks muchly,

 

1 Solution

Accepted Solutions
Accepted Solution!

Thanks Ben, thats useful

Thanks Ben, thats useful information, my problem is that I am supposed to use this environment to test the upgrade from 8 to 9 and base the upgrade of the live system on this. Basically have a practice attempt before touching the live stuff.

However as someone appears to have already had a crack at this I no longer have a test 8 system to upgrade and mess around with.

Management want this step to occur before they are confident enough to sign off the upgrade. So I am back to having to install 8 and pretty much start again - I can find no information about going backwards 9 to 8 and I presume this is because :

A. It is crazy.

B. There would be all manner of changes to the database schema which would be tricky to revert without a lot of work.

So it will be a weekend of installing and configuring, then do the upgrade and demonstrate that yes indeed it does work and finally sometime next week move on to the next stage and see what problems arise at that point.

Thanks all for your help.

 

 

View solution in original post

4 Replies

That is a bit strange.  What

That is a bit strange.  What is the SchemaVersion in SQL?

 

 http://www.symantec.com/docs/TECH70211

Problem

Below is a listing of the versions for Enterprise Vault (EV).   After verification of the binaries on the EV server, it is imperative that the schema version of the VaultDirectory and Vault Store databases both match appropriately. Any differences will result in loss of functionality within the product.

Cause

It is crucial that component versions are at the same EV product/schema version across all EV/SQL servers.  A mismatch could have occurred because of a partial or failed upgrade. See the installation Guide or Upgrade Documents to assist with confirming a successful upgrade or new installation.

Solution

The EV Directory Database Schema Version can be found by running the following SQL query:

USE EnterpriseVaultDirectory
SELECT SchemaVersion
FROM DirectoryEntry
 


The EV VaultStore Database Schema Version can be found by running the following SQL query:

USE EnterpriseVaultDirectory
SELECT SchemaVersion
FROM VaultStoreEntry

The EV Binaries Version can be found in the registry:

[HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Install] 
"Version"

 

On a 64bit OS everything is under a WOW6432Node key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Install]
"Version"  

 


 Enterprise Vault Versions Information:

 

EV Product Version
EV Binary Version
EV Directory Database Version
EV Vault Store Database Version
EV Fingerprint Database Version
 6.0 Base
 6.0.0-7400
 6.0.2.2
 6.0 Base
 
 6.0 SP1
 6.0-RG7637
 6.14.0.2
 6.4.2.3
 
 6.0 SP2
 6.0-RG7791
 6.22.4.3
 6.11.2.3
 
 6.0 SP3
 6.0-RG8000
 6.27.0.3
 6.11.3.3
 
 6.0 SP4
 6.0-RG8502
 6.27.2.3
 6.11.4.3
 
  6.0 SP5
 6.0-RG8644
 6.27.2.3
 6.12.0.3
 
 6.0 SP6
 6.0-RG8806
 6.27.2.3
 6.12.0.3
 
 7.0 Base
 7.0-RG1394
 7.50.2.14
 7.5.1.4
 
 7.0 SP 1
 7.0-RG2002
 7.50.7.14
 7.6.0.6
 
 7.0 SP 2
 7.0-RG2133
 7.50.7.14
 7.6.1.6
 
 7.0 SP 3
 7.0-RG2513
 7.50.8.14
 7.7.0.6
 
 7.0 SP 4
 7.0-RG2730
 7.50.8.14
 7.7.0.6
 
 7.0 SP 5
 7.0-RG3001
 7.50.10.14
 7.7.0.6
 
 2007 Base
 7.5-RG1250
 7.103.1.15
 7.58.12.6
 
 2007 SP1
 7.5-RG1397
 7.104.8.15
 7.60.0.6
 
 2007 SP2
 7.5-RG1862
 7.104.8.15
 7.60.0.6
 
 2007 SP3
 7.5-RG2138
 7.104.11.15
 7.60.0.6
 
 2007 SP4
 7.5-RG2534
 7.104.14.15
 7.70.2.6
 
 2007 SP5
 7.5-RG2635
 7.105.16.15
 7.71.4.6
 
 2007 SP6
 7.5-RG2840
 7.105.20.15
 7.72.1.7
 
 8.0 Base
 8.0-RG1405
 8.49.5.23
 8.24.7.9
 
 8.0 SP1
 8.0-RG1560
 8.54.7.24
 8.28.1.10
 
 8.0 SP2
 8.0.2.RG1693
 8.69.9.26
 8.30.6.11
 
 8.0 SP3
 8.0.3.1845
 8.81.1.29
 8.34.2.13
 
 8.0 SP4
 8.0.4.1991
 8.89.1.29
 8.37.0.14
 
 8.0 SP5
 8.0.5.1048
 8.94.0.29
 8.38.3.14
 
 9.0 Base
 9.0.0.1193
 9.24.11.39
 9.11.4.22
 
 9.0.1
 9.0.1.1073
 9.28.2.42
 9.13.1.24
 
 9.0.2
 9.0.2.1061
 9.29.3.43
 9.13.1.24
 
 9.0.3
 9.0.3.1164
 9.36.1.45
 9.13.9.24
 
 9.0.4
 9.0.4.1097
 9.43.3.45
 9.16.1.25
 
 9.0.5
 9.0.5.1067
 9.43.10.45
 9.16.6.25
9.3.6.2
 10.0 Base
 10.0.0.1307
 10.58.16.124
 10.14.10.25
 
 10.0.1
 10.0.1.1171
 10.69.9.126
 10.14.25.25
9.3.7.2
 10.0.2
 10.0.2.1112
 10.88.16.128
 10.18.6.26
9.3.8.2
 10.0.3
 10.0.3.1090
 10.102.3.134
 10.20.9.29
9.3.12.2
10.0.4
 10.0.4.1189
 10.125.5.137.0
 10.33.5.37.0
9.5.0.2.0
11.0 Base 11.0.0.1351 11.30.8.154.0 11.19.0.43.0 9.5.3.2.0
11.0.1 11.0.1.3474 11.48.0.160.0 11.32.9.45.0 9.10.4.4.0

 

 


Beginning with EV 10.0.4, cumulative hot fix (CHF) installations are implemented using a CHF Installer in the form of a "setup.exe" file.  Each CHF will have its own version information and may or may not update the schema versions of the EnterpriseVaultDirectory, Vault Store and / or Fingerprint databases.  The following table presents the versions of these entities after the CHF installation.


Note: The CHF Version can be found in the registry of the EV server, replacing the # with the CHF number (i.e., CHF1) at:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Install\Hotfixes\10.0.4\CHF#]
"Version"

CHF Product Version
CHF Binary Version
EV Directory Database Version
EV Vault Store Database Version
EV Fingerprint Database Version
11.0.1CHF2 11.0.1.3573 11.48.0.160.4 11.32.9.45.3 9.10.4.4.0
11.0.1CHF1 11.0.1.3527 11.48.0.160.1 11.32.9.45.1 9.10.4.4.0
11.0.0CHF1
11.0.0.1444 11.30.87.154.0 11.19.43.1

9.5.3.2.0

11.0.0CHF2 11.0.0.1470 11.30.87.154.1 11.19.43.1 9.5.3.2.0
11.0.0CHF3 11.0.0.1488 11.30.8.154.1 11.19.43.1 9.5.3.2.0
10.0.4CHF1
10.0.4.1293 10.125.5.137.0 10.33.5.37.0 9.5.0.2.0
10.0.4CHF2
10.0.4.1333 10.125.5.137.2 10.33.5.37.1 9.5.0.2.0
10.0.4CHF3
10.0.4.1354 10.125.5.137.2 10.33.5.37.1 9.5.0.2.0

 

Note:  This is only applicable to the EV Server and not applicable for any Accelerator or associated EV products.  For version information for Compliance Accelerator or Discovery Accelerator, see TECH210647 in the Related Documents section below.


 

https://www.linkedin.com/in/awsterling/

Thanks for the link Tony. The

Thanks for the link Tony. The versions reported by SQL are  :

9.16.6.25 = schema vault store entry

9.43.10.45 = schema directory entry

 

So everything other than the Windows registry are showing version 9.0.5

 

This is most odd. If someone were to have run the install for 9 over an existing 8 installation but didn't use the service account, or had an account without the required privileges then I am guessing they might be able to install the binaries but not update the registry - this is just a guess, but I have no other theory to explain the mismatch.

 

Anyway, the long and short of it is that I will have to rebuild the test environment in order to start testing the upgrades. Not really what I was planning on doing this weekend - but at least I can get on with it rather than trying to understand this version mismatch mess.

 

Cheers all.

There was a problem

There was a problem previously where if EV was in a Cluster, after an upgrade (or during) it would pull the previous version from the registry on the other node, this could be the issue.

 

Even if it isn't a cluster, or has never been one, I wouldnt worry too much about the registry value, it is easily changed and has little operational effect on EV, I have had a lab up and running on 10.0.0 with the registry marked as 11.0.1 for the last month with no ill side effects at all.

 

Go by the File versions and VAC reported version, don't worry about reinstalling or creating a new environment, you will be wasting your time, just change the value in the registry if it is really bothering you.

 

Accepted Solution!

Thanks Ben, thats useful

Thanks Ben, thats useful information, my problem is that I am supposed to use this environment to test the upgrade from 8 to 9 and base the upgrade of the live system on this. Basically have a practice attempt before touching the live stuff.

However as someone appears to have already had a crack at this I no longer have a test 8 system to upgrade and mess around with.

Management want this step to occur before they are confident enough to sign off the upgrade. So I am back to having to install 8 and pretty much start again - I can find no information about going backwards 9 to 8 and I presume this is because :

A. It is crazy.

B. There would be all manner of changes to the database schema which would be tricky to revert without a lot of work.

So it will be a weekend of installing and configuring, then do the upgrade and demonstrate that yes indeed it does work and finally sometime next week move on to the next stage and see what problems arise at that point.

Thanks all for your help.

 

 

View solution in original post