cancel
Showing results for 
Search instead for 
Did you mean: 

EV11 Journal Search\Restore

EVGarrison
Level 5

Hi all,

Not sure ill get a solution to this one but i feel it’s worth talking about and I’m sure others find themselves in the same boat as me.

Since they brought in EV11 the journal Restore process is a complete PITA.

Before 11 you could search the journal, Add certain items of your choice to a basket, keep searching and adding and then when ready restore all of those items to a mailbox of your choice. Making it very quick and easy to cherry pick the items or many hundreds of items you need to restore.

Now its all gone, you can search which work well, but getting those items back to a mailbox is ridiculous, if you're talking about say 500 hundred items, its almost impossible, the results page has to keep loading in more items as you get lower down the page and as you keep going down to highlight more it seems to have a limit as to how many items it will display, so you lose the high items you had higlighted, why isnt there a "highlight all and restore"!! So are you supposed to go down the list highlighting the ones you want, then restore those - being careful to remember how far you get before moving on to the lower ones where it has to load them in??

Then there is this backward step of actually restoring, now all the option i have from the journal is Export to Zip, why can’t i select a destination mailbox? Why isn’t there a "Restore all results" option at least???

Can anyone shed some light on this backwards step?

Many Thanks

 

1 ACCEPTED SOLUTION

Accepted Solutions

GertjanA
Level 6
Partner    VIP    Accredited Certified

Hi,

If you are licensed for Journal Archiving you are licensed for DA too (journal license to be used when asked for by DA install)

It is indeed a seperate install. The install is pretty simple. Once installed, you will have 1 configuration database, and one database per 'customer' (minimum is one).

If you run many large and/or complex queries, it might be best to install DA on a seperate server (can be a VM). If you run relatively simple queries, and your EV servers are not overloaded during the day, you can install on an EV-server. Installing on seperate server requires also the EV API to be installed (included in install-kit). when installing on EV server, no need to do that.

There is an initial configuration via a webpage. Once configured, you use the DA-client to do the rest (from any workstation). As long as the user starting the client is in the DA setup, he can connect without issues.

Be advised to include it in any documentation you have in regards to upgrading. DA needs to be done first, then EV itself.

Regards. Gertjan

View solution in original post

11 REPLIES 11

Rob_Wilcox1
Moderator
Moderator
Partner    VIP   

Have you investigated discovery accelerator?

Working for cloudficient.com

AndrewB
Moderator
Moderator
Partner    VIP    Accredited

rob - even with DA you're not going to restore it back to a mailbox in the end are you? 

garrison - what are you doing this for? legal purpose? user error remediation instead of the exchange team restoring from backup?

EVGarrison
Level 5

Hi Gents,

Its for FOI requests, we often get given a criteria of emails to get back that could  go back over a number of year or just a few months. Either way it could lots of items, Version 10 and previous did this perfectly for us.

Any suggestions?

GertjanA
Level 6
Partner    VIP    Accredited Certified

Hi EVG,

Wether or not the way you used EV10 search to get the items is valid, and supported, I am not going to answer.

What I do know is getting items from a journal-archive using a search, and then exporting them should really be done using Discovery Accelerator.

Using this allows you to specifically locate items, and export those to a PST file. That PST file can then be imported in a mailbox, or handed to a user.

the Export to Zip is a setting in the search policy. You could play around with it, because you can also select PST and even NSF (if you have Domino).

Regards. Gertjan

EVGarrison
Level 5

Ok,

We dont have DA installed, I think we are licensed for it. Ill add that to my growing list of things to look at.

Its a seperate install i presume, not a complex process to get up and running i hope?#

Thanks

GertjanA
Level 6
Partner    VIP    Accredited Certified

Hi,

If you are licensed for Journal Archiving you are licensed for DA too (journal license to be used when asked for by DA install)

It is indeed a seperate install. The install is pretty simple. Once installed, you will have 1 configuration database, and one database per 'customer' (minimum is one).

If you run many large and/or complex queries, it might be best to install DA on a seperate server (can be a VM). If you run relatively simple queries, and your EV servers are not overloaded during the day, you can install on an EV-server. Installing on seperate server requires also the EV API to be installed (included in install-kit). when installing on EV server, no need to do that.

There is an initial configuration via a webpage. Once configured, you use the DA-client to do the rest (from any workstation). As long as the user starting the client is in the DA setup, he can connect without issues.

Be advised to include it in any documentation you have in regards to upgrading. DA needs to be done first, then EV itself.

Regards. Gertjan

View solution in original post

EVGarrison
Level 5

Hi Gertjan, thanks for your advice.

I have now installed DA, however after installing the client on a machine i point it to the EV server and get "There are no instances available"

Ive gona through and setup what was needed on the localhost/evbaadmin page and restarted the service.

Im missing somethign simple i think, any ideas?

Cheers

GertjanA
Level 6
Partner    VIP    Accredited Certified

Hi EVG,

Remark: Make sure DA is on the same level EV is (EV11.0.1 CHF4 means DA needs 11.0.1 CHF4)

in the EVBAAdmin webpage, you need to create a customer. what you have done now is basically installing the software.

Open the webpage (using the VSA), rightclick the servername, New Customer

You should be able to use the SQL locations where you have the EV-databases on. (make sure to add the new databases to your maintenanceplans/backup in SQL). Make sure to read properly what is asked, it sometimes is  a little confusing.

When you have the customer database, you should be able to connect. If that fails, try installing the client on the DA server, and connect from there. Then verify roles and permissions etc. You might not (yet) have access to the DA.

GJ.

 

 

Regards. Gertjan

AndrewB
Moderator
Moderator
Partner    VIP    Accredited

install the DA client on the DA server and see if it works from there. if it does then the rest is basic stuff like network, permissions, firewall, security, user, etc.

EVGarrison
Level 5

Ok a new day and progress, ive not done anything but today when i created a new customer it worked, it appeared in the evbaadmin page straight away.

 

Now the client finds the instance but i get "the instance 'CustomerName' is currently unavailable; an administrator must update it before clients can connect."

 

In the Current status section of the Customer page its says Version 6.0 revision 0

State : update failed

Customers tasks : Stopped

Info: ExecuteNonQuery requires an open and available Connection. The connection's current state is closed.

 

Have restarted the service a few times.

Also to confirm - both EV and DA are on CH4

EVGarrison
Level 5

Ive got this working, thanks for your help guys.

 

Cheers