cancel
Showing results for 
Search instead for 
Did you mean: 

EV12.0.3 EVDatabaseUpgrader script fails on Audit DB

Fremont
Level 5
Partner Accredited

Getting the following when doing 12.03. upgrade from 12.0.

"EnterpriseVaultAudit The database needs to be upgraded from '3.0.0.0.0' to '3.2.0.1.0'.
Error EnterpriseVaultAudit Database upgrade failed because of incompatible database versions.

We upgraded from 11.0.1 to 12.0 using Server Setting Migration wizard successfully. One thing odd that happened at the time was when I tried to use the EVDatabaseUpgrader script I was getting SQL databases locked.  So I tried starting the Directory service then realized SQL Management Studio was lociing SQL.  Closing it let the Directory service start and I noticed it also updated the Directory db successfully.  Which means the old method of starting services one by one still works.  So I started the Storage service and upgraded the VS db's successfully and all services and tasks started fine.  Verified server was archiving with no errors.

Now that I installed 12.0.3 the EVDatabaseUpgrader script is failing with above error.  I suspected the audit db did not get upgraded.  So I ran the 2 audit upgrade scripts manually: Audit_schema_Upgrade.sql and AuditDBRoles.sql.  However still EVDatabaseUpgrader was failing with same error.

I talked to Veritas Support and apparently other customers had seen this too.  The solution was to go to open the Audit table in the EnterpriseVaultAudit db and manually change the value for SchemaVersion column from 3.0.0.0.0 to 3.2.1.0. 

After that reran EVDatabaseUpgrader and all db's upgraded successfully.

FYI for anyone getting this.

1 REPLY 1

GertjanA
Level 6
Partner    VIP    Accredited Certified

Thanks for letting us know. Might come in handy!

Regards. Gertjan