cancel
Showing results for 
Search instead for 
Did you mean: 

Enterprise Vault 8 and Event IDs 6796 and 13360

Ed_Laukiavich
Level 4
Since our upgrade to Enterprise Vault 8 I have been recieving event ID 6796 followed by 13360 in the Enterprise Vault Event log. The reference to the vault store in 13360 is our vaultstore for email, we are currenly able to retrieve and recall items in email. Can anyone shed some light on these events; what they mean, what is causing them, what should I bee looking at for resolution.


Event Type: Error
Event Source: Enterprise Vault
Event Category: Storage Online
Event ID: 6796
Date: 5/27/2009
Time: 8:58:11 AM
User: N/A
Computer: PEI-SRV3
Description:
A COM exception has been raised.
<0x80040e14>
Internal reference
.\VaultStoreDB.cpp (CVaultStoreDB::GetJournalEntriesForIncrSyncRecords) [lines {12511,12522,12525,12526,12527,12528,12529,12530,12531,12538}] built Nov 27 20:39:34 2008

An exception is raised when a process encounters an unexpected fault.

For more information, see Help and Support Center at http://evevent.symantec.com/rosetta/showevent.asp



Event Type: Error
Event Source: Enterprise Vault
Event Category: Storage Online
Event ID: 13360
Date: 5/27/2009
Time: 8:58:11 AM
User: N/A
Computer: PEI-SRV3
Description:
An error was detected while accessing the Vault Database 'EVEmailVaultStore' (Internal reference: .\ADODataAccess.cpp (CADODataAccess::ExecuteSQLCommand) [lines {1379,1381,1396,1419}] built Nov 27 19:47:12 2008):

Description:
Cannot resolve the collation conflict between "SQL_Latin1_General_CP1_CI_AS" and "SQL_1xCompat_CP850_CI_AS" in the equal to operation.

SQL Command:
usps_GetJournalEntriesForIncrSync

Additional Microsoft supplied information:

Source: Microsoft OLE DB Provider for SQL Server
Number: 0x80040e14
SQL State: 42000
Native Error: 00000468
HRESULT 0x80040e14

8 REPLIES 8

TRALSH
Level 4
Employee

Ed_Laukiavich
Level 4
I will run these again on the SQL server however I did this prior to upgrading from EV7.0 SP2 to EV 2007 SP5 since I had collation failures in the deployment scanner. Fixed all of the collations, ran the scanner again clean and successfully upgraded to EV 2007 SP5. Ran for 1+ month with no errors.

Ran the deplayment scanner again for EV 8, ran clean w/o collation issues. Successfully upgraded to EV on on 5/17 these errors did not start showing until 5/19

Ed_Laukiavich
Level 4
The collation check scripts run clean on all the EV Databases.

The master database for the SQL server is SQL_1xCompat_CP850_CI_AS and all of the EV databases are SQL_Latin1_General_CP1_CI_AS. The log message appears to be pointing to a conflict betwwen the master default and this one EV store DB. Any ideas on this?


MichelZ
Level 6
Partner Accredited Certified
Sorry to say, but I think this is a case for SYMC support.

Cheers

cloudficient - EV Migration, creators of EVComplete.

Korbyn
Level 5
Partner Accredited
Ed.  What did Sym have you do?  Change the EV databases to equal the Master, or change the Master to equal the EV database languages?

I'm guessing here, but did you by any change move from SQL 2000 to SQL 2005?  or was someone screwing around with your Master database default lanugage?

K.

Hermann2009
Level 4

Dear all,
Sorry to reactivate the old case .
Because of certificate troubles i have to reinstall my SQL 2005 Server for my Vault 8 SP3.
After reinstall and DB Import frequently i got the event error 6796 and 13360.

So i did the DB check on my MSSQL 2005 Server, with the following result

SELECT DATABASEPROPERTYEX(DB_name(), 'Collation')  collation;

Master

SQL_Latin1_General_CP1_CI_AS

EnterpriseVaultDirectory

Latin1_General_CI_AS

EnterpriseVaultMonitoring

Latin1_General_CI_AS

EVVSExchangeVaultStore_2

Latin1_General_CI_AS

EVVSGVIE_2_2

Latin1_General_CI_AS

EVVSGVIEIT_1_1

Latin1_General_CI_AS

EVVSJournalVaultStore_3

Latin1_General_CI_AS

EVVSVIEIT_1

Latin1_General_CI_AS

 
Following the SQL Script and there i have a question:

in the definition section the SETVAR desired_collation ...

-- please do not use brackets for database name, it should be Northwind not [Northwind]. Names with blanks are not allowed.
:SETVAR destdb EnterpriseVaultDirectory
:SETVAR desired_collation Cyrillic_General_CI_AS
:SETVAR script_only 1

is Cyrillic_General_CI_AS
i want to change my Latin1_General_CI_AS (???)

And which DB i have to change? 
The Master or all eVault DB's?

Any one who fixed this problem successful?

 

Hermann2009
Level 4
Dear all
the easierst way is:
- backup you sql server
- stop eVault Service
- stop SQL Service
- uninstall SQL Server Service
- reinstall SQL Server (select the correct SQL language! -> the eVault DB language)
- reinstall SQL SP
- attach the existing DB files (mmc -> run as administrator ...)
- restart the eVault Service

and everything is fine!

Korbyn
Level 5
Partner Accredited
Simple...'er

There's an article for resetting the default languange of the EV databases.  Pretty much follow it except your changing the langage back to what it was in the beginning for EV, which is now what SQL2005 master is now.