cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

ISA 2006 SP1 + FBA

Hi Everyone,
In our environment we're using Exchange 2007 SP1 & ISA 2006 SP1 & Enterprise Vault SP4 .
Not sure if anyone has come across this problem before?
When using IE 6/7/8 lite client for OWA, archive explorer displays 'AE requires internet Explorer 6 or later'. This error also appears when using Firefox 2.x/3.x

I have spoke with a Symantec Engineer, and believes that this is a MS bug. Before I go reporting this, just curious if someone has already spoken with Microsoft?

' ISA forms based authentication for OWA may have stripped the IE version from the user agent header
  ' In this case, we may have the user agent in the query string parameter "UA"

From Symantec backline engineers investigation, he found this:-
 
excerpt from script
' Checks the IE Version
' ---
Sub CheckIEVersion()
 dim sUserAgent
 dim fVersion
 dim ErrorMessage
 fVersion = 0.0
 
On error resume next
 
 sUserAgent = Request.ServerVariables("HTTP_USER_AGENT")
 fVersion = GetIEVersionFromUserAgent(sUserAgent)
 if fVersion = -1 then
  ' ISA forms based authentication for OWA may have stripped the IE version from the user agent header
  ' In this case, we may have the user agent in the query string parameter "UA"
  fVersion = GetIEVersionFromUserAgent(Request.QueryString("UA"))
 end if
 
#############################################################
 
This is a microsoft issue, so you would need to find out from them, why this is broken.
The clue here is that it has something to do with forms based authentication.

Any help is much appreciated,
Regards,
-S