Highlighted

Journaling Task - System Mailbox not found!!


EV 8.0 SP3 on Win2K3 with Exchange 2003


Under Target, I added Exchange Server.

I am trying to add a new journal task, while running the wizard, it is not finding the
system mailbox.

System mailbox exists with "Send As" and "Recieve As" permissions on the same exchange server.

EV Service account also exists with all the neccessary permissions mentioned in the Install and Configure document.

Your help is greatly appreciated.

Thanks
Rajesh

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

also, did you just create the

also, did you just create the system mailbox?

if yes there is this from the docs.

After you create the Enterprise Vault system mailbox, it may take some time for the mailbox to be available. The amount of time depends on configuration options in Exchange System Manager. The mailbox must be available before you add an Exchange Server archiving task.

If required, you can make the mailbox available sooner by manually forcing an update of Exchange Server 2000 or 2003. This is not required on Exchange Server 2007.

To force a manual update of the Exchange Server (2000 or 2003)

Click Start > Programs > Microsoft Exchange > System Manager.

In the left-hand pane, double-click the Recipients container.

Click Recipient Update Services.

In the right-hand pane, right-click the Recipient Update Service for the domain that contains the Exchange Server computer for which you are adding an archiving task.

Click Update Now.


For the best O365 Reporting Solution click here Radar-Reporting

View solution in original post

9 Replies
Highlighted

Is the system mailbox

Is the system mailbox hidden?
Can you create an outlook profile for the system mailbox and open it successfully?
For the best O365 Reporting Solution click here Radar-Reporting
Highlighted
Accepted Solution!

also, did you just create the

also, did you just create the system mailbox?

if yes there is this from the docs.

After you create the Enterprise Vault system mailbox, it may take some time for the mailbox to be available. The amount of time depends on configuration options in Exchange System Manager. The mailbox must be available before you add an Exchange Server archiving task.

If required, you can make the mailbox available sooner by manually forcing an update of Exchange Server 2000 or 2003. This is not required on Exchange Server 2007.

To force a manual update of the Exchange Server (2000 or 2003)

Click Start > Programs > Microsoft Exchange > System Manager.

In the left-hand pane, double-click the Recipients container.

Click Recipient Update Services.

In the right-hand pane, right-click the Recipient Update Service for the domain that contains the Exchange Server computer for which you are adding an archiving task.

Click Update Now.


For the best O365 Reporting Solution click here Radar-Reporting

View solution in original post

Highlighted

Hi Sorry for the late

Hi

Sorry for the late reply..

Mailbox is not Hidden.

Yes, i can create outlook profile for the system mailbox and log in successfully, can send and recieve mail.

Thanks
Rajesh




Highlighted

Is the system mailbox

Is the system mailbox definitely on the same exchange server as the journal mailbox?
https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

Yes, the system mailbox and

Yes, the system mailbox and journal mailbox reside on the same server.
Highlighted

ok so kjust to get this

ok so kjust to get this straight
you're going through setting up a new exchange server target, it then asks if you want to create the journal task and the archiving task
you click next and then it says "Choose a system mailbox" and you hit browse and when that list comes up, it has

"Select a mailbox"
! NONE FOUND"

is that correct? so you don't even see the list of mailboxes including the journal?
are the other mailboxes on this exchange server other than the journal and ev system mailbox?

and when we say system mailbox, you're not refering to the Exchange System Mailbox are you?
i.e.  SystemMailbox{76567BBC-93FF-413C-B2E1-0742A00FB5E3}

If thats the case, it has to be a regular mailbox along with an AD User (whether its enabled or not doesn't matter), and then use this mailbox for the purposes of being the EV system mailbox

so for instance you might call it EVSysMailbox-ExchSvrA

Also is this Exchange 2003 or 2007?
is it in the same domain as the Enterprise Vault server or a different one? you may need to specify a Global Catalog if the exchange server is in a seperate domain
https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

Please see the highlighted

Please see the highlighted answers.

ok so kjust to get this straight
you're going through setting up a new exchange server target, it then asks if you want to create the journal task and the archiving task
you click next and then it says "Choose a system mailbox" and you hit browse and when that list comes up, it has

"Select a mailbox"
! NONE FOUND"

is that correct? so you don't even see the list of mailboxes including the journal? Yes - I dont see any mailbox listed, says "none found"

are the other mailboxes on this exchange server other than the journal and ev system mailbox? Yes- There are other mailboxes on this server

and when we say system mailbox, you're not refering to the Exchange System Mailbox are you?
i.e.  SystemMailbox{76567BBC-93FF-413C-B2E1-0742A00FB5E3} - No, A seperate system mailbox created ( named - EV. ServerName)

If thats the case, it has to be a regular mailbox along with an AD User (whether its enabled or not doesn't matter), and then use this mailbox for the purposes of being the EV system mailbox - It is a regular mailbox which is NOT hidden, Account NOT disabled, can send and recieve emails from this mailbox.

so for instance you might call it EVSysMailbox-ExchSvrA

Also is this Exchange 2003 or 2007? Exchange 2003
is it in the same domain as the Enterprise Vault server or a different one? you may need to specify a Global Catalog if the exchange server is in a seperate domain - Same Domain

Highlighted

OK do the following for us 1.

OK do the following for us

1. Follow the wizard all the way through to Select System Mailbox (do not hit Browse yet)
2. Open a command prompt and cd \program files\enterprise vault
3. Type "Dtrace" and press Enter
4. Type "set mmc v" and press Enter
5. Type "Log C:\missingMailboxes.txt" and press Enter
6. Minimize the command prompt and go back to the Vault Admin Console
7. Hit the "Browse" button and wait for it to say no mailboxes found
8. Go back to the command prompt and type "exit"
9. Attach the MissingMailboxes.txt to this thread

In the text file you should see something similar to the following

(mmc) <808> EV:M Entering ListMailboxes(yourExchSrvr, , )
(mmc) <808> EV:M Entering Initialise()
(mmc) <808> EV:M Loaded netapi32.dll
(mmc) <808> EV:M Loaded activeds.dll
(mmc) <808> EV:M Leaving Initialise()
(mmc) <808> EV:M Exchange Server DN not specified, call FindExchServerDN().
(mmc) <808> EV:M Entering FindExchServerDN(), Search Base: , ExchServer: yourExchSrvr
(mmc) <808> EV:M Entering CExchange2000DirObj::GetADDomainController()
(mmc) <808> EV:M CExchange2000DirObj::GetADDomainController() - using Domain Name: DOMAIN.COM
(mmc) <808> EV:M CExchange2000DirObj::GetADDomainController() - DsGetDcName dwResult==[0]
(mmc) <808> EV:M CExchange2000DirObj::GetADDomainController() - returning | DC Name==[\\yourDCSrvr.domain.com],| Search Format==[GC://yourDCSrvr.domain.com],| GC Found==[True]
(mmc) <808> EV:M Bind to Search Base: GC://yourDCSrvr.domain.com
(mmc) <808> EV:M Execute search
(mmc) <808> EV:M Exchange Server Found. DN: CN=yourExchSrvr,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=your Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com, LegacyDN: /o=your Exchange/ou=First Administrative Group/cn=Configuration/cn=Servers/cn=yourExchSrvr
(mmc) <808> EV:M Leaving FindExchServerDN with status: Success
(mmc) <808> EV:M Using Exchange Server DN: CN=yourExchSrvr,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=your Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com
(mmc) <808> EV:M Setup required attributes (FF!)
(mmc) <808> EV:M Bind to Exchange Server: GC://yourDCSrvr.domain.com/CN=yourExchSrvr,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=your Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com
(mmc) <808> EV:M Search for private MDBs: (&(objectCategory=msExchPrivateMDB)(homeMDBBL=*))
(mmc) <808> EV:M Found an MDB: GC://yourDCSrvr.domain.com/CN=Mailbox Store1,CN=your Storage Group,CN=InformationStore,CN=yourExchSrvr,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=your Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com, enumerating mailboxes...
(mmc) <808> EV:M Entering ListMailboxesInMailboxStore(GC://yourDCSrvr.domain.com/CN=Mailbox Store1,CN=your Storage Group,CN=InformationStore,CN=yourExchSrvr,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=your Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com)
(mmc) <808> EV:M Build attribute list
(mmc) <808> EV:M Bind to MDB: GC://yourDCSrvr.domain.com/CN=Mailbox Store1,CN=your Storage Group,CN=InformationStore,CN=yourExchSrvr,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=your Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com
(mmc) <808> EV:M Getting 500 results at a time from: GC://yourDCSrvr.domain.com/CN=Mailbox Store1,CN=your Storage Group,CN=InformationStore,CN=yourExchSrvr,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=your Exchange,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com
(mmc) <808> EV:M Listing mailboxes in range: homeMDBBL;Range=0-499
(mmc) <808> EV:M   Processing result row 1 of 1...
(mmc) <808> EV:M     Examining mailbox 1 of 11 in current row - DN: CN=Mailbox1,OU=your OU,DC=domain,DC=com
(mmc) <808> EV:M       Binding to: GC://yourDCSrvr.domain.com/CN=Mailbox1,OU=your OU,DC=domain,DC=com
(mmc) <808> EV:M       Entering ProcessObjectAttributes()
(mmc) <808> EV:M         Found distinguishedName: CN=Mailbox1,OU=your OU,DC=domain,DC=com
(mmc) <808> EV:M         Found displayName: Mailbox1
(mmc) <808> EV:M         Found mailNickname: Mailbox1
(mmc) <808> EV:M       Leaving ProcessObjectAttributes()



https://www.linkedin.com/in/alex-allen-turl-07370146
Highlighted

Thank You Guys!!! Before

Thank You Guys!!!

Before running DTrace, i did the following...

- Added Vault Service account to the provisioning group.
- Added a Provisioning Task
- Added Vault service account to the security tab of that particular mailbox server and checked all - ( This is in installation guide - page 64)

Allowed 1 hour for the replication.

Bingo!!, can see all the mailboxes now.

Thanks Tony and Jesuswept2, appreciate your help.

Thanks
Rajesh