Highlighted

Move archive in a stuck state after original move failed

I am in the process of moving archives from one server to two other servers in an EV 10.0.4 environment. Generally the process is working fine - there are some failures but rerunning them usually sorts that out, however I have an issue with one partuicular archive which is stuck on step 2 of 5 and is not moving beyond that stage.

The process would normally be that an archive would be moved from server1 to either server2 or server3, however after doing some digging into this issue, I have discovered that the affected archive was originally moved from server1 to server3, but that process did not complete successfully and it appears that one of my colleagues then attempted to move the archive from server3 to server2 which I presume has thrown a spanner into the works with it.

I have checked the log files and on server3 there is mention that the shortcut processing for a previous movearchive is not complete so the job enters a sleep state but the log on server1 does contain the following:

 

04/03/2015 18:01:08 Error occurred while trying to synchronize the destination mailbox. Exception: KVS.EnterpriseVault.MoveArchiveTask.StampExchMbxFolderIDsException: Failed to synchronize the destination mailbox's archive folder IDs. Reason: Failed to synchronize mailbox for move archive - HRESULT [0xc0040ce6] ---> System.Runtime.InteropServices.COMException (0xC0040CE6): Failed to synchronize mailbox for move archive - HRESULT [0xc0040ce6]
   at KVS.EnterpriseVault.ExchangePolicySync.AgentSyncHelper.SynchronizeMailboxForMoveArchive(String strLegacyMbxDN, String strAdMbxDN, String strMsgStoreDN)
   at KVS.EnterpriseVault.MoveArchiveTask.ShortcutUpdatePhase.SynchMbxToStampArchiveFolderIds(String legacyMbxDN, Int64 exchServerIdentity)
   --- End of inner exception stack trace ---
   at KVS.EnterpriseVault.MoveArchiveTask.ShortcutUpdatePhase.SynchMbxToStampArchiveFolderIds(String legacyMbxDN, Int64 exchServerIdentity)
   at KVS.EnterpriseVault.MoveArchiveTask.ShortcutUpdatePhase.SynchronizeMailbox(String computerName). Enterprise Vault will ignore this error.

04/03/2015 18:01:08 Error occurred while trying to synchronize the destination mailbox. Exception: KVS.EnterpriseVault.MoveArchiveTask.StampExchMbxFolderIDsException: Failed to synchronize the destination mailbox's archive folder IDs. Reason: Failed to synchronize mailbox for move archive - HRESULT [0xc0040ce6] ---> System.Runtime.InteropServices.COMException (0xC0040CE6): Failed to synchronize mailbox for move archive - HRESULT [0xc0040ce6]
   at KVS.EnterpriseVault.ExchangePolicySync.AgentSyncHelper.SynchronizeMailboxForMoveArchive(String strLegacyMbxDN, String strAdMbxDN, String strMsgStoreDN)
   at KVS.EnterpriseVault.MoveArchiveTask.ShortcutUpdatePhase.SynchMbxToStampArchiveFolderIds(String legacyMbxDN, Int64 exchServerIdentity)
   --- End of inner exception stack trace ---
   at KVS.EnterpriseVault.MoveArchiveTask.ShortcutUpdatePhase.SynchMbxToStampArchiveFolderIds(String legacyMbxDN, Int64 exchServerIdentity)
   at KVS.EnterpriseVault.MoveArchiveTask.ShortcutUpdatePhase.SynchronizeMailbox(String computerName). Enterprise Vault will ignore this error.

 

We has some issues with the storage and indexing services which have been rresolved and it appears that the failed items were retried for the affect archvie and these also failed due to the fact that the EV was not operational and that it appears that the processing of the archive has stopped completely as no further entries are logged for it.

The archive has not active account associated with it as I guess the user has left the company.

I cannot do anything to the current move operation as all the icons in the move archvie status window are greyed out.

Would it be possible to remove the two failed move attempts / archives on the two destination servers and retry the move operation?

 

Thank you.

 

 

 

 

2 Replies

Re: Move archive in a stuck state after original move failed

Hello,

I have a simular Issue.

Did you ever resolved this.

Thanks and regards,

Stefan

Re: Move archive in a stuck state after original move failed

Hi Stefan,

Can you open a new thread for this? Include EV version, and what you have done. People tend to ignore 'old' questions, and in this case, the original one is from 2015.

Regards. Gertjan