Need to prevent EV from adding new items

2nd go at posting this so appologies if there are 2 posts in a couple of minutes...

We have a requirement to stop adding any items to EV and stop removing them from Exchange mailboxes for the period of a migration. EV11 Exch 2010.

I changed the archive policy to be 999 days and to be sure disabled the archive task.

At first this looked good, but I have notcied the count of items in EV is still going up every day.

I had a look at the policies and found some options for Virtual Vault allowing users to add items through their Outlook client, so I have disabled them and run a sync, but the number is still going up.

The option in the Outlook client too is disabled to allow users to add / delete from EV. Desktop policy is only set to allow Search, Cancel and Help.

What have I missed? There must be some way these items are being added to the Vault.

Any way to find out where they come from.

Any help greatly appreciated.

Thanks - Slack

9 Replies

Re: Need to prevent EV from adding new items

Hi Slack,

Is the Store in vault option enabled on the policy?  

Have you set the vault stores into backup mode to stop items being added? 

Regards,

Patrick 

Re: Need to prevent EV from adding new items

Thanks for the quick reply.

Store in Vault is not enabled under the Desktop policy, that's the only place I see that option.

Backup mode has not been enabled, our backup software runs scripts that would unset this. I can make those changes if needed...

But, what would happen if EV is in backup mode and user are able to move an email in Outlook to their Virtual Vault / Vault Cache for example and the server is in backup mode? Would that just sit locally in their vault cache on their machine as it can't sync up to EV. Therefore the email would now be missing from Outlook and not in EV... this seems like a problem waiting to happen. Especially during a migration.

Backup mode may be the way to go, but I would need to understand the implications and gotchas before I do.

Thanks

Re: Need to prevent EV from adding new items

Hi,

When items are dragged to VV they should be full items and would remain there.

Within VV under Search Folders the item would remain in the To Archive folder until it is able to upload to EV. 

Thanks,

Patrick 

Re: Need to prevent EV from adding new items

For clarification, if you enabled backup mode and then a user dragged an item to the Virtual Vault, the item would be removed from the mailbox but not added to EV until the next synch, which would be after backup mode was cleared. Until then, the only copy of it would sit locally in the Vault Cache store. Leaving items in this location is not something we recommend, as they become vulnerable to a failure of the user's workstation.

You may have disabled the "Store in Vault" option on the Options tab of the Desktop Policy. This controls the ability of users to archive items manually using the Enterprise Vault toolbar on the Outlook Ribbon. However, it does not control whether users can drag items into Virtual Vault to archive them that way. That functionality is controlled by the following setting:

Desktop Policy > Advanced tab > List settings from Virtual Vault > Users can archive items

If you're looking to lock things down for a migration, you'd probably want to set all the "Users can..." options in that list to "No" for safety.

 

Additionally, I would not recommend disabling the Archiving Task. This will prevent users from restoring archived items to their mailboxes if they want. A couple easy ways to leave the task running but make sure it does not add any items to the Vault are:

1) Change the task's schedule to run "Never"

2) Set the task to run in report mode

Changing the required age in the Mailbox Policy will also work, but it might be tedious work depending on how many provisioning groups and policies you have. I would recommend against this just from an administrative effort perspective.

Hope that helps!

--Chris

Re: Need to prevent EV from adding new items

Hi Chris,

Good, your post is in line with my thoughts.

I was concerned about items getting stranded in Virtual Vault, seems this can happen so setting backup mode at this stage seems like a bad idea.

I had disabled the archiving task a long while back, as well as changing the archiving date from 45 days to 999 days and removing the schedule just to be sure! So, I am pretty confident this is not running and causing the problem. Also, we would be seeing a lot more email appear in EV.

I had already changed the Desktop policy to not let users "Store in Vault".

With regards to the following settings: Desktop Policy > Advanced tab > List settings from Virtual Vault > Users can archive items

I had set all of these "User Can" to NO the other day and run a sync, but I still have items appearing in EV. (they are still all set to NO).

This morning , we have already had a few items show up, which I can see from the usage.asp page.

I'm just not sure where these items can be coming from?!

 

Once I have disabled the "Users Can Archive items", should this stop them from being able to drag items out of their mailbox and in to the virtual vault?

If it should, then I can get a bunch of the users to test and see if that is still working, maybe some of them have not picked up the change to this policy for some reason?

That's the only thing I can think?!

Any ideas?

Thanks

 

Highlighted

Re: Need to prevent EV from adding new items

it might be there is some work left in MSMQ?

Following Chris's recommendation, if you set your archiving task to report mode, than restart them, then verify your MSMQ's on the EV server. As soon as that drops to 0, then nothing more should be archived.

 

Regards. Gertjan

Re: Need to prevent EV from adding new items

Will double check the queues in a bit thanks.

As it goes, it looks like the policy changes I made a few days ago have kicked in this morning for some users now. This is odd in itself as the changes were made days ago and I did a Sync and Provision for everyone.

Unfortunately, my changes have stopped users from being able to move any items back OUT of their Virtual Vault as well.

Is there a setting that should allow this? Stop adding anything new to VV but you can move stuff out?

I am guessing either:

Users Can Copy Items to another store

or

Users Can copy items within their archive

or maybe

Users can hard delete items.

Any idea?

We want to be in a state where users can move out anything stuck in their virtual vault, but are not able to add anything new to it.

The count on the items awaiting backup has not gone up since my 1st post this morning, so it looks like thepolicies were just not working before and have now kicked in. I assume doing sync / provision would be enough to activate these policies, is that not the case?

Thanks

Re: Need to prevent EV from adding new items

Still not sure which combination of settings I am looking for having looked at the Admin guide.

Users can copy items to another store:

Controls whether users can copy and move items from a Virtual Vault to another message store.

If users can copy or move items out of Virtual Vault and the content is available in Vault Cache, the items are retrieved from Vault Cache.

If the Vault Cache content strategy is Do not store any items in cache, the items are retrieved from the online archive. In this case, use the Virtual Vault advanced setting Max total size of contentless operations to control the maximum total size of view, copy, and move operations.

That doesn't mention if you need to allow "Users can hard delete items" for Move to work.

As this took a few days to go live for some reason, testing with the userbase will be awkward so I would like to get this right.

Anyone got any ideas?

I would like to block adding to Virtual Vault but let users move stuff out, back to their Exchange mailbox.

Thanks

Re: Need to prevent EV from adding new items

Well, this is working good enough now.

The only thing I can think is that even though we ran a sync and it showed completed, it must not have worked first time or for the first couple of days when I set this up.

Thanks for your help everyone.