Highlighted

SetEVExchangePermissions.ps1 Customization.

I'm doing some testing for an envronment where I need to selectively apply the SVA account permissions on a per server, per database basis.

I understand that I can specify per server with the -server switch when ran remotely, does anyone have any thoughts for how to do this on a per database level as well?

Are there any thoughts or customization of the script that can share?

Thanks in advance.

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Well, I'm not sure whether

Well, I'm not sure whether people can post here their own customisations .. I mean they can, as a guide.

 

From what I just scanned in the .ps1 file you'd be looking at making changes to :

 

function ProcessInstructions()

 

If that helps?

Working for Quadrotech-it.com

View solution in original post

3 Replies
Highlighted
Accepted Solution!

Well, I'm not sure whether

Well, I'm not sure whether people can post here their own customisations .. I mean they can, as a guide.

 

From what I just scanned in the .ps1 file you'd be looking at making changes to :

 

function ProcessInstructions()

 

If that helps?

Working for Quadrotech-it.com

View solution in original post

Highlighted

Dear Rob Wilcox Can you help

Dear Rob Wilcox Can you help me?

 

Actually I am on project of Enterprise Vault 10 Journaling for Exchange 2007 for the same as you know I just run the script SetEVExchangepermissionpolicy.ps1 and what happen after run this I got a complaint from customer that after run this script the VSA(Vault service Account) has the full permission on all the mailboxes and interesting thing is that these permissions applied to worldwide mailboxes .So is it possible that we only want to give these permissions on one site only not to whole organization do you guys have any idea about it?  if yes then please suggest me something.

Highlighted

Parveen, I'd suggest creating

Parveen, I'd suggest creating a new forum thread, if this doesn't immediately answer your questions ...

 

It should be granting send-as and receive-as..  not full control.  The step by step guide to permissions is in the EV Docs.  If you follow those you can set permissions manually.

Working for Quadrotech-it.com