Highlighted

Storage Service will not stay running

Hey all,

I'm running EV 12.3 on a Windows 2016 environment with SQL 2017 on W2016.

Having an issue enabling mailboxes, as the storage service won't create an archive for the user. Storage service no longer stays running and crashes when I start it. 

When the storage service starts and fails, the error produced is "Fingerprint database update failed for vault store group identity - '1'. "

SQL was uninstalled and reinstalled last week as there was an issue. Backups had been taken, but it looks like the FingerprintDatabase was not backedup, as it is not an option when trying to restore the db. 

 

EDIT: Forgot to mention, I did run the db upgrade utility and it errored out saying it was still using version 8.0.0.0.0 and not 9.x.

 

Any insight into how I can get archiving working again would be greatly appreciated. TY!

2 Replies

Re: Storage Service will not stay running

I advise to get someone on site to assist.

If you have all databases except the VSG DB, you really are in trouble.. From the sounds of it, the backups are not consistent.

This is not an issue the forummembers can assist you with.

It might be possible to use EVSVR to recreate it, but that probably runs for weeks. See Utilities guide. I advise to first get advise, then run the tool. Don't make things worse then they already are

Regards. Gertjan

Re: Storage Service will not stay running

Thanks Gertjan!

 

I should have mentioned this is for our lab development and training for EV. I'm the "expert" here in this case. Lesson learned. 

Appreciate the response!