Highlighted

Upgrade V11 CHF5 to 12.3 SQL Collation Warning

Hello,

we want to Update an customer to V12. The Deployment Scanner gives follwoing error.
EV11 is running great at the Moment:

At least one test for the SQL server collation has failed. SQL databases (shown below) contain entities with mixed collations. If they are Enterprise Vault databases then they will prevent a successful upgrade. Please go to http://www.veritas.com/docs/TECH55063 for more details. Any Idea what to do? i stopped the upgrade at the Moment

 
 123\EVAULT: Unmatched default SQL collation: Server: Latin1_General_CI_AS; EnterpriseVaultDirectory database: .
123\\EVAULT: Database: EnterpriseVaultDirectory - no mixed collations found.
123\\EVAULT: Unmatched default SQL collation: Server: Latin1_General_CI_AS; EnterpriseVaultMonitoring database: .
123\\EVAULT: Database: EnterpriseVaultMonitoring - no mixed collations found.
123\\EVAULT: Unmatched default SQL collation: Server: Latin1_General_CI_AS; EVVSGExchangeVSG_1_1 database: .
123\\EVAULT: Database: EVVSGExchangeVSG_1_1 - no mixed collations found.
123\\EVAULT: Unmatched default SQL collation: Server: Latin1_General_CI_AS; EVVSJournalVS_2 database: .
123\\EVAULT: Database: EVVSJournalVS_2 - no mixed collations found.
123\\EVAULT: Unmatched default SQL collation: Server: Latin1_General_CI_AS; EVVSMailboxVS_1 database: .
123\\EVAULT: Database: EVVSMailboxVS_1 - no mixed collations found.

2 Replies

Re: Upgrade V11 CHF5 to 12.3 SQL Collation Warning

Is it a shared SQL or dedicated to EV?

If it's dedicated then you can just change the default SQL collation settings to match ones of EV databases.

If it's a shared server you may need to look into either moving SQL databases to a SQL server where you can change collation settings without affecting other databases.

Re: Upgrade V11 CHF5 to 12.3 SQL Collation Warning

I've seen this before, and it is really confusing.

123\EVAULT: Unmatched default SQL collation: Server: Latin1_General_CI_AS; EnterpriseVaultDirectory database: .
123\\EVAULT: Database: EnterpriseVaultDirectory - no mixed collations found.

Note that you have the entry for the databases twice. one reports an issue, one is correct.

Make sure that if you run the Deployment Scanner, you only list the ACTIVE SQL server to be checked. As said, I have seen this earlier, attempted upgrade, worked like a charm :-)

Before upgrade however, make sure you have a good backup of all EV databases!

 

Regards. Gertjan