VOM missing disks

I'm having issues trying to determine the best place to look to determine the reasons why VOM is reporting different information to commands run at the command line.

 

E.G

[root@svctesu02 ~]# vxdisk list -o alldgs
DEVICE       TYPE            DISK         GROUP        STATUS
fj_dxm0_000a auto:cdsdisk    meth01-fs_dg01  meth01-fs_dg online
fj_dxm0_000b auto:cdsdisk    -            (meth02-fs_dg) online
fj_dxm0_000c auto:cdsdisk    -            (meth03-fs_dg) online
fj_dxm0_0006 auto:cdsdisk    -            (meth01-db_dg) online
fj_dxm0_0007 auto:cdsdisk    -            (meth02-db_dg) online
fj_dxm0_0008 auto:cdsdisk    meth03-db_dg01  meth03-db_dg online
fj_dxm0_0032 auto:cdsdisk    -            (vxfendg)    online
fj_dxm0_0033 auto:cdsdisk    -            (vxfendg)    online
fj_dxm0_0034 auto:cdsdisk    -            (vxfendg)    online
sda          auto:none       -            -            online invalid
sdb          auto:LVM        -            -            LVM
sdc          auto:LVM        -            -            LVM

Yet in VOM I only see the following

Selection_005.jpg

disk fj_dxm0_000a is not show in VOM but it is there in the system.

VOM does show that its Disk Group is imported and Healthy

Selection_008.jpg

 and its Volume is online, 

Selection_009.jpg

but it has no details of the disk, 

Selection_007.jpg

how can this be?

It's not causing any issues to the "solution" but it's worrying that it has no information about a disk that is there at the OS, where should I start to look to investigate this further?

[root@svctesu02 ~]# vxprint -hrt -g meth01-fs_dg
DG NAME         NCONFIG      NLOG     MINORS   GROUP-ID
ST NAME         STATE        DM_CNT   SPARE_CNT         APPVOL_CNT
DM NAME         DEVICE       TYPE     PRIVLEN  PUBLEN   STATE
RV NAME         RLINK_CNT    KSTATE   STATE    PRIMARY  DATAVOLS  SRL
RL NAME         RVG          KSTATE   STATE    REM_HOST REM_DG    REM_RLNK
CO NAME         CACHEVOL     KSTATE   STATE
VT NAME         RVG          KSTATE   STATE    NVOLUME
V  NAME         RVG/VSET/CO  KSTATE   STATE    LENGTH   READPOL   PREFPLEX UTYPE
PL NAME         VOLUME       KSTATE   STATE    LENGTH   LAYOUT    NCOL/WID MODE
SD NAME         PLEX         DISK     DISKOFFS LENGTH   [COL/]OFF DEVICE   MODE
SV NAME         PLEX         VOLNAME  NVOLLAYR LENGTH   [COL/]OFF AM/NM    MODE
SC NAME         PLEX         CACHE    DISKOFFS LENGTH   [COL/]OFF DEVICE   MODE
DC NAME         PARENTVOL    LOGVOL
SP NAME         SNAPVOL      DCO
EX NAME         ASSOC        VC                       PERMS    MODE     STATE
SR NAME         KSTATE

dg meth01-fs_dg default      default  28000    1439298345.37.svctesu01.XXXXXX.local

dm meth01-fs_dg01 fj_dxm0_000a auto   65536    3867082448 -

v  meth01-fs    -            ENABLED  ACTIVE   3867080704 SELECT  -        fsgen
pl meth01-fs-01 meth01-fs    ENABLED  ACTIVE   3867080704 CONCAT  -        RW
sd meth01-fs_dg01-01 meth01-fs-01 meth01-fs_dg01 0 3867080704 0   fj_dxm0_000a ENA

 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

The command that VOM uses for

The command that VOM uses for Storage Foujndation discovery is "vxlist" (not a typo).  Unless you find a simple explanation for this behavior using this utility, please open a case with technical support for an analysis of the discovery process for this disk.  Based on the data supplied here, this may be more of an issue that can be handled in this forum.

View solution in original post

3 Replies
Highlighted
Accepted Solution!

The command that VOM uses for

The command that VOM uses for Storage Foujndation discovery is "vxlist" (not a typo).  Unless you find a simple explanation for this behavior using this utility, please open a case with technical support for an analysis of the discovery process for this disk.  Based on the data supplied here, this may be more of an issue that can be handled in this forum.

View solution in original post

Highlighted

I expected as much...  When I

I expected as much...  When I return to the customers site I will do further analysis and open the case, I just wanted to see if anyone else had seen anything similar, VXVM and VCS are functioning as would be expected...  The environment isn't a live one yet.  Intresting thing that the same issue with two different VOM servers each looking at a different environment.  The example above was in the new  UAT environment, but the new Production Environment has a similar issue where it also can't see one of its disks in VOM too...

 

 

Highlighted

It is fairly normal to have

It is fairly normal to have information in VOM lagging behind actual state in VxVM if something was done on a node outside of VOM, I've seen delays for tens of minutes till VOM actually picked up the changes and updated its database.

That said, if it is consistently out of date and not consistent with CLI after the "refresh host" was run it might be subject to a support case.