Highlighted

Appliance and HW compression on tape

Hi guys,

For supported tape library - Qualstar + 2x LTO5 FC the HW compress is not enable.

sginfo -a /dev/sgx show DCE = 0.

Appliance 5240 - 8.1.2.

The appliance has not stinit and mt command where is possible to enable this. Any supported recommendation for enable this ?   Many thanks

 

Petr

 

 

3 Replies
Highlighted

Re: Appliance and HW compression on tape

Hi Petr,

Have you had a look in the GUI for your Qualstar library to see if compression shows as disabled there on your drives?  

Most modern libraries and drives have compression enabled by default and you can't turn it on or off (except with special firmware versions from the vendor), so it does seem strange.  NetBackup knows nothing about tape drive compression, but I'm guessing your Qualstar GUI will show the drives having compression turned off.

If that is the case, then I'd see if that can be changed using the Qualstar GUI, otherwise it might be an issue you have to raise with Qualstar.  I run 5230 appliances with a Dell TL4000 tape library and LTO6 FC drives.  The sginfo command shows DCE as 1 for me, but there is no way from the appliance or tape library GUI to change this.

Hope this helps,

Steve

Highlighted

Re: Appliance and HW compression on tape

Is that show of DCE purely a show of current active mode, or is it a show of possible capability?

Maybe it is always zero when not actively writing / reading physical tape media?

Highlighted

Re: Appliance and HW compression on tape

For my environment, DCE shows as 1 regardless of any tape activity or not:

Data compression mode page (0xf)
----------------------------------------------------
DCE 1
DCC 1
DDE 1
RED 0
Compression algorithm 255
Decompression algorithm 255

The above is no tape activity at all.

Steve