cancel
Showing results for 
Search instead for 
Did you mean: 

Catalog DR email not sending

NetBackup Appliance 5230

Appliance Code: 3.2

NetBackup Code: 8.2

The DR catalog backup email is not sending. This was working when we were at 3.1.2 and stopped working after we upgraded to 3.2 + associated EEBs.

The only change was....we upgraded from 3.1.2 to 3.2 Smiley Wink

I manually ran the /opt/NBUAppliance/scripts/mail_dr_info.pl with the appropriate arguments and it worked just fine. This appears to be broken somewhere between when the catalog backup finishes and actually sending the email with attachments. Docs I'm finding on this topic are really old, so I'm looking for more current solutions to this problem. If not a solution, then I'll take any tips to where/what I should be looking for. No, there's nothing about it in the /usr/openv/netbackup/logs/bpdbm log about any issues. So it has to be "deeper" than that.

Please advise.

1 Solution

Accepted Solutions
Accepted Solution!

Re: Catalog DR email not sending

Solution to the DR Email Issue.....

Applied this EEB: NBAPP_EEB_ET3997942-3.2.0.0-1.x86_64-201023175310.rpm

View solution in original post

6 Replies

Re: Catalog DR email not sending

Hey Dennis, is it just the one 3.2 appliance doing it or are they all having the issue ? I'm wondering for instance whether something like the SenderID got reset during the upgrade and so when it's generated the mail server is bouncing it as not-authorized (because it comes from a different domain, that kind of weirdness). Off-the-cuff I suspect running mail_dr_info.pl from the CLI would use the existing postfix configuration to send the email instead of whatever sender info NBU has stashed - sorry, I don't have one I can reference or I'd check the code. I was briefly excited to find this https://vox.veritas.com/t5/NetBackup-Appliance/How-to-send-Catalog-DR-email-from-an-appliance/td-p/8... but I see you've spotted it as well. heh. Just for kicks....the catalog backup is actually succeeding, right ? Wherever you have the DR info being saved still exists post-upgrade and such, it didn't get deleted by the image ? Sorry I don't have anything concrete otherwise that's immediately jumping out at me.

Re: Catalog DR email not sending

In the other post that was referenced, @davidmoline recommended the following:

If you are having this issue then log a case and reference either the original article number or the new one (which is 100047439). 

A better option may be to upgrade to appliance version 3.2 and apply EEB from ET 3997942 where this problem is supposed to have been fixed.

It seems that ET 3997942  is not included in the recommended 3.2 EEBs. 
@DPeaco might need to log a Support call for this.

Re: Catalog DR email not sending

Hello Marianne....

My appliances are at 3.2 + all current EEBs. The DR email broke when we upgraded from 3.1.2 to 3.2.

Re: Catalog DR email not sending

@DPeaco 

Yes, I got that from your previous post. What I was trying to say is that  ET 3997942 does not seem to be included in the recommended 3.2 EEB's.

Maybe worth logging a Support call with all the references as per @davidmoline's advice in the other post? 

Re: Catalog DR email not sending

Thank you @Marianne 

Catalog backup is working properly...the DR files are there....just not getting the "email".

@jnardello - Yes, the perl script works, I suspect it's just a "hook" somewhere in NBU that's keeping this from working. I have larger "fish to fry" right now but I will look at opening a support case on this and post the resolution here.

Accepted Solution!

Re: Catalog DR email not sending

Solution to the DR Email Issue.....

Applied this EEB: NBAPP_EEB_ET3997942-3.2.0.0-1.x86_64-201023175310.rpm

View solution in original post