cancel
Showing results for 
Search instead for 
Did you mean: 

Routing on Appliance 5230

NBU35
Level 6

Hi 

We are trying to add a route to our existing appliance 5230, running at 2.6.0.3. This is configured in media server role.

Currently this server is getting used for backup of only one client which contains Netezza DB.

Now we want to use this appliance also for backup of few more clients and those clients are not reachable from this appliance.

I checked there are no routes for those clients on this appliance.

following is current routing table:

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.100.249.0    0.0.0.0         255.255.255.240 U         0 0          0 bond1
10.100.14.0     10.100.14.254   255.255.255.0   UG        0 0          0 bond0
192.168.229.0   0.0.0.0         255.255.255.0   U         0 0          0 eth0
10.100.7.0      10.100.14.30    255.255.255.0   UG        0 0          0 bond0
10.100.117.0    10.100.14.30    255.255.255.0   UG        0 0          0 bond0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo

bond0 has IP - 10.100.14.30 

bond1 has IP - 10.100.249.5

eth0 has default IP.

I am able to ping gateway 10.100.14.254 from the destination clients. Now when i try to add static route from WEB GUI, it refelcts error "Default gateway is in use".

when I try to add route from CLISH, i recieve following error message.

Gateway Add 10.100.14.254 10.100.28.0 255.255.255.0 bond0
name:########01:
- [Info] Adding route(Dest: 10.100.28.0 GW: 10.100.14.254 NM: 255.255.255.0 DEV: bond1)
- [Info] Validating route input (10.100.28.0 10.100.14.254)
- [Info] Validating routing table
- [Info] Updating routing information
- [Error] Failed to update routing information. The network gateway is not reachable with the route information that you have provided. The gateway might not be reachable because it is not covered under a subnet mask that can be reached through your network interface settings.
- [Error] Failed to add new network route entry

Please assist.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

NBU35
Level 6

Hi sdo 

 

Thanks, issue has been fixed.

All i need to delete all gateway and network cofnfig and readd them again.

View solution in original post

4 REPLIES 4

sdo
Level 6
Partner    VIP    Certified

Not enough information.

To make any sense of this we need to see:

IP address, interface, subnet, network, netmask, CIDR, gateway ... all seven of these items... for all three of these...   master bond0, master bond1, one of the new clients... i.e. we need 21 pieces of information.

NBU35
Level 6

Thanks sdo.

Can you explain what is CIDR ?

I checked with Netwrok people they are able to ping these gateways from each other, now i can assume  reason behind this issue could be " there is no default route on appliance".

something like 0.0.0.0    10.100.14.254     0.0.0.0     U         0 0          0 bond0

but when I tried to add this static route, I again recieved an error " Default Gateway is already in use".

sdo
Level 6
Partner    VIP    Certified

CIDR:

https://en.wikipedia.org/wiki/Classless_Inter-Domain_Routing

...think of it as a shorthand way of expressing the network and netmask together... but usually network engineers like to see the details of any network issues expressed in all forms both shorthand and longhand - hence things are much easier to diagnose when all of "interface, IP, network, subnet, netmask, CIDR, gateway" are specified in discussions.

NBU35
Level 6

Hi sdo 

 

Thanks, issue has been fixed.

All i need to delete all gateway and network cofnfig and readd them again.

View solution in original post