Highlighted

Fail to install Netbackup Self Service Adapter

Greetings!

I try to install Netbackup Self Service. I've successfully installed NSS Portal, but while i run the NSS Adapter installer i get error. Let's see that step by step.

-Select Components(include Portal Panels, Web Services and Tasks, Database) ------> success

-Validate Power Shell -----> success

-Select Portal Web Service(Default Web Site/NetBackupSelfServicePublicWebService) --------> success

-Validate Portal Web Service Connection -------> Unblock blocked files is Ok, but Check vonnection to Portal Web Service fail

Log file output:

Target Unblock:
    Unblocking files for location 'C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\..\'
Target GetFrontOfficeParameters:
    WebSite 'Default Web Site' has Url 'http://server'
    DapiConnectionString: authtype=Anonymous;url=http://server/NetBackupSelfServicePublicWebService/DirectaApi.svc;
Target CheckDapiConnection:
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : Failed to Connect to Dapi with connection string: authtype=Anonymous;url=http://server/NetBackupSelfServicePublicWebService/DirectaApi.svc; Exception: Exception calling "DoesIntegrationSettingExist" with "2" argument(s): "The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : <html xmlns="http://www.w3.org/1999/xhtml">
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : <head>
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : <title>IIS 8.5 Detailed Error - 500.19 - Internal Server Error</title>
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : <style type="text/css">
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : <!--
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : .config_source code{font-size:.8em;color:#000000;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : pre{margin:0;font-size:1.4em;word-wrap:break-word;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : ul,ol{margin:10px 0 10px 5px;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : ul.first,ol.first{margin-top:5px;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : fieldset{padding:0 15px 10px 15px;word-break:break-all;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : .summary-container fieldset{padding-bottom:5px;margin-top:4px;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : legend{color:#333333;;margin:4px 0 8px -12px;_margin-top:0px;
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : font-weight:bold;font-size:1em;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : a:link,a:visited{color:#007EFF;font-weight:bold;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : a:hover{text-decoration:none;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : h1{font-size:2.4em;margin:0;color:#FFF;}
    C:\Program Files\Biomni\NetBackup Self Service Adapter 8.1\MSBuild\Validate.proj(126,5): error : h2{font-size:1.7em;margin:0'."
Done building target "CheckDapiConnection" in project "Validate.proj" -- FAILED.

Done building project "Validate.proj" -- FAILED.

Thank you.

8 Replies
Highlighted

Re: Fail to install Netbackup Self Service Adapter

Hi KrotovKirill, 

From the error, it seems like you're pointing the adapter at the root of the website when looking for the Portal. Have you installed the Portal to the Root? or is it in a virtual directory?


Regards
Casper.

 

Highlighted

Re: Fail to install Netbackup Self Service Adapter

Hi Casper,

In this case i've installed Portal to the Root. But before i tried to install it to the virtual directory and i have got the same error.

Regards

Highlighted

Re: Fail to install Netbackup Self Service Adapter

Hi,

When you browse to http://server does the portal resolve (the panels won't work at this stage, but the page should be viewable)

If that works, can you then browse to http://server/NetBackupSelfServicePublicWebService/DirectaApi.svc and tell me what you see?


Thanks

Highlighted

Re: Fail to install Netbackup Self Service Adapter

When i browse to http://server i get http error.

sc1.pngAnd the same error, when i browse http://server/NetBackupSelfServicePublicWebService/DirectaApi.svc

sc2.png

Regards

Highlighted

Re: Fail to install Netbackup Self Service Adapter

Even I have the same error when I try to set this up. Please help!

Highlighted

Re: Fail to install Netbackup Self Service Adapter

Good morning KrotovKrill, 

This sort of issue is difficult to sort remotely via this medium. I'd suggest that this be raised up via support, and we can perhaps arrange a Webex to resolve?


Regards

Casper

Highlighted

Re: Fail to install Netbackup Self Service Adapter

Good morning SudeeshSudhi, 

This sort of issue is difficult to sort remotely via this medium. I'd suggest that this be raised up via support, and we can perhaps arrange a Webex to resolve?


Regards

Casper

Highlighted

Re: Fail to install Netbackup Self Service Adapter

Hi,

 

This resolved my issue

 

enter image description here