Showing results for 
Search instead for 
Did you mean: 

7.7.3 and the dratted "not a superuser" error from DOS batch files

Level 6

Ok folks, does anyone have a simple, easy to read guide to allowing DOS batch files that worked fine under but now throw the amazingly unintelligent "not a superuser" error in 7.7.3?

I can't disable UAC.  The domain userid/password that the scripts run under is a Local Admin and is same as the account that Veritas runs under.  The scheduler that runs the script has no idea about "elevating users".  And there's no way I'm going to mess with the disaster that is NBAC.

Why bother to continue to provide the commands if they no longer work the way they used to?



Partner    VIP    Accredited Certified

If it used to work in 7.6.x.x then you can try this Try to add batch-files location into BPCD_WHITELIST_PATH just for test. 

Yes, this all worked fine from 6.5.6 up through 7.7.3 broke it all.

The URL you gave me fails but I did find this one that discusses that whitelist:

I'll give that a shot.

I've also seen the docs on BPNBAT but I can't seem to get it to take the responses file so I can't embed that into the script...'s looking more and more like DOS batch scripting is dead for NetBackup.

I'm now in discussion with Senior Management about getting a Security Exemption to allow disabling of UAC...that or tag onto an existing Unix box as a Media Server so the commands run as root...but some of the commands don't support the -M flag so I'd need two boxes, one for each Master...