cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Advanced disk pool down

Version is 8.2

 

Hi all,

I am trying to setup a disk pool for my new backups. This was working in Feb but now it's saying the volume is marked as down:

1589819453 1 33280 8 lsabackup01.ad.locksmithanimation.com 0 0 0 *NULL* nbemm Volume lsabackup01.ad.locksmithanimation.com:QNAP_ADU:\\qnap\Veritas_Backups marked down
1589819513 1 33280 8 lsabackup01.ad.locksmithanimation.com 0 0 0 *NULL* nbemm Volume lsabackup01.ad.locksmithanimation.com:QNAP_ADU:\\qnap\Veritas_Backups marked down
1589819573 1 33280 8 lsabackup01.ad.locksmithanimation.com 0 0 0 *NULL* nbemm Volume lsabackup01.ad.locksmithanimation.com:QNAP_ADU:\\qnap\Veritas_Backups marked down
1589819633 1 33280 8 lsabackup01.ad.locksmithanimation.com 0 0 0 *NULL* nbemm Volume lsabackup01.ad.locksmithanimation.com:QNAP_ADU:\\qnap\Veritas_Backups marked down
1589819693 1 33280 8 lsabackup01.ad.locksmithanimation.com 0 0 0 *NULL* nbemm Volume lsabackup01.ad.locksmithanimation.com:QNAP_ADU:\\qnap\Veritas_Backups marked down
1589819753 1 33280 8 lsabackup01.ad.locksmithanimation.com 0 0 0 *NULL* nbemm Volume lsabackup01.ad.locksmithanimation.com:QNAP_ADU:\\qnap\Veritas_Backups marked down
1589819813 1 33280 8 lsabackup01.ad.locksmithanimation.com 0 0 0 *NULL* nbemm Volume lsabackup01.ad.locksmithanimation.com:QNAP_ADU:\\qnap\Veritas_Backups marked down

 

This is a unc path but was working. Here is a few logs that I know have been asked for in the past:

Storage Server : *removed for the forum*
Storage Server Type : AdvancedDisk
Storage Type : Formatted Disk, Direct Attached
State : UP
Flag : OpenStorage
Flag : AdminUp
Flag : InternalUp
Flag : SpanImages
Flag : LifeCycle
Flag : CapacityMgmt
Flag : FragmentImages
Flag : Cpr
Flag : RandomWrites
Flag : FT-Transfer
Flag : CapacityManagedRetention
Flag : CapacityManagedJobQueuing

Disk Pool Name : QNAP_ADU
Disk Pool Id : QNAP_ADU
Disk Type : AdvancedDisk
Status : UP
Flag : Patchwork
Flag : Visible
Flag : OpenStorage
Flag : AdminUp
Flag : InternalUp
Flag : SpanImages
Flag : LifeCycle
Flag : CapacityMgmt
Flag : FragmentImages
Flag : Cpr
Flag : RandomWrites
Flag : FT-Transfer
Flag : CapacityManagedRetention
Flag : CapacityManagedJobQueuing
Raw Size (GB) : 44089.86
Usable Size (GB) : 44089.86
High Watermark : 98
Low Watermark : 80
Num Volumes : 1
Max IO Streams : -1
Comment :
Storage Server : lsabackup01.ad.locksmithanimation.com (UP)

Disk Pool Name : QNAP_ADU
Disk Type : AdvancedDisk
Disk Volume Name : *removed for the forum*
Disk Media ID : @aaaap
Total Capacity (GB) : 44089.86
Free Space (GB) : 37925.51
Use% : 13
Status : DOWN
Flag : ReadOnWrite
Flag : AdminUp
Flag : InternalDown
Num Read Mounts : 0
Num Write Mounts : 1
Cur Read Streams : 0
Cur Write Streams : 0
Num Repl Sources : 0
Num Repl Targets : 0

I can manually mount and create a text file in there as well. Does anyone know the cause of this? More than happy to run anything else as needed.

Many Thanks
Mark

Tags (2)
1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: Advanced disk pool down

@markplayford 

Please forgive me, but I'm battling to piece everything together. 

Here you received 'server name not found' error: 
./nbdevquery -listconfig -storage_server lsabackup01 -stype advanceddisk
DSM was unable to find the following storage server: lsabackup01
failed to get storage server configuration information, server name not found in the NetBackup configuration

Maybe because you used short name instead of FQDN ?  Does the command work when you use FQDN? 

Your last post shows : 
Configured Disk Volume \\qnap\Veritas_Backups is not found on storage server

You say ' .... it's only the unc share of the volume that has changed.'   
Is \\qnap\Veritas_Backups  the updated path? 
Is this the same path that you manually use on the storage server (lsabackup01) to access the path? 

Lastly - NBU logon services - 
Please try this: 
Change these 2 services to Windows user with write access to the storage (you may try your own user name as a test, since you know that is working):
NetBackup Client Service
NetBackup Remote Manager and Monitor Service
(Reference: https://www.veritas.com/support/en_US/doc/62428570-127355758-0/v41399748-127355758   )

Restart these 2 services.

Let us know if there is any progress. 

View solution in original post

12 Replies
Highlighted

Re: Advanced disk pool down

@sdo @Marianne Calling help from some frind.

@markplayford I guess this is a Windows based Netbackup installtion - right ?

 

Highlighted

Re: Advanced disk pool down

Sorry, yes it is. Server 2012 (not r2) running 8.2.

Highlighted

Re: Advanced disk pool down

@markplayford who manages Windows OS in your environment?? If it's not you, can you check with Windows Team if they did any AD changes or added/change any security or access rules? Also what account are you using to access this UNC path, I hope there is not change to this account.

Highlighted

Re: Advanced disk pool down

Hi,

I manage the environment so there are no changed there. I'm using the local system for netbackup to access as well as a local for  web console and Broker service.

I've just realised I changed the storage device to a new vlan so it has a new address but I added it with DNS name. Is there a way of adding a new diskpool without having to delete the storage server as it is used for another disk pool.

Thanks
Mark

 

Highlighted

Re: Advanced disk pool down

When you say you changed VLAN and has new address - is that also a new DNS name?

If it is only the IP that has changed, then you should be able to flush the DNS cache on the server (ipconfig /flushdns) and flush the NetBackup host cache (bpclntcmd -clear_host_cache), and then the new IP should be used. 

If you have change the actual DNS name of the storage server, then it is possible to fix this, but it is not simple and really requires consulting services to make the change (as it involves updating the backup metadata within the catalog). 

If you have change the DNS name, can you make an CNAME alias that uses the old DNS name popinting to the new name?

Highlighted

Re: Advanced disk pool down

The IP was changed to a new network but the DNS name stayed the same. The cname was updated on the dns server and I can get to it fine from the windows server outside of netbackup.

I have ran both of those commands but has not changed the fact the volume is still marked as down, would I need to manually up it?

Many Thanks for all your help.
Mark

Highlighted

Re: Advanced disk pool down

I've tried running the nbdevquery command and it says it can't find the storage server:

./nbdevquery -listconfig -storage_server lsabackup01 -stype advanceddisk
DSM was unable to find the following storage server: lsabackup01
failed to get storage server configuration information, server name not found in the NetBackup configuration

Highlighted

Re: Advanced disk pool down

Apologies, I just re-read part of your message. The storage server has remained the same it's only the unc share of the volume that has changed

Highlighted

Re: Advanced disk pool down

Still working through this.

I have tried running:

./nbdevconfig -updatedp -stype AdvancedDisk -dp QNAP_ADU

And I get this error:

RDSM has encountered an STS error: getDiskVolumeInfo
WARNING : Configured Disk Volume \\qnap\Veritas_Backups is not found on storage server
Update of disk pool replication properties succeeded

Highlighted
Accepted Solution!

Re: Advanced disk pool down

@markplayford 

Please forgive me, but I'm battling to piece everything together. 

Here you received 'server name not found' error: 
./nbdevquery -listconfig -storage_server lsabackup01 -stype advanceddisk
DSM was unable to find the following storage server: lsabackup01
failed to get storage server configuration information, server name not found in the NetBackup configuration

Maybe because you used short name instead of FQDN ?  Does the command work when you use FQDN? 

Your last post shows : 
Configured Disk Volume \\qnap\Veritas_Backups is not found on storage server

You say ' .... it's only the unc share of the volume that has changed.'   
Is \\qnap\Veritas_Backups  the updated path? 
Is this the same path that you manually use on the storage server (lsabackup01) to access the path? 

Lastly - NBU logon services - 
Please try this: 
Change these 2 services to Windows user with write access to the storage (you may try your own user name as a test, since you know that is working):
NetBackup Client Service
NetBackup Remote Manager and Monitor Service
(Reference: https://www.veritas.com/support/en_US/doc/62428570-127355758-0/v41399748-127355758   )

Restart these 2 services.

Let us know if there is any progress. 

View solution in original post

Highlighted

Re: Advanced disk pool down

Not a problem Marianne, thanks for helping.

I'll go through and make the changes you have asked.

Firstly, I changed the command so it was -stype AdvancedDisk and it now says. "no configuration items found!"

I'll make the other changes now and update you.

Many Thanks
Mark

Highlighted

Re: Advanced disk pool down

Marianne, thank you so much. I totally forgot that I moved the server to to new hardware and one thing I never addedd since having to reinstall Netbackup was the 2 users. I now remember having to do that before.

Thanks you so much for your help.
Mark