cancel
Showing results for 
Search instead for 
Did you mean: 

BMR restore $CLNT_NAME error 227

Hello everybody,

 

I want to do a BMR restore but I have gotten this error rc (1002) and also i have run this commands

 

bpclimagelist -client $CLNT_NAME -T

echo %ERRORLEVEL%  = 227

bpclimagelist -client cvsipreapp -T

echo %ERRORLEVEL%  = 0

 

So when i put the variable $CLNT_NAME i got the error 227 but if i put the client_name i got the error 0.

The question is how can i check if the $CLNT_NAME variable has the right parameter ?

 

Best regards

 

Screen Shot 2014-03-29 at 9.39.59 AM.png

 

 

 

 

 

 

 

9 Replies

Since it looks like it is a

Since it looks like it is a variable with the $, I do believe you need to

 

echo "%CLNT_NAME%"

to see what it is set at or


SET

to show all variable set.

Based on that client name, it would of course generate the error 227 if it is different than its client name when the backup occured.

    Hello, I have run the

 

 

Hello, I have run the echo "%CLNT_NAME%", but it does not print anything, so I set the hostname to the variable  and run the bpclimagelist -client $CLNT_NAME -T commnand, but when i try to run the restore again i got other error

 

Screen Shot 2014-03-31 at 1.10.26 PM.png

 

Screen Shot 2014-03-31 at 1.36.02 PM.png

 

best regards

I think it would be wise to

I think it would be wise to get a little more detail from you regarding versions. What version of NetBackup is your Master server?

If doing network boot, what version is your bootserver running?

What version of the client is the backup from?

What version of the client is the srt patched with?

  Hello   The master server

 

Hello

 

The master server version is 7.5.0.5 running on solaris, the boot server is 7.5.0.5 running on windows, the client into the srt iso is netbackup 7.5.0.5.

 

the client i am trying to  recover is windows.

 

best regards

Which BMR restore method you

Which BMR restore method you are following? Media or NW?

Have you done Prepare To Restore step if its NW based restore?

 

Thanks.

Mandar

Hello. I am restoring from

Hello. I am restoring from ISO but also i have done the steps:

 discovered the configuation from the server

changed the configuration

done the prepare for restore

 

Best regards

 

 

Have you prepared the ISO

Have you prepared the ISO post prepare to restore or before that step?

If you have burned the ISO post PTR and then booting client for restore using it then only auto restore will work for that client. Else you need to choose "Generic Restore" option on the SRE shell menu, set master server ip-details, choose your client config and then click restore.

Thanks.

Mandar

Hello,   I have had the

Hello,

 

I have had the netbackup 7.0.1 running and i have done BMR restore with  ISO SRT before.  then I upgraded to netbackup 7.5.0.5 i create a new SRT and added the network windows drivers to the SRT.

 

After that i done the prepare for restore, then i created the iso then i booted the server but when i  try to recover the backup got the error  rc=1002, then i run the commands

bpclimagelist -client $CLNT_NAME -T

echo %ERRORLEVEL%  = 227

bpclimagelist -client cvsipreapp -T

echo %ERRORLEVEL%  = 0

 

i have been sure there is a valid backup images for restoring.

 

Best regards

 

 

 

Can you check if "generic

Can you check if "generic restore" option on the SRE shell is working well for you?

You need to provide your master server ip , NW details, then choose your client config and click restore.

Thanks.

mandar