Backups working fine but unable to restore even fromt he Master server

Folks,

 

Here is a weird one I did my last random test for restores about 30 days ago, went in grabbed a random server, random drive, random folder and did an intgrity check all was great. Yesterday I went to do my checks and picked a different server location etc and got this:

WARNING: unable to obtain a list of files using the specified search criteria.  NOTE: it has been determined you do not possess the necessary permission to restore from FULL or INCREMENTAL backups.

I went back to the restore which worked a month before and got the same message? So I went to the Master server to just check the box off and verified the backups (Ones in question were 25GB in files backed up) and tried ot proxy restore and got the same message. So I had the Master server try to restore one of its backups and got the same message.

I checked the basic's made sure the clients had the ability to browse and restore both in the global and individual settings, restarted the Master server after to make sure i did nto have an errant bug runnign around. Logged in as the local Admin on the Master server afterwards and tried to restore its own backups again to get the same message. I checked AD and Administrators and Domain admins have backup and restore rights.

So somehow I have lost a permission to something but where do I look?

For the envoroment this is a an Active directory Domain with Server 2012-2016 with no VM's, I have a single Master server with a direct connect 4 Drive tape library and a backup Media server on a closed network. I was able to kick of a backup via the Policies but trying to run one on the local client fails with a 245 error.

Any ideas where to look?

2 Replies
Highlighted

Re: Backups working fine but unable to restore even fromt he Master server

1) have you opened the Master server java console or the backup archive & restore(BAR) from client?  ( i assume you are trying from BAR window if yes, could you try from Java console?

2) Do you know if the NBAC is enabled on the master server?

 

Re: Backups working fine but unable to restore even fromt he Master server

RamNagalla,

Yes I was running BaR (Backup and recovery) console from both client and server with the same result, I can see the full and Inc backups but when I click on them I get the error. I even dug through the logs to see if I could find errors to point the way.

So I have a work around and feel stupid though it is not making sense to me, in the past I ran BaR without running as Admin was not needed so I had not tried it. After an hour of frustration I ran BaR as Administrator just to see if the error changed and it worked on the Master.. so I ran it on both Master and clients and have 2 restores going without issue. I am guessing the Systems Engineer made an Active directory Domain change which is not allowing creditials to transverse, but is just a guess. When he gets in Monday I will bug him for his change log to see if i can figure it out and update this thread in case someone else has the issue down the road.

 

Thank you for the help! Still open to ideas where to look in AD.