cancel
Showing results for 
Search instead for 
Did you mean: 

Can I configure Qlogic hba of a media server with 1 hba to be QLogic and 1 hba to be target mode

tien86
Level 4
Partner

Hello bro,

I have a media server 2 hba ( Qlogic- 2 ports ) connected to a tape. When I enable nbhba mode, all 4 hba ports become Initiator mode and connection to tape is lost. Can I configure this media use 1 hba to be QLogic and 1 hba to be target mode

Thank and appreciate any suggestions.

1 ACCEPTED SOLUTION

Accepted Solutions

tien86
Level 4
Partner

Hello,

I found that I have problem with SAN Switch and Media Server FC Target mode port. Then I create a SR from symantec and very nice. I received a patch which help to solve my problem.

 

View solution in original post

4 REPLIES 4

revarooo
Level 6
Employee

you can set using WWN

         -modify
          Modifies the mode of the HBA card. Specify the HBA card to be changed through the World Wide Name (wwn).

       -wwn string
          Specifies the World Wide Name of the HBA card. These required selection criteria are used to specify which card and port to mark.

       -mode target | initiator
          Sets the mode of the specified HBA card. Target mode uses the HBA as the target for a SAN Client. Do not set an existing card to initiator mode unless it had been
          previously set to target mode.

 

 

 

nbhba -modify -wwn 123456789ABCDEF0 -mode target

 

List the ports after:

nbhba -L

 

 

Nicolai
Moderator
Moderator
Partner    VIP   

This is what I have done (long time ago).

However I have seen the issues on connect before. Typical marking one port marks both port on the same HBA for FT operation. But for sure marking one port shouldn't impact HBA 2.

Symantec has also released this tech note about marking FT ports on HBA with multipe ports:

Marking the FT media server HBA ports

http://www.symantec.com/docs/HOWTO66224

tien86
Level 4
Partner

I can connect to tape. I found I have problem with FT Server configuration. I haven't find issue root. There only a possiblility is a port in target hba is unplug 

 

# /usr/openv/netbackup/bin/admincmd/nbftconfig -listactive
No active connections found

 

# /usr/openv/netbackup/bin/admincmd/nbftconfig -listservers
m backup-02 7.6.0.3  active 8
d 0 FABRIC active 0 0 50:01:43:80:28:CF:59:98 QLE256x Series FC Hba 8
d 0 FABRIC active 1 0 50:01:43:80:28:CF:59:98 QLE256x Series FC Hba 8
d 1 DISCONNECTED active 0 0 50:01:43:80:28:CF:59:9A QLE256x Series FC Hba 0
d 1 DISCONNECTED active 1 0 50:01:43:80:28:CF:59:9A QLE256x Series FC Hba 0

 

 

11/24/2014 17:06:56.321 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186049419008 File ID:199 [No context] 1 [SC_UpdateTgtAttrTable] ISP2532 at tgt 1 WWN[20:01:43:80:28:CF:59:9A] intlevel 17
11/24/2014 17:07:00.293 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186024236800 File ID:199 [No context] 1 [FTServerMgr_i::listAllPseudoDevices] targets 2 luns 2
11/24/2014 17:08:53.323 [Application] NB 51216 nbftsrvr 199 PID:3036 TID:140186049419008 File ID:199 [No context] [Info] V-199-8 Shutdown requested
11/24/2014 17:08:53.323 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186049419008 File ID:199 [No context] 1 [FTServer::ShutDown] Pipes closed - stopping signal processing in 4 seconds, concurrent IOTask used 1
11/24/2014 17:08:53.323 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186049419008 File ID:199 [No context] 1 [FTServer::ShutDown] gFatServer->ShutDown() detected
11/24/2014 17:08:53.323 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186049419008 File ID:199 [No context] 1 [advertiseStartup] gFatServer->ShutDown() detected, stopping
11/24/2014 17:08:53.324 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186049419008 File ID:199 [No context] 1 [FTServerMgr_i::getDriverLogMsgs] gFatServer->ShutDown() detected
11/24/2014 17:08:55.828 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186049419008 File ID:199 [No context] 1 [FTServerMgr_i::getDriverLogMsgs] stopping
11/24/2014 17:08:59.308 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186051540736 File ID:199 [No context] 1 [checkServer] child shutdown
11/24/2014 17:08:59.317 [Debug] NB 51216 nbftsrvr 199 PID:3036 TID:140186051540736 File ID:199 [No context] 1 [FTServerMgr_i::suspend] Destroying the object ref
11/24/2014 17:09:21.347 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098683733792 File ID:199 [No context] 1 [hasSANClientLicense] Found SAN Client License
11/24/2014 17:09:21.347 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098683733792 File ID:199 [No context] 1 [FTServerMgrService::init] called with 0 arguments
11/24/2014 17:09:21.395 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098683733792 File ID:199 [No context] 1 [FTServerMgrService::driverRunning] 'ps -ea | grep nbfdrv64' failed (not found?), exit status = 1, errno = 0:Success
11/24/2014 17:09:21.405 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098683733792 File ID:199 [No context] 1 [forkDriver] getshm(): shmget id 360448 attached at 0x7f6b44490000
11/24/2014 17:09:22.407 [Application] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] [Info] V-199-7 Supporting 2 luns per target mode FC HBA port
11/24/2014 17:09:22.407 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ReloadJungo] nbfdrv64 running as root (PID=5307)
11/24/2014 17:09:22.407 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ConfigureSDCs] Using multiple PCI buses.
11/24/2014 17:09:22.407 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [SetLogLevel] DebugLevel changing from 0 to 1
11/24/2014 17:09:23.158 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [InitializeSDC24xx] ISP-2532 instance 2 PN 1 (Subsystem Device ID 0xb263) WWN:[50:01:43:80:28:cf:59:98] intlevel=16 PCI Express
11/24/2014 17:09:23.159 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [InitializeSDC24xx] ISP-2532 instance 3 PN 2 (Subsystem Device ID 0xb263) WWN:[50:01:43:80:28:cf:59:9a] intlevel=17 PCI Express
11/24/2014 17:09:23.559 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [InitSGRVPool] SGRVpool allocated with support for 644 * 256K buffers
11/24/2014 17:09:23.559 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [SetTargets] (Targets=2)
11/24/2014 17:09:24.211 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ProcessManage] node IOTID[1,65535,255,65535] 0x7fadec008db0 STMTMTYPE_AttachChange type 3 STMTMP2P_Up 8 gbit/s
11/24/2014 17:09:24.211 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [SC_UpdateTgtAttrTable] ISP2532 at tgt 0 WWN[20:01:43:80:28:CF:59:98] intlevel 16
11/24/2014 17:09:28.232 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [gethrtime]  detected 1.99554 GHz CPU
11/24/2014 17:09:28.299 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ProcessManage] node IOTID[1,65535,255,65535] 0x7fadec008eb0 STMTMTYPE_FabricChange type 1 STMTMFABRIC_Up
11/24/2014 17:09:28.299 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ProcessImmedNotify24xx] [P:01] SDCISPSTAT24xx_IN_LinkReset (LIP or NOS/OLS)
11/24/2014 17:09:28.548 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ProcessImmedNotify24xx] [P:01] SDCISPSTAT24xx_IN_LinkReset (LIP or NOS/OLS)
11/24/2014 17:09:28.548 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ProcessImmedNotify24xx] [P:01] SDCISPSTAT24xx_IN_LinkReset (LIP or NOS/OLS)
11/24/2014 17:09:28.548 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ProcessManage] node IOTID[1,0,0,65535] 0x7fadec008fb0 STMTMTYPE_PortDBChange type 0 STMTMLoggedIn
11/24/2014 17:09:28.548 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ProcessManage] node IOTID[1,0,0,65535] 0x7fadec0090b0 STMTMTYPE_PortDBChange type 1 STMTMLogOut
11/24/2014 17:09:28.548 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [ActivateInterface24xx] PN=2 FWstate 4 Lost Rx sync, awaiting resynchronization
11/24/2014 17:09:28.548 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098665801472 File ID:199 [No context] 1 [SC_UpdateTgtAttrTable] ISP2532 at tgt 1 WWN[20:01:43:80:28:CF:59:9A] intlevel 17
11/24/2014 17:09:31.501 [Debug] NB 51216 nbftsrvr 199 PID:5292 TID:140098638518016 File ID:199 [No context] 1 [FTServerMgr_i::listAllPseudoDevices] targets 2 luns 2

 

 

 

tien86
Level 4
Partner

Hello,

I found that I have problem with SAN Switch and Media Server FC Target mode port. Then I create a SR from symantec and very nice. I received a patch which help to solve my problem.

 

View solution in original post