cancel
Showing results for 
Search instead for 
Did you mean: 

Catalog Recovery Error - 8.1.1

robertoaxity
Level 6
   VIP   

Hello,

I need recovery the catalog in a new virtual machine, i follow all steps

https://www.veritas.com/support/en_US/article.100005565

but in the step 7 when i try to recovery appear the next error.

lprvnetbkp01.resp.derco.cl_1629132650
Failed to find all media needed for catalog DR image
The following DR media could not be located in NetBackup database.
Please insert the following media and run the volume configuration wizard or the vmupdate command to update the NetBackup database.
Host Media ID Barcode
lprpaplnetbk. 000079 000079L7
lprpaplnetbk. 000079 000079L7

but in the library i have the media

2021-08-18 00_07_25-10.55.0.10 - Conexión a Escritorio remoto.png2021-08-18 00_07_09-10.55.0.10 - Conexión a Escritorio remoto.png

Can you help me please

version are 8.1.1 in the old master and the new master server

Regards

3 REPLIES 3

davidmoline
Level 6
Employee

Hi @robertoaxity 

You will need to update your barcode rule before you inventory the library. If you note in your picture the MediaID is 0079L7, which is not what is required even though it is the correct tape. 

Delete the tape from NetBackup, go in and inventory the library again, but before you click update, go into advanced settings and add a "Media ID Generation" rule for robot 1 which is 1:2:3:4:5:6 (the first 6 characters of the barcode - make sure you alos specify that the length is 8 characters). 

Now when you inventory the MediaID will be correctly set to 000079. 

Alternately you can add a line to you vm.conf file on the media server and restart NetBackup 

MEDIA_ID_BARCODE_CHARS = 1 8 1:2:3:4:5:6

Cheers
David

PS Ammended as I originally had barcode rule instead of media id generation rule

pats_729
Level 6
In addition to what David has mentioned… be sure to move catalog backup tapes to CatalogBackup Pool. I can see the tapes are put in NetBackup pool.

For catalog recovery catalog tapes should be available in CatalogBackup pool.

Hope it helps.

robertoaxity
Level 6
   VIP   


Thanks to both of you for the advice, currently I still do not continue with the recovery process, since I preferred to keep the backups active through the old master server, when I try again I will comment if indeed based on your help I can solve the incident.

Thanks very much