Highlighted

Device configuration wizard cannot configure tape drive from Media servers

Hello Sirs i did the following in my site recently: 

1. upgrade from windows 2008 to windows 2016 - successfull   2. Did a fresh install of netabackup on all servers (1 master and 2 media) - successfull .  3. Did a catalog restore to get all configs and relational databases back to status quo - successfull 4. Had to install tape drives for Operating systems to see tape drives, could use OS to move tapes about via robot on media servers  5. Device configuration wizard is unable to configure the tape drives on media servers (showing only disk instead of "tape & disk" thus unable to backup nor restore via tape. Please i need help on how to fix this issue as its giving me nightmare... please find attached screenshots for correspondence . Any form of recommendation will be highly appreciated

Tags (2)
1 Solution

Accepted Solutions
Accepted Solution!

Re: Device configuration wizard cannot configure tape drive from Media servers

@Chidobrad 

You need to check installed license keys on the master server as well as all media server.

You need all of the following licenses on master and media servers to config shared tape drives:

Enterprise Server 
Library based tape drive(s)
Shared Storage Option

When you have confirmed all of this, restart NBU on media servers and master server, then verify with output of this command:

nbemmcmd -listhosts -verbose

Please post above output as text. 

View solution in original post

12 Replies

Re: Device configuration wizard cannot configure tape drive from Media servers

I can't open word doc.

What do these show on media servers ?

scan -changer

scan -tape

(scan.exe is in Volmgr/bin)

Attach as text files pls.

Re: Device configuration wizard cannot configure tape drive from Media servers

Sometimes when I have this message I need to run these commands:

 

nbemmcmd -updatehost -machinename MEDIA -machinetype media -machinestateop set_tape_active -masterserver MASTER 

nbemmcmd -updatehost -machinename MEDIA -machinetype media -machinestateop set_master_server_connectivity -masterserver MASTER 

 

Fill in your MASTER and MEDIA server names

Re: Device configuration wizard cannot configure tape drive from Media servers

both should be "nbemmcmd" (fixed the post)

Re: Device configuration wizard cannot configure tape drive from Media servers

Hi,

 

Can you please check the license and confirm,

 

SHARE STORAGE OPTION is showing "+" or "-" .

Accepted Solution!

Re: Device configuration wizard cannot configure tape drive from Media servers

@Chidobrad 

You need to check installed license keys on the master server as well as all media server.

You need all of the following licenses on master and media servers to config shared tape drives:

Enterprise Server 
Library based tape drive(s)
Shared Storage Option

When you have confirmed all of this, restart NBU on media servers and master server, then verify with output of this command:

nbemmcmd -listhosts -verbose

Please post above output as text. 

View solution in original post

Re: Device configuration wizard cannot configure tape drive from Media servers

Please find txt files as requested from Media servers

Re: Device configuration wizard cannot configure tape drive from Media servers

I tried the commands recommended.. from the GUI media servers changed from "disk to disk and tape" briefly but then changed back after refreshing 

Re: Device configuration wizard cannot configure tape drive from Media servers

Apologies, i mistakenly clicked on this as solution ... meanwhile its not... how do i revert this

Re: Device configuration wizard cannot configure tape drive from Media servers

ok - the robot and four drives are visible to the OS, and also NetBackup can see them - so you now need to follow the advice from other repliers/posters/responders.

Re: Device configuration wizard cannot configure tape drive from Media servers

Okay thanks... waiting on others for their opinions and recommendations

Re: Device configuration wizard cannot configure tape drive from Media servers

they already did - see M's and Sclind's and Sagar's posts

Re: Device configuration wizard cannot configure tape drive from Media servers

Hello Marianne,

Many thanks as your recommendation was the answer. i didnt input SSO on media servers  and that was the cause of the problem. Once i inputted the license, the master server saw it and everything started working fine. many thanks and God bless

Regards,

Chidobrad