cancel
Showing results for 
Search instead for 
Did you mean: 

Duplication job is failing with status code 228

john10
Level 6

Hi All,

We recently upgraded NetBackup Master/Media server from 7.0 to 7.6, after upgrading to 7.6 "nbsl &  NetBackup Vault Manager" are not coming up for the same i followed TECH55418 and rebooted the server from that time NBSL is up and running, but coming to "NetBackup Vault Manager" is not coming up and we configured Catalog backup initially to hard disk of Master server later will duplicate to Tape is failing with status code 228, could any 1 help me on this ?

Thanks in Advance

1 ACCEPTED SOLUTION

Accepted Solutions

john10
Level 6

HI All,

 

Thanks for your suggestion, 

finally Sym Engineer found the issue,

we found netbackup Directories in both D:\ & C:\ also , he just replaced the nblog.conf file in C:\ also , after that Vault is running fine and Duplication jobs also completing with out issue,

and i'm not able to see full NBU master server folders in C:\, i checked with local SA also, but they also havent aware as we are able to see the folders data in C:\  as 2011

nblog.png

View solution in original post

15 REPLIES 15

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Have you checked and confirm that NBU catalog/databases were in healthy state before the upgrade?
Have you checked that image header migration (as explained in NetBackup 7.6 Upgrade Guide  ) has completed successfully?

Have you verified that new 7.6 NBU Vault license is added to the master?

Have you checked Windows Event Viewer Application log for errors when you try to start the service?

About status 228 - this is what  NetBackup Status Codes Reference Guide says:

NetBackup status code: 228
Message: unable to process request
Explanation: An inconsistency exists in the catalog or a request was made that would be improper to satisfy.
Recommended Action: Do the following, as appropriate:
■ If this status involves a media server, verify that its server list specifies the correct master server. On a UNIX or Linux server, the master server is the first SERVER entry in the bp.conf file. On a Windows server, the master is designated on the Servers tab in the Master Server Properties dialog box.
See "Using the Host Properties window to access configuration settings" in the Troubleshooting Guide.
■ For detailed troubleshooting information, create a bpdbm debug log directory and retry the operation. Then, check the resulting debug log.

Have you checked bpdbm log yet?

john10
Level 6

Hi Marianne,

 

yes before upgrading i checked NBCC and it didnt not given any error or Logs, and coming License we had Vault key presented on server , 

and in my case master & media server are same 

please suggest what to check next i enabled the logs give 15 min i will upload them also

vault _licence_0.pngfailed_duplicatejob.png

john10
Level 6

Hi Marianne,

 

Below is the errors i found in eventvwr,

and when i try to up the services manually i got below error.

vault-error.png

 

OID:119:V-1-53 The LogDirectory setting for the given originator was not provided in the Logging configuration file.

The NetBackup Vault Manager service failed to start due to the following error: 
The service did not respond to the start or control request in a timely fashion.

john10
Level 6

Hi Marianne,

 

please find the bpdbm log attached below.

watsons
Level 6

I am trying to see what happens to your "netbackup vault manager" here.

You can ignore the "OID:119 V-1-53..." message because OID119 is for process bmrd, not nbvault.

But you can look into this file \netbackup\nblog.conf to see if you have the following for nbvault:

# 166. nbvault
166.L10nResource=nbvault
166.NtEventLogSourceName=nbvault
166.OIDNames=nbvault
166.LogDirectory=nbvault

There is a known issue in 7.6.0.2 (&3) about vault not accessible from the Java GUI but I wonder if it's the same with your situation: http://www.symantec.com/docs/TECH218104. Probably log a support case to have it check.

 

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

You seem to have a number of issues here.

Probably best to log a Support call with Symantec.

About status code 228 and bpdbm log:
I only see this one error in the log:

14:28:38.810 [5416.7232] <16> read_next_image: db_IMAGEreceive() failed: system call failed (11)

This does not help to see where/what the issue is. You will need to increase logging to at least level 3 (Symantec Support will ask you for level 5 logs) and restart NBU.

You may also want to perform an image consistency check.
Extract from Commands manual:

bpdbm -consistency [0-2]

Runs the consistency checks on the catalog. The following are the three consistency levels:

0 - A quick check of the NetBackup image database (the default).
1 - Performs more checks than the default check.
2 - The most in-depth consistency check. In addition to the level 0 and 1 checks,
this level checks that the media that is mentioned in the image exists. (That is,
it cross-references the media servers databases.) On a large NetBackup
installation, the process takes much longer to complete than the other checks.

 

john10
Level 6

Hi Watson,

 # 166. nbvault
166.L10nResource=nbvault
166.NtEventLogSourceName=nbvault
166.OIDNames=nbvault
166.LogDirectory=nbvault

is present in "nblog.conf" on Master, and for NBvault i alredy raised a case with Sym, so they asked me to patch it to 7.6.0.4 i did the same but still the same issue, and in eventvwr server is reporting to EID 7000 & 70009 so they are saying its problem with Microsoft is this correct ?

 

john10
Level 6

Hi Marianne,

for bpdbm -consistency please find the below attached Logs ,

and coming to bpdbm log, please confirm do i need to increase the logging level to 3 and recycle NBu and post the output log or after increasing the logging do i need to perform any operation in Master server ? 

 

 

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

You actually have 2 separate issues here that need 2 separate calls with Symantec:

1. Vault not starting

2. status code 228

Now that you are on 7.6.0.4 you need to request Support calls to be escalated.

We cannot comment on Event Viewer logs. You need to look at Event Source and start from there.

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

No errors in consistency check. So, this is good news.

bpdbm log shows status 11 before logging level was increased.

All you can dow now is to wait for status 228 again and then check bpdbm log again.

john10
Level 6

Hi Marianne,

Thanks for the conformation and agin we had failure for Duplication job with 228, im attaching the log again, please have a look on it .

john10
Level 6

Hi Marianne,

i found below error in bpdbm log, is this is the cause for error ? and in images path i can see only "as93w001" but not  "as93w001\S"

 

FYI

12:46:03.698 [740.7456] <4> ImageDelete::clean_stream: Unable to unlink stream file "D:\Program Files\Veritas\NetBackup\db\images\as93w001\S". No such file or directory (2)

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

This certainly seems to be a problem, although the message is a 'Notice' <4> and not an Error <16> like the status 11 at the beginning of the log.

Best to get the call with Symantec escalated.
This could be a problematic image header in the EMM database.
If so, it will require custom SQL script from Support to clear this up.

I can not see anything in the log that has to do with failed duplication.
For this we will need:
All text in Details tab of the failed job (not screenshot, please...)
admin log on master server
bpbrm logs on source and destination media server (if they are different)
bptm logs on source and destination media server.

PS: 
You really need to get your call(s) with Symantec escalated.
All of us trying to help here are doing so in our own time and do not always have the time to assist and read logs throughout the day...

john10
Level 6

Hi Marianne, 

Sure i loged a case with Sym too, and the failed job doest not have details in text,

john10
Level 6

HI All,

 

Thanks for your suggestion, 

finally Sym Engineer found the issue,

we found netbackup Directories in both D:\ & C:\ also , he just replaced the nblog.conf file in C:\ also , after that Vault is running fine and Duplication jobs also completing with out issue,

and i'm not able to see full NBU master server folders in C:\, i checked with local SA also, but they also havent aware as we are able to see the folders data in C:\  as 2011

nblog.png