cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR: file read failed BAR when browsing for restore

r1
Level 5

I am trying to do a restore for a windows 2008 client and when I launch the client BAR console I see the backups but when clicking one of them to restore , nothing shows up in the contents and i get this error "ERROR: file read failed"

 

I tried FQ names , upgraded the client binraries to match the server verion , restarted NBU , nothing works . In the bpcd log i see the following errors<4> bpcd

exit_bpcd: FTL - BPCD EXIT STATUS 46

11:07:36.383 [8420.6340] <16> process_requests: Server access denied

 

Much appreciate it

1 ACCEPTED SOLUTION

Accepted Solutions

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Where is restore initiated from? 
Client or master?
Is UAC disabled?

Please provide screenshots of entire process - from initial screen where you 'Specify NetBackup machines', all the steps up to where the error is seen.

Ensure bprd log folder exists on the master (under ..netbackup\logs) for troubleshooting.
Restart NBU after folder is created.

View solution in original post

25 REPLIES 25

r1
Level 5

See attachment for error that i get

SymTerry
Level 6
Employee Accredited

Are you also getting "bpcd valid_server: <your master server> is not a master server" or "bpcd valid_server: <your media server> is not a media server"The "Server access denied" error is what your looking for here. 

Check the media server name on the client's server list:

  • On Windows clients in the Specify NetBackup Machines and Policy Type dialog box, do the following: Add the server in the Server to use for backups and restores drop-down list. To display this dialog box, start the Backup, Archive, and Restore interface on the client. Then click Specify NetBackup Machines and Policy Type on the Filemenu.

  • On UNIX, Linux, and Macintosh clients, add a SERVER entry in the bp.conf file.

r1
Level 5

Yes i am seeing that error as well . the correct server name is listed , I even deleted it from the Server entry in the regedit and putthe IP address and Long name and still getting the same error .

watsons
Level 6

what is the OS of your master server?

If it's Unix-based, make sure the client name you have it's case sensitive.

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Where is restore initiated from? 
Client or master?
Is UAC disabled?

Please provide screenshots of entire process - from initial screen where you 'Specify NetBackup machines', all the steps up to where the error is seen.

Ensure bprd log folder exists on the master (under ..netbackup\logs) for troubleshooting.
Restart NBU after folder is created.

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Cannot be too much of a crisis?

Users who appear once every 4 years an then just disappear again...

r1
Level 5

Sorry was way to busy , this is still critical but have not had the time

- intiated from the cleint

-UAC is off, see screenshot , this iwindows 2008 server

- see attached svcreenshots

r1
Level 5

more info , client  ver 7.6.0.1

RonCaplinger
Level 6

Maybe check the Host Properties for the master server to make sure there are no Restore Failover entries referencing a media server that is not also listed as a valid media server on the client? 

Also check the General Server tab on the master server for a Media Host Override that could be trying to redirect the restore to an invalid media server.

r1
Level 5

responces

- No Restore server in the restore faiover tabe under hostproperies

- Media host override tab has nothing configured

Thanks

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

I just had a look at the screenshots that you posted. 

Blanking out everything without explanation doesn't really help...

Can you confirm that 'Server' entry at the top is the master server hostname?

Is Source and Destination client name the same as the local hostname on this client?
(Check 'hostname' and 'bpclntcmd -self' output from cmd.)

We still need the bprd log on the master server.
After the error is seen on the client, copy the log to bprd.txt and upload as File attachment.

About UAC - was the machine rebooted after disabling UAC?
Does this user have local admin rights on the client?

r1
Level 5

Can you confirm that 'Server' entry at the top is the master server hostname?

Ofcourse it is , if it wasn't I wouldn't be able to see any of the backup imageswith thier dates . I confirmed it is is the master server name

Is Source and Destination client name the same as the local hostname on this client?
(Check 'hostname' and 'bpclntcmd -self' output from cmd.)

Ran the command and all looks good

We still need the bprd log on the master server.
After the error is seen on the client, copy the log to bprd.txt and upload as File attachment.

Will upload on next post , it errors out on this post for some reason

About UAC - was the machine rebooted after disabling UAC?

Yes ,It has always been disabled and this server reboots once a month for patching
Does this user have local admin rights on the client?

I am the user and i am domain admin

 

r1
Level 5

Actually , i opened up the bprd log from the master , and last update is at 1:35 . Nothing after that and I have jus launched the BAR and got the error

01:35:41.306 [24773] <2> bpcr_get_version_rqst: bpcd version: 07600000
01:35:41.306 [24773] <2> bpcr_ex_client_cmd_and_verify: CLIENT_CMD_SOCK from bpcr = 10
01:35:41.306 [24773] <2> bpcr_ex_client_cmd_and_verify: CLIENT_STAT_SOCK from bpcr = 11

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Was NBU restarted after bprd log was created? Client connection requests will only be logged if bprd folder was in place when NBU Request Service was started.

Is 'bpclntcmd -pn' on the client returning correct info?

If comms between client and master is fine, then restore requests and above bpclntcmd command WILL be logged in bprd log (provided that the folder existed when Request Service (bprd) was started).

r1
Level 5
  • bounced services few minutees ago
  • bpclntcmd looks good , client name along with it's ip adddress coming back correctly
  • attached is the log you requested

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified
Please tell me what to look for in the log. What time did you try the restore from the client? What is client hostname/IP? I will download the zip file when I am on my laptop again (can only open .txt files on mobile device).

Pangal
Level 5

Hi,

          1) I am assumin you are running as administrator

           2) Also m assuming the output of bpclntcmd -pn , bpclntcmd -self, bpclntcmd -hn,  bpclntcmd -ip is good

          3) There is global attribute which permits client to do restore , hope that is checked

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

You need to tell us what to look for.

I found many browse requests from IP 10.80.63.129 (host sp102568) for various other clients (spnap1,  sp8vsql1, sp12sql3) but no restore request.

Is this the host (sp102568) where you are seeing the error? 

Is this host a Media Server or Windows Admin Console with Server entry for it on the master server?

If not this host, give us something to work with.
Give us a bprd log with evidence of failed restore request and tell us which host the request was coming from and more or less what time.

r1
Level 5

sp8smp is the name of the client , ip address ends weith .35 . The restore is not intiated and maybe that's why you are not seeing the restore request . The error message shows up when any of the restore images icons are clicked , I have already attached a screenshot of the error in my previous post and you can see in screenshot #3 that no restores is intiated , can't get to that point . Unable to select any files . all of the spXXXX names are workstations , we are not intitating the restores from any of those machines , i am running the restore from the client it self which in this case is sp8smp . Lastly, the bprd log i attached previously is a clean fressh log meaning .

- new log created(Empty)
- going to sp8smp and launched the BAR gui, selected the client "sp8smp" in the target and destntation , then when trying to browse , got the error message
- saved the bprd and sent it off to you

so everything you see in the log is a complete process of only that restore event .

We don't have a media server , sp102568 is not a media server , it is a workstation that has nothng to do with this restore . sp102568 is only plugged in the servers list under servers tab in the master server host properties . Hope I covered all your questions . Thanks