cancel
Showing results for 
Search instead for 
Did you mean: 

Error: Option path requires a valid argument value

Hill All,

Can you please help me to fix issue I'm facing when I try to update java on my windows media server with the command nbcomponentupdate.exe, I'm getting the Error: Option path requires a valid argument value.

c:\Program Files\Veritas\NetBackup\bin\goodies>nbcomponentupdate.exe -product NetBackup -component jre -path C:\JRE_Update\jre-8u271-windows-x64 -logpath C:\tmp -dryrun

 

Regards

 

5 Replies

Re: Error: Option path requires a valid argument value

Try path in double quotes and see it helps.

like

c:\Program Files\Veritas\NetBackup\bin\goodies>nbcomponentupdate.exe -product NetBackup -component jre -path "C:\JRE_Update\jre-8u271-windows-x64" -logpath C:\tmp -dryrun

Re: Error: Option path requires a valid argument value

hi @Brigard 

Please also take care to ensure that dashes are really dashes and not something that looks similar. This typical happen when copying and pasting from word.

Re: Error: Option path requires a valid argument value

Hello Ramnagalla,

I tried as suggested, but I'm getting the same error message.

Please assist.

Regards

Re: Error: Option path requires a valid argument value

@Brigard 

Disclaimer:
I have never tried to use this command.
I am trying to assist based on what I see in the Commands Reference Guide:

https://www.veritas.com/support/en_US/doc/15263389-132009154-0/v121626809-132009154

It seems you first need to determine which Java version is installed with your version of NBU, and then use this command to update a 'minor version' to a 'major version':

The NetBackup installed version of the JRE is the supported major version for that NetBackup release. Use this utility to update to a minor version of the supported major JRE version. For example, if NetBackup 8.0 installed JRE 1.8.0.31, the supported major version is 1.8. Use this utility to update to JRE 1.8.0.92.

Veritas recommends that you update to another major JRE version only if the JRE vendor declares an end-of-life for the installed JRE version. For example, if the JRE vendor declares an end-of-life for JRE 1.8, which is also the installed JRE version in your environment, update to JRE 1.9.

What exactly do you have in C:\JRE_Update\jre-8u271-windows-x64 ?
The path should be a folder that contains the extracted JRE folder.

-path component_path

Specifies the path where the new version of JRE for the upgrade is located. The component_path is either the installed JRE location or the extracted JRE folder.

It seems that only specific Java versions are supported for each NBU version as per the Command Ref Guide.
So, either something wrong with the contents of the folder that you specified, or perhaps unsupported Java version (but then I'd expect the error message to be different).

 

Re: Error: Option path requires a valid argument value

Hello Marianne,

I used the the same Commands Reference Guide to performe the update, it works for Linux but with windows I'me getting this error.

Installed version : 1.8.0_101
Fixed version : 1.7.0_281 / 1.8.0_271 / 1.11.0_9 / 1.15.0_1

OS: Windows Server 2012 R2 Datacenter

Regards