Highlighted

Exclude list not excluding the additions I've added

I'm using Netback 8.0 for the master. For a few of the policies, I've added a folder or two to the Exclude list for the related clients. I'll add and apply them. When I check back later the same day, the Exclude list shows my additions. The next morning, however, the Exclude lists are back to their previous state and don't include my additions. The first time this occurred, I thought that I had forgotten to click Add and Apply; but I'm positive I did it correctly the next yesterday. This morning, my additions were missing again.

 

Anyone have any idea why this is occurring?

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: Exclude list not excluding the additions I've added

Thanks for the responses.

It turns out that our SAs make updates to the servers using Puppet. This overrides any changes that I made to the Exclusion list. Their going to add our Exclusion functionality to Puppet so that we can get the exclusions to stick. 

View solution in original post

4 Replies
Highlighted

Re: Exclude list not excluding the additions I've added

Only idea I have is a open BAR gui somebody else is using. 

scenario is as follows:

User 1 open BAR GUI and go to exclude list

You update the exclude list

User 2 click "ok" instead of "Cancel" and the old exclude list values are written to registry.

Re: Exclude list not excluding the additions I've added

I believe you are checking only on the GUI side.

Check using command bppllist <Policy name> -L if the exclusions are still not present...

Also you can enable bpbkar logs and see if your exclusions are working

Highlighted

Re: Exclude list not excluding the additions I've added

Exclusions are not configured in NBU policy - it is done via Host Properties.

The properties will update the Registry on the client.
Entry can also be update via BAR GUI on the client itself or by editing the registry directly.
So, if the Exclude List that was updated is 'different' or removed the next day, you need to find out what is happening on the client. Maybe software that is preventing registry updates? 

You can check the Registry on the client :
Regedit -> HKLM\Software \Veritas\NetBackup\CurrentVersion\Config
Open 'Exclude'

If it still resets after using regedit, you need to troubleshoot on the client. Talk to Sysadmin...

Highlighted
Accepted Solution!

Re: Exclude list not excluding the additions I've added

Thanks for the responses.

It turns out that our SAs make updates to the servers using Puppet. This overrides any changes that I made to the Exclusion list. Their going to add our Exclusion functionality to Puppet so that we can get the exclusions to stick. 

View solution in original post