cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Issue while configuring tape drive robot on clustered master server

Hi Team,

It will be great help if anyone can help on below issue.

I have one old clustered master server which is on 7.7.3 version which are going to decommissioned in 1 month.First we have started decommissioning media server. It has only one media server which is RCH now. Before proceeding on decommissioing RCH, i am trying to move RCH to master server. This is a clustered master server and it has 2 nodes active and passive. Zoning is done and i can see tape drive and robot on master server node. While doing robot/tape drive configuration using wizard, i am not getting active node name listed in the list where i need to select RCH, however virtual name is listed there. I tried configuring by selecting virtual name, it has given me error "Invalid host(88) : host is not defind in EMM". Please help on it. Details are given below.

vmoprcmd -devmon hs command output (it listed only one node which is passive node and one media server which we will decomm first)

HOST STATUS
Host Name Version Host Status
============================
masternode2 773000 ACTIVE-DISK

nbumedia 773000 ACTIVE-DISK

 

emmcmd -listhost output:

cluster nbumaster
server nbumaster
master masternode2
master masternode1

 

Tags (2)
5 Replies
Highlighted

Re: Issue while configuring tape drive robot on clustered master server

Hi,

on a clustered master server, RCH will be tagged to virtual name and wont show active node name. However, it might be necessary for you to run device configuration wizard when you failover to the other node.

Hope it helps.

 

Highlighted

Re: Issue while configuring tape drive robot on clustered master server

@Born2rise 

Please double-check that you have correct licenses added for all nodes. 

You need to have Library-based tape drive licenses added. 

This status looks like this license might be missing:  ACTIVE-DISK

Highlighted

Re: Issue while configuring tape drive robot on clustered master server

@Born2rise 

One more thing -
Please be sure to go through 'Device configuration guidelines' and  'Configuring devices ' in Veritas NetBackup™ Clustered Master Server Administrator's Guide.

This section says that you need to configure devices on the active node, then fail over and repeat device config, because device paths will most likely be different on the 2 nodes. 

Highlighted

Re: Issue while configuring tape drive robot on clustered master server

Thanks for checking on it.

We have license for library. Status is showing as Active Disk as i have deleted robot and tape drives from media server and it is used for disk storage only. Also passive node does not have any tape drive configuration.

I tried to follow the recommended steps. It says to use node name to select for RCH but the problem is Active node name is not showing in device cofiguration wizard.

I tried to add robot and tape drive using command line.. Luckily, i am able to configure it and inventory using commandline is also completed and virtual name is showing as RCH. But the problem is, i am not able to create the storage unit of it beacause TLD is not visible in storage unit creation window and also this TLD is not visible while performing inventory using GUI. I bounce the services on master server but no luck.

If we can do something which show active node of master server in vmoprcmd -devmon hs command then i think, it will help to check the status of active node wheather it is active disk or active tape.
Highlighted

Re: Issue while configuring tape drive robot on clustered master server

The HOST STATUS from nbemmcmd -listhosts -verbose is supposed to reflect licensed features, not configuration details.

I have been once on a particular site with a clustered master server where I had issues with host status and device config. 

This worked for me: 

nbemmcmd -updatehost -machinename <media_server> -machinestateop set_tape_active -machinetype media -masterserver <master_server>
(media_server will be the active nodename and master_server the virtual hostname)

Next, run device config wizard from cmd: 
vmoprcmd -h <media-server> -timeout 3600 -autoconfig -a

Restart MM processes (stoplid ; ltid -v) 
You may need to freeze the cluster to prevent failover or restart action by the cluster.