cancel
Showing results for 
Search instead for 
Did you mean: 

Medias are not automatically moving to scratch volume pool.

ROHIT_KUMAR_AGA
Level 3
Certified

Some medias in my 7.1.0.4 Netbackup environment have Data Expiration and Time Assigned filed empty with Robot Type as NONE means these are scratch medias but these are showing in different-diferent volume pools but not in scratch. 

1 ACCEPTED SOLUTION

Accepted Solutions

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified
Media will only return to Scratch if they came from Scratch. Have a look at Previous Pool field in this output : nbemmcmd -listmedia -mediaid (media-id ) Only if Previous Pool is listed as Scratch will they go there when expired. You will need to move all expired tapes manually to Scratch. From there on they will automatically go to Scratch when all images expire.

View solution in original post

6 REPLIES 6

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified
Media will only return to Scratch if they came from Scratch. Have a look at Previous Pool field in this output : nbemmcmd -listmedia -mediaid (media-id ) Only if Previous Pool is listed as Scratch will they go there when expired. You will need to move all expired tapes manually to Scratch. From there on they will automatically go to Scratch when all images expire.

View solution in original post

mph999
Level 6
Employee Accredited

nbemmcmd -listsettings -machinename <master server name> also has a setting:

RETURN_UNASSIGNED_MEDIA_TO_SCRATCH_POOL="yes"

It is not likely this is set to 'no' as 'yes' is the default, but none the less, it is another possible reason that media may not be returning to scratch, though the reason given by Marianne is, in my experience at least, the most common.

ROHIT_KUMAR_AGA
Level 3
Certified

Thanks Marianne for the response....

The Previous Pool Name field in below output is blank (-) and the media is showing in another pool now (not scratch).
nbemmcmd -listmedia -mediaid (media-id )

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified
You will have to manually move these tapes to Scratch. This will be a once-off. From there on expired tapes will be returned to Scratch.

Nicolai
Moderator
Moderator
Partner    VIP   

How may mount does the tapes in qustion have ?

If tapes get frozen upon first mount, they will be assigned to a pool but with no Data Expiration/Time Assigned. If that is the case, simply unfreeze the tapes.

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Good point about Frozen tapes.

The most common problem I've seen is where Scratch pool was added after tapes were already in use.

Tapes can only go back to Scratch. 

Note the RETURN in RETURN_UNASSIGNED_MEDIA_TO_SCRATCH_POOL="yes" setting.....

If 'Previous Pool' field is blank, then tapes were not originally in Scratch.

All expired tapes need to be moved to Scratch as a once-off.