cancel
Showing results for 
Search instead for 
Did you mean: 

NBU 7.5 Recommended device drivers for IBM LTO4 tape drives

Willie_SA
Level 6
Partner Accredited

What is the recommended device drivers for IBM LTO4 drives with NetBackup 7.5.0.6 ?

SAN media server is HP server - W2008 R2 Service Pack 1

Currently using IBM driver 6.2.3.6

 

Symptoms:

When Media server are bounced - it does not go down UNTIL the drives are being Disabled via the Device manager.

When Enabling the drives again it takes very very long.

 

Any advise?

 

 

8 REPLIES 8

sksujeet
Level 6
Partner Accredited Certified

It is recommended to use latest drivers of the Vendor

When Media server are bounced - it does not go down UNTIL the drives are being Disabled via the Device manager.

YOu mean you are not able to power dow the server if the drivers are enabled? Which OS and hardware you are running.

Gracefull shutdown of server which is very busy or running appliation will take some time to disconnect all the connection and will shut down. How long you waited and what it generates in the event viwer

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

According to NBU 7.x HCL, Symantec has tested driver version 6.2.1.7.

There are also other instructions for IBM tape drivers in the HCL:

IBM Tape Driver Support
The latest version of the IBM tape device driver package that has been tested with NetBackup is listed below. Using the version listed here is recommended, but older versions of the tape drivers are also supported and may work well. There is no need to upgrade the tape driver if the configuration is working properly. Upgrading to the version listed here may be necessary if implementing the latest model tape drives or if problems are encountered that have been addressed by the driver provider.

If using the IBM Windows Tape Device Drivers be sure to choose the install_nonexclusive.exe executable. This option permits a tape drive to be accessed by multiple processes on a Media Server, which is a requirement for NetBackup.
NetBackup requires the IBM Data Path Failover feature to be disabled on the IBM tape device driver. To disable this feature, open the reg folder of the IBM driver package, double-click DisableDPF.reg, and reboot the system.
- IBMTape driver level 6.2.1.7 tested on Windows
 
 
Please also check HBA make/model/driver - IBM should have a compatibility matrix on their web site.
Confirm that tape and disks are zoned to different HBA's.
Some HBA vendors have recommended settings for use with tape.
These recommendations can usually be found on the vendor's web site.
 
Hope this helps!

Willie_SA
Level 6
Partner Accredited

Thank you for the replies.

The claim was made that when the server was restarted(down and up) normally - it did not go down - until they went in again in safe mode and disabled the drives. This was after 30 minutes.

 

My experience - on the side to enable the drives again.

I enable via the Server Manager / Device monitor.

It takes +- 15 minutes for the screen to return from hour glass. When you then close the window and open again - the drive is enabled.

During the 'enable time' you cannot do anything in that Server Manager window.

It is as if the Enable process takes _= 15 minutes to complete the enable process.

 

 

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Maybe uninstall and reinstall drivers as per above documentation?

When system is accessible again, check Windows Event logs for errors during period that problems were experienced - especially System log.

Please check hba drivers/settings as well. 

Willie_SA
Level 6
Partner Accredited

I uninstalled the drivers.

When re-installing with command _exclusive or _nonexclusite _ it times out. Coming up with message:

Exiting application.

Program stopped prematurely due to error(s).
If the debug flag was set, check debug.txt for details.

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

Anything in Event Viewer Application and/or System log?

This server does not sound healthy... Problem more wrong than just IBM drivers.
Hopefully something useful in Event Viewer.

Willie_SA
Level 6
Partner Accredited

I tried re-doing this last night in hopefully a quieter rime.

Still times out.

I found via the Task manager / Performance that the memory of the server is 99% utilized all the time.

The process store.exe is taking ALL the memory it can get on the server - but according to internet research - this is as per design.

Think this might have the effect on my timeout condition.

I asked the server owners for feedback.

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

The 99% memory utilization will make this server unsuitable as media server.

NBU bptm and bpbrm processes will also need system resources, not to mention bpbkar that needs to generate data stream...