[NBU 8.1.2.0] - Silent install failed.

Hello team,

we try to deploy Netbackup client 8.1.2.0 silently with Bladelogic automation.

We have always this :

+ 01-09-2019,19:38:25 : Action ended 19:38:25: INSTALL. Return value 8.
01-09-2019,19:38:25 : The following processes are currently running on the system:
01-09-2019,19:38:25 : [0]:[System Process]
01-09-2019,19:38:25 : [4]:System
01-09-2019,19:38:25 : [336]:smss.exe
01-09-2019,19:38:25 : [424]:csrss.exe
01-09-2019,19:38:25 : [492]:wininit.exe
01-09-2019,19:38:25 : [504]:csrss.exe
01-09-2019,19:38:25 : [548]:winlogon.exe
01-09-2019,19:38:25 : [2008]:svchost.exe
01-09-2019,19:38:25 : [2016]:8003-CsInstallerService.exe
01-09-2019,19:38:25 : [2024]:nscp.exe
01-09-2019,19:38:25 : [1008]:msiexec.exe
01-09-2019,19:38:25 : [4280]:msiexec.exe
01-09-2019,19:38:25 : [5068]:conhost.exe
01-09-2019,19:38:25 : [888]:SETUP.EXE
01-09-2019,19:38:25 : [380]:VxLogServer.exe
01-09-2019,19:38:25 : [1204]:cmd.exe
01-09-2019,19:38:25 : [4152]:powershell.exe
01-09-2019,19:38:25 : Action ended 19:38:25: INSTALL. Return value 8.
01-09-2019,19:38:30 : Another installation is already in progress on server 'MyServerName'. Complete that installation before proceeding with this install.

None of you encounter the same error ?

 

Thx for your help.

4 Replies

Re: [NBU 8.1.2.0] - Silent install failed.

Hi

Ok. So before starting the install process, it is safe to restart the server. May be your there is a pending reboot.

If this issue still occur :

Open Windows Registry Editor. Click Start > Run, type regedit, and click OK.
Back up the registry.

In the left pane, navigate to the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer.
In the left pane, right-click on the Inprogress key, and click Delete.
Click Yes to permanently delete the entire Inprogress key and all of its subkeys.
Close Windows Registry Editor.
Open Task Manager. Click Start > Run, type taskmgr, and click OK.
Click the Processes tab.
Locate and right-click any occurrence of msiexec.exe, and click End Process.
Run the installer again
Highlighted

Re: [NBU 8.1.2.0] - Silent install failed.

Thx @ElGringo for your help.

We have try to reboot the server before the installation.
We have also check the registry.

But the error persist.

Re: [NBU 8.1.2.0] - Silent install failed.

This is actually Microsoft preventing NBU installation, as it believes another Windows Installer process is already running.

Troubleshooting therefore needs to be done from a Microsoft point of view.

I found the following suggestion on a Microsoft forum:

1. Click Start->Run, type "regedit.exe" in the Open box, and click OK.

2. Navigate to HKEY_LOCAL_MACHINE\System\Setup"

3. If there is any key or values named "FactoryPreInstallInProgress", please right click and delete it.

4. Repeat the above steps to delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory

See if this helps.

Re: [NBU 8.1.2.0] - Silent install failed.

Hello,

Confirmed that HKEY_LOCAL_MACHINE\System\Setup\FactoryPreInstallInProgress and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory are not in my system but still experiencing intermittent Return value 8 (Another installation is already in progress.).

By the way, we are automating the installation of NBU agent and we are getting an intermittent result (3/5 success rate)