cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

NBvwcPlugin Install

I went through the documentation and followed along on the web install instructions, but step 8 seems to be a no go for me. When I login to the Web Client there is no Netbackup data in there at all. Not sure what I may have missed here, but if anyone has any info it would be greatly appreciated.

https://www.veritas.com/support/en_US/article.000095689

You can see below that I have both the thick and web client plugins installed, but for some reason nothing is showing up in the web client.

plugins.png

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Re: NBvwcPlugin Install

Sorry I had forgot about this post. Apparently the Web Client plugin doesn't seem to utilize DNS at all. The fix for me ended up being some changes for the name setup. I can't recall what all I changed, but I believe I deleted and recreated the certs used until the names were just right which allowed the master, vcenter host and plugin to communicate.

View solution in original post

8 Replies
Highlighted

Re: NBvwcPlugin Install

I did find this...

NetBackup plug-in not shown in vSphere Web Client
portal even after registration
If the plug-in is hosted on an HTTP site instead of an HTTPS site, you need to make
the vSphere Web Client trust the HTTP connections. If not, the connection does
not download and deploy the plug-in. To build this trust, add following directive to
the webclient.properties file:
allowHttp = true
The webclient.properties file can be located in the following directories:
Windows:C:\ProgramData\VMware\vSphere Web Client\
Linux: /var/lib/vmware/vsphere-client

Mine is definitely http as the install instructions said that it could be either or. The web client host here is an appliance so this fix isnt suitable as you cannot edit the settings on it.

Highlighted

Re: NBvwcPlugin Install

 

The appliance is SUSE Linux so shouldn't you able to edit there...

 

 

Highlighted

Re: NBvwcPlugin Install

What was the web host for the plugin? I have seen the plugin install GUI accept a url without the plugin actually being hosted by the web host and then mark the process as finished.

Highlighted

I'm not quite sure what that

I'm not quite sure what that question means. I dropped netbackup-vwc-plugin.zip in the C:\inetpub\wwwroot location for the default website. I also just this morning went ahead and got a certificate for it so it is now HTTPS. I unregistered it and then went through the process again using https this time and it still does not work.

Highlighted

Re: NBvwcPlugin Install

We had the same problem. After uncountable attempts of un- and re-registering, trying with and without https, I found the article "After successful installation and registration of the NetBackup plug-in, it does not appear in the v..."

As described there, I created a folder com.symantec.netbackup.plugin-7.7.2 (we're using the latest NetBackup version) in the vsphere-client-serenity folder on our Windows vSphere Web Client Server. In this folder I copied the extracted content of the netbackup-vwc-plugin.zip. It still had to restart the server, because a simple logoff/logon on the vSphere Web Client seemed not to be enough.

But now it finally works.

---

And by the way, for a clean removal of Web Client plugins I followed the description on "Removing or Disabling unwanted plug-ins from vCenter Server and vCenter Server Appliance". In my eyes using the Java application does not make a clean unregister. I found all the versions of the plugin form our earlier installations.

Highlighted
Accepted Solution!

Re: NBvwcPlugin Install

Sorry I had forgot about this post. Apparently the Web Client plugin doesn't seem to utilize DNS at all. The fix for me ended up being some changes for the name setup. I can't recall what all I changed, but I believe I deleted and recreated the certs used until the names were just right which allowed the master, vcenter host and plugin to communicate.

View solution in original post

Highlighted

Re: NBvwcPlugin Install

Having the same problem and tried all the above methods and failing

Environment Overview

vSphere 6.0 u1b PSC External Appliance

vSphere 6.0 u1b vCenter Server Appliances (Two)

vSphere 6.0 u1b ESXi Hosts (Many)

NetBackup 7.6.1 Master Server running on Windows 2012R2

NetBackup 7.6.1 Media Server running on Windows 2012R2

 

NetBackup vCenter Plugin Virtual Appliance (OVA) works well for the Classic C vSphere Client. However, installing and setting up the plugin for vSphere Web Client is a completely different story and my preferred option is to have the Web Client version working!

I, like many have registered / un-registering / re-registering this Web plug-in, unzip netbackup-vwc-plugin.zip into var/lib/vmware/vsphere-client on both vCenter Appliances all fail. Now I'm getting vops stack errors (probably a separator issue)

However, when I login as adminsitrator@vsphere.local I can view Servvices 'Netbackup Plug-In for vSphere Web Client (server1.somewhere.here) and (server2.somewhere.here) in the Administratration\Deployment\System Configuration  \Services panel. Stopping and Starting Servers etc. are all greyed out.

 

Highlighted

Re: NBvwcPlugin Install

I m having the same issue and  tried all the  suggestions given above. Even i doubt the ability of the plugin to do name resolving , but how did u fix the issue with the name resolution , is there a way to setup some local hosts entries with vcenter web plugin ?