cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

NDMP Verification TPAutoconf - Node-Scope

I am trying to setup NetBackup 7.7 (trial) and connecting to Netapp 8.2.2 cDOT mode. I believe I have everything setup but I am only able to see one node in the NetApp cluster. When I have node-scode-mode on I can see "the" node and all of its volumes. but when I turn it off I can't see anything. I believe I am using the right LIF IP, I have tried it several different ways.

When I have node-scope-mode off I get

C:\Program Files\Veritas\Volmgr\bin>tpautoconf -verify 10.5.10.107
Connecting to host "10.5.10.107" as user "admin"...
Waiting for connect notification message...
Opening session--attempting with NDMP protocol version 4...
Opening session--successful with NDMP protocol version 4
  host supports MD5 authentication
Getting MD5 challenge from host...
Logging in using MD5 method...
ndmp_connect_client_auth failed
: host "10.5.10.107" failed
NDMP failed to verify host

But when I turn it on I get

 

C:\Program Files\Veritas\Volmgr\bin>tpautoconf -verify 10.5.10.107
Connecting to host "10.5.10.107" as user "admin"...
Waiting for connect notification message...
Opening session--attempting with NDMP protocol version 4...
Opening session--successful with NDMP protocol version 4
  host supports MD5 authentication
Getting MD5 challenge from host...
Logging in using MD5 method...
Host info is:
  host name "jacksondr-03"
  os type "NetApp"
  os version "NetApp Release 8.2.2 Cluster-Mode"
  host id "2014569956"
Login was successful
Host supports LOCAL backup/restore
Host supports 3-way backup/restore

 

What am I missing? I have read the documentation and it all seems setup correctly. I am currently backing it up using Backup Exec but I want to be able to use the clustering capabilities on the NetApp side.

 

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

Sorry Brian for the delayed

Sorry Brian for the delayed response.  node-scope-mode is a requirement if you need CAB(cluster aware backup). This is something very recently introduced in the Netbackup with version 7.7. So you should be able to back it up with this version.

You need to make sure that the NDMP is enable with all the nodes present with the cluster. Can you please check output of system services ndmp show and paste it. You should be able to see all nodes present in the cluster in the output.

Also can you please try the tpautoconf command for each of node-mgmt LIF and cluster-mgmt LIP.

Also consider following while choosing correct LIF for the backup

"""

There should be at least one intercluster LIF for each node of the cluster that does not host a cluster-management LIF. This is required for three-way and remote backups. If you do not specify an intercluster LIF, all of the three-way and remote backups for volumes that are not hosted on the same node as the
cluster-management LIF fail. NetBackup does not access these LIFs directly, so it does not need credentials for them.

"""

View solution in original post

3 Replies
Highlighted

Anybody have any thought on

Anybody have any thought on thiss?

Highlighted
Accepted Solution!

Sorry Brian for the delayed

Sorry Brian for the delayed response.  node-scope-mode is a requirement if you need CAB(cluster aware backup). This is something very recently introduced in the Netbackup with version 7.7. So you should be able to back it up with this version.

You need to make sure that the NDMP is enable with all the nodes present with the cluster. Can you please check output of system services ndmp show and paste it. You should be able to see all nodes present in the cluster in the output.

Also can you please try the tpautoconf command for each of node-mgmt LIF and cluster-mgmt LIP.

Also consider following while choosing correct LIF for the backup

"""

There should be at least one intercluster LIF for each node of the cluster that does not host a cluster-management LIF. This is required for three-way and remote backups. If you do not specify an intercluster LIF, all of the three-way and remote backups for volumes that are not hosted on the same node as the
cluster-management LIF fail. NetBackup does not access these LIFs directly, so it does not need credentials for them.

"""

View solution in original post

Highlighted

Thanks SymGuy-IT Here is the

Thanks SymGuy-IT

Here is the output for NDMP

Node                  Enabled   Clear text  User Id
--------------------- --------- ----------- ---------
jacksondr-03          true      false       admin
jacksondr-04          true      false       admin
2 entries were displayed.

i read node-scope has to be turned off if you want to see the cluster. Node-scope ON is for individual filer/vservers to be shown, this is how we currently back it up, with it on.

 

jacksondr:Smiley Embarassed network int show
            Logical    Status     Network            Current       Current Is
Vserver     Interface  Admin/Oper Address/Mask       Node          Port    Home
----------- ---------- ---------- ------------------ ------------- ------- ----
jacksondr
            cluster_mgmt up/up    10.5.10.100/16     jacksondr-03  e4a     true
            ndmp_bkp     up/up    10.5.10.107/16     jacksondr-03  e4a     true
jacksondr-03
            clus1        up/up    169.254.14.58/16   jacksondr-03  e1a     true
            clus2        up/up    169.254.183.110/16 jacksondr-03  e2a     true
            intercluster_lif
                         up/up    10.9.10.108/16     jacksondr-03  e0a     true
            mgmt1        up/up    10.5.10.110/16     jacksondr-03  e4a     true
jacksondr-04
            clus1        up/up    169.254.140.120/16 jacksondr-04  e1a     true
            clus2        up/up    169.254.127.31/16  jacksondr-04  e2a     true
            intercluster_lif
                         up/up    10.9.10.109/16     jacksondr-04  e0a     true
            mgmt1        up/up    10.5.10.111/16     jacksondr-04  e4a     true

 

As I said above, I can see one vserver with node-scope on, but off I get "ndmp_connect_client_auth failed". If node-scope is on then according to you I should see both jacksondr-03 and 04, which is not the case.

Using tpautoconf to view both mgmt LIFs I get failed to verify host. Do I not have to have it in NetBackup first?