NetBackup 7.6 Duplication Error

Hi,

I am fairely new to Netbackup Solution and having some issues that i am looking to get some answers from the community would really appreciate if someone can advise on this.

I have configured a Disk Backup for AD granular recovery with an SLP to duplicate jobs to LTO5 Tape Library ( Image attached). when duplication jobs are started it's failing with an error

"unable to allocate new media for backup, storage unit has none available(96)"

Detail Status:

10/01/2017 02:01:09 - requesting resource LCM_b52-hcart3-robot-tld-1
10/01/2017 02:01:10 - begin Duplicate
10/01/2017 02:01:10 - granted resource LCM_b52-hcart3-robot-tld-1
10/01/2017 02:01:10 - started process RUNCMD (10696)
10/01/2017 02:01:10 - ended process 0 (10696)
10/01/2017 02:01:10 - requesting resource b52-hcart3-robot-tld-1
10/01/2017 02:01:10 - requesting resource @aaaaz
10/01/2017 02:01:10 - reserving resource @aaaaz
10/01/2017 02:01:12 - Error nbjm(pid=7508) NBU status: 96, EMM status: No media is available
10/01/2017 02:01:12 - Error nbjm(pid=7508) NBU status: 96, EMM status: No media is available
10/01/2017 02:01:12 - Error nbjm(pid=7508) NBU status: 96, EMM status: No media is available
10/01/2017 02:01:13 - end Duplicate; elapsed time: 0:00:03
unable to allocate new media for backup, storage unit has none available (96)

 

according to the detail this job is looking for a completely different robot in this case (LTO3), if i have configured SLP to use LTO5 robot why is this still looking for a different resouce library.

*scratching my head*

Please help!

 

6 Replies
Highlighted

Re: NetBackup 7.6 Duplication Error

Maybe you still have some pending SLP operations which was configured on the LTO3 library, check them and cancel any pending oprtations - if they not required anymore - by command: nbstlutil cancel -lifecycle xxx

More details of SLP commands can be found on below article:

http://www.veritas.com/docs/000013928

 

Thanks

Khalid 

Re: NetBackup 7.6 Duplication Error

@Khalid_Mashaykh 

Thank you for your Prompt Response, 

Resolve this issue i had two different versions of SLP Server Backedup using old SLP were configured to use LTO3 robot and LTO5 Volume Pool (awesome configuration)

Nbstl -L -all_versions  shows all SLP 

Nbstl add_backup -L -all_allversions  - for all versions of SLP

nbstl ADDS_Backup -modify_version -version 1 -residence "DefineStoragePool" , "name of robots"

Worked for me. 

but thank you for responding. Much appreciated.

Re: NetBackup 7.6 Duplication Error

If you have recently changed the SLP, then incomplete previous duplications will still look for the storage that it was configured to use at the time. 

 

You can use this TN to list all versions and then modify old version:
http://www.veritas.com/docs/000019913

PS: 

Why did you you configure Daily and Monthly duplications to use WEEKLY as source?

 

Re: NetBackup 7.6 Duplication Error

@Marianne

Configured SLP for the first Marianne, I think I've not followed the admin guide very well. but thank you for pointing this out, Just answered another issue I was having. 

Thank you. 

Re: NetBackup 7.6 Duplication Error

That looks much better... 

Remember that you have now added another SLP version! 

Re: NetBackup 7.6 Duplication Error

@Marianne 

Thank you for your help and sanity checking Smiley Happy