cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

NetBackup Plugin does not appear in the vsphere web client

Today, I attempted to set up the NetBackup Web Plugin with my customer for the first time. These were our steps as documented in the manual and in the NBU7.7.2 BluePrint Plug-in for Vmware Vsphere - Apr 2016

 

1. We downloaded the Plugin from My.Veritas V.7.7.3
2. We checked that web services were enabled on the 5230 appliance, which is our master / Media Server using the setupWmc command.

3. We checked what ports were configured for the web services uisng the configurePorts command.

ports

8080

8443

8205


4. We generated the authentication token on the appliances for each vcenter. using the Credential Create Command on the appliance.
5. We installed IIS web services v8 on a virtual machine running Windows 2012 and set up the virtual directory to the .zip file, and verified the link works for downloads on the network. http://<redacted>/netbackup-vwc-plugin/netbackup-vwc-plugin.zip
6. We ran the pluginutil.Jar program and registered the plugin.
7. The plugin does not appear in vcenter. It does not appear on the list of disabled plugins, nor can we search for it. We noted an error in the vsphere-client-virgo.log file that the zip file was empty. (It was not empty, the .zip file cotains the plugin's files. We believe something is going wrong when the file is downloaded or during the install that we cannot solve. The logs are not giving a clear answer and the registration script completes without any errors. )
8. We enabled http for vsphere by adding it to the web.client.properties file and restarting all of the services (Vcenter and ESXi are all at 6.0)
9. We unregistered and re-registered the plugin.
10. The plugin still does not appear in the vsphere web client.

 

Any information  of what could possibly be the problem would be very apreciated. 

6 Replies
Highlighted

Re: NetBackup Plugin does not appear in the vsphere web client

Hi,

 

Try this. I also had an issue where it was showing up. 

 

https://www.veritas.com/support/en_US/article.000081472

Highlighted

Re: NetBackup Plugin does not appear in the vsphere web client

Unfortunately, we found that page and followed the instructions on it before opening this post. The odd thing is that the c-sharp plugin works perfectly. the web plugin stubbornly won't show up no matter what changes we make. I have an open case with Veritas. So far we are stuck.

Highlighted

Re: NetBackup Plugin does not appear in the vsphere web client

Were you able to get anywhere with this?  We are having a similar issue.

Highlighted

Re: NetBackup Plugin does not appear in the vsphere web client

Hello All,

I had the same issue that you all reported in this discussion with NetBackup 8.0 web client plugin and the solution was to follow the technote below and restart the web client service after that.

https://www.veritas.com/support/en_US/article.000081472

Kind Regards
David

Highlighted

Re: NetBackup Plugin does not appear in the vsphere web client

Hi @dtrostli1

would be better you start a new topic, because this is very old.

 

Thiago

Highlighted

Re: NetBackup Plugin does not appear in the vsphere web client

Hello All,

Forgot to mention that I also did a chown -R vsphere-client:users in the folder outlined in the technote forementioned.

Regards

David