NetBackup VM Backup

Hi,

The backup of few VM servers are getting failed if the VMTools services are running on the server. The quiescing option is enabled for all the VM backups. 

 

1 Solution

Accepted Solutions
Accepted Solution!

Re: NetBackup VM Backup

You don't have to reinstall NetBackup. There's an installation program called "Veritas VSS Provider for vSphere" in NetBackup\bin\goodies. If you run it, it will reinstall the Veritas provider, and NetBackup will use the Veritas provider rather than the VMware provider.

I think there's a way in the VMware Tools console to tell whether their VSS Provider is in place. I haven't checked in a long time.

You can tell from the application event log on the VM that the Veritas VSS provider is used in your VMware backup. You should see events for it starting and stopping. It may still have one of the old names in the event log.

View solution in original post

14 Replies

Re: NetBackup VM Backup

@ANURAG2840 apologies, but I didn't quite understand, plus you didn't really give us much to go on.  Please can you take a little more time to restate the problem, and please also provide error output.  Thank you.

Re: NetBackup VM Backup

HI SDO

The query is that in order to take a quiesced VM backup the VMTools services call the VSS services of the host. If the VMTools services are running on the host, few VM backups are getting failed (4 to 5). Stopping the VMTools on these hosts allow the VM backups to complete successfully. The VMBackups of all other server are going as usual with both the VMTools and VSS services running simultaneously.

 

Highlighted

Re: NetBackup VM Backup

@ANURAG2840so I understand that some of your VMs are failing backup. And "stopping" the VMTools service on these guests allows the backup to run succesfully.

If the above is correct, it still does not give enough information for anyone to help you. (if I understood incorrectly, then you still haven't detailed the problem correctly).

You can at least give details of the backup policy you use (which options you are using to configure the VMware policy) and attach the details of the failed job. You need to help us to help you.

 

 

Re: NetBackup VM Backup

My understanding was that having VMTools installed and working and running was a requirement for clean VSS aware backups.

IMO stopping or killing VMTools simply to overcome an unwanted error, and to thus "appear" to achieve a clean backup, is not a good move.  It is all actually meant to work together.  If there was no need for VMTools then it wouldn't even exist.  Personally, I wouldn't trust that your now supposedly working backups are actually safe.  Yes, you might be able to restore test, and the restore might appear to work once, the restore test might even appear to work ten times in a row, or a hundred times in a row, but can you ever be truely sure that it always is clean when you stop VMTools, that it always will be clean when you stop VMTools?

At the end of the day the question will always be... Was the backup actually taken in a supported scenario?  I'm not sure that I'd like to be in a situation explaining to the customer why their restores didn't actually work when they came to actually use them...

You:  Oh, yeah, we kill/stop VMTools when we have snapshot failures.

Customer:  Did the vendor authorise/approve you to do that?

Re: NetBackup VM Backup

 

Re: NetBackup VM Backup

@sdo 

Thanks for the response. I disabled the VMWARE snapshot provider services and the backup is running as expected now. 

Re: NetBackup VM Backup

Seems to be a somewhat common problem:

https://communities.vmware.com/thread/533736

I'm still not convinced that disabling the service is the right thing to do.

We still do not know exactly why it happens, nor exactly what the full impact/risk of disabling that service is.

Have you upgraded VMTools to latest version to match the ESXi hosts ?

Re: NetBackup VM Backup

Reinstalling VMware Tools after NetBackup is worrisome. The NetBackup installation or upgrade replaces the VMware snapshot provider with the Veritas provider (known in former versions as the Symantec or Backup Exec provider). We do this precisely because the VMware provider doesn't give the control we need over quiescing of databases.

Also, if a VM holds copies of several Exchange database but the backup conditions are to catalog only the active copies with the VM, with the Veritas provider NetBackup can tell Exchange to only truncate logs for the databases being protected.

Re: NetBackup VM Backup

I never knew that.  The implication then is that :

1) we can never allow VMTools to auto-update, or to be updated by anyone

...and/or...

2) we all need to implement procedures whereby, if we ever have a need to upgrade VMTools inside a guest VM, then we need to uninstall NetBackup Client and re-install NetBackup Client to ensure that the Veritas supplied VSS provider takes precedence

.

Is that right?

Accepted Solution!

Re: NetBackup VM Backup

You don't have to reinstall NetBackup. There's an installation program called "Veritas VSS Provider for vSphere" in NetBackup\bin\goodies. If you run it, it will reinstall the Veritas provider, and NetBackup will use the Veritas provider rather than the VMware provider.

I think there's a way in the VMware Tools console to tell whether their VSS Provider is in place. I haven't checked in a long time.

You can tell from the application event log on the VM that the Veritas VSS provider is used in your VMware backup. You should see events for it starting and stopping. It may still have one of the old names in the event log.

View solution in original post

Re: NetBackup VM Backup

@Lowell_Palecek   - appreciate the additional detail.  Thank you Sir!

Re: NetBackup VM Backup

Seems other versions of Windows OS under VMware may also be having quite similar problems:

https://www.theregister.co.uk/2019/10/16/vmware_windows_2019/

Re: NetBackup VM Backup

@ANURAG2840 it might be a good idea to unmark my previous post as a solution - which doesn't seem fair/valid to me anymore.

Re: NetBackup VM Backup

@Lowell_Palecek 

Thank you for the insight. I have installed the Veritas VSS usitility and it removed the VMWare snapshot provider and required a reboot. The backups are working as expected.

@sdo 

Thanks for the efforts. The issue is sorted.