cancel
Showing results for 
Search instead for 
Did you mean: 

Netbackup 10.0.0.1 client Solaris 5.10 upgrade fail

albatroz19
Level 5

Hi,
i have a Solaris 5.11 global zone on Oracle SPARC-T7-4 server, and Netbackup upgraded from 7.7.3 to 10.0.0.1 version.

Now i wanna upgrade the local zone also it on 7.7.3, to 10.0.0.1 but it fail with this error:

"ERROR: Detected an attempt to install incorrect platform and/or
operating system and version client binaries on client10."

These are Global and Local zone info:

- Global zone SunOS  5.11 11.3 sun4v sparc sun4v  Oracle Solaris 11.3 SPARC

- Whole Local zone SunOS  5.10 Generic_Virtual sun4v sparc sun4v  Oracle Solaris 10 1/13 s10s_u11wos_24a SPARC

On Veritas SORT NetBackup Operating System Compatibility Checker, i see that it's accepted for NBU 10 version.
Please someone can suggest a solution?

PS: I tried upgrade via primary gui, push install, manual install on local zone.

Thanks in advance,
Regards

7 REPLIES 7

quebek
Moderator
Moderator
   VIP    Certified

Hi

Thinking out loud... are you using proper client binaries?

How you do upgrade this? Can you shed a ligth? via local installer, deployment policies, push install?

DPeaco
Moderator
Moderator
   VIP   

Upgrading directly from 7.7.3 to 10.x is a huge jump! There are a LOT of security enhancements/implementations in NBU from version 8.1.1 and after. Sometimes, you have to upgrade in "steps" before you reach the end result for the version you wish to end up with.

Thanks,
Dennis

Hi,
client binaries are correct.

I do a pre-check via upgrade software by client's on Netbackup Java GUI, and it's ok, but when i do upgrade it fail with error above indicated.
Already tried push install, local installer, but same error.

Regards,

Hi @albatroz19 

It may be cleaner to uninstall the old version first and perform a tidy up before doing a fresh install on NetBackup 10.x

There is little on the client (other than perhaps exclude lists) that needs to be saved during an upgrade.

As for why it is failing - you may be missing required packages in the local zone to allow the install to work:
developer/developerstudio-126/library/c++-libs
developer/developerstudio-126/library/c-libs
developer/developerstudio-126/library/f90-libs
developer/developerstudio-126/library/math-libs
developer/developerstudio-126/library/perflib
developer/developerstudio-126/library/studio-gccrt
Refer to this article on Solaris 11 requirements for NetBackup 10:
https://www.veritas.com/content/support/en_US/article.100055295.html

David

kiyan
Level 5

I believe if it is missing a required package, it will provide a hint at installation (at least for me it did) time as it will do precheck for these packages.
But it could be something different between these two OS,just check if the both of them (OS level) are having same release, build etc.

 

 

HI @albatroz19 

As @kiyan says, there may be differences between the global and local zones. This is apparently a known issue  depending on the pkginfo settings. When you patch the global zone, not all packages in the local zone will be updated necessarily.

I believe if you detach then 'attach -u' the local zone this will sync up the versions. 

Cheers
David

Genericus
Moderator
Moderator
   VIP   

Check the software compliance - NetBackup stopped supporting Solaris at 9.1.0.1

I know because my master is solaris at 9.1.0.1 and I am migrating off solaris now...

NetBackup 10.2.0.1 on Flex 5360, duplicating via SLP to Access 3350, duplicating via SLP to LTO8 in SL8500 via ACSLS