cancel
Showing results for 
Search instead for 
Did you mean: 

Netbackup 7.1 Vmware Vstorage API Restore

mrtba
Level 4

Good afternoon,

 

I'm trying to restore a full VM to a vcenter server and I'm receiving the error below

ERROR:  restore not initiated:  the restore failed to recover the requested files(5)

 

This seems to be a pretty generic error.  I would like to provide some details about our setup.

 

We have a Vcenter server with a Netbackup Proxy host host on the ESX server that I'm restoring to.  The VM is windows and I'm restoring to an alternate location.  I'm only chnaging the display name of the VM and restoring to the same vcenter server and esx host that the VM was backed up through.  The restore is coming from tape if that matters.  The tape is in the robot. 

 

Is there some logs I can turn on for troubleshooting?

I'm using the FQDN name in all places. 

 

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions

mrtba
Level 4

Had to run the Netbackup restore as admin in windows server 2008....  Darn UAC!  I spent 4 hours trying to figure that out....

View solution in original post

5 REPLIES 5

mrtba
Level 4

Had to run the Netbackup restore as admin in windows server 2008....  Darn UAC!  I spent 4 hours trying to figure that out....

View solution in original post

pikachu
Level 6
Employee Certified

ERROR:  restore not initiated:  the restore failed to recover the requested files(5)

=> if you trace it back it is bprd that fails

Saravana
Level 3

From Netbackup 7.x onwards it uses vStorage API for backing up VM.

privileges which the VCB user has is enough to do backup whereas for restoration prospectus we need to use the account which has administrator rights.

So do re-configuring the credentials for vCenter server or ESX whatever is configured.

In below navigation path.

Media->Credential->Virtual Machine Servers.

Check the link for credential problem and solution.

 http://www.symantec.com/docs/TECH128513

pikachu
Level 6
Employee Certified

Keep in mind IF you delete virtual credentials they only get deleted out of the GUI, however NOT out of the EMM. If you decide to re-add a VC/ESX, which you just deleted you will run into issues.

 

Run 'nbemmcmd -listhosts'

identified the servers, which do not exist in the GUI credentials anymore and now run

'nbemmcmd -deletehost -machinetype virtual_machine -machinename MYOLDSERVER'

Marianne
Moderator
Moderator
Partner    VIP    Accredited Certified

THIS ISSUE IS SOLVED!!

Please see https://www-secure.symantec.com/connect/forums/netbackup-71-vmware-vstorage-api-restore#comment-6202421