cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Netbackup 7.6.1.1 Plug-in for VMware vCenter - auth token issues

Hello
Faced with the problem of adding a master server in vsphere client

Plug-in are installing exact documentation
Plug-in is available for Backup Monitoring, Reporting, I can see the VM.
port on the master server 8443 is configured and tested


log recoveryportal.log:
[http-9445-2] 05 May 2015 11:33:13 INFO  com.symantec.nbu.netbackup4j.http.NBHttpClient : GET method url:https://crm1-nb01:8443/nbwebservice/server/master/crm1-nb01/timezone
[http-9445-2] 05 May 2015 11:33:13 INFO  com.symantec.nbu.netbackup4j.http.NBHttpClient : Setting socket timeout to 300000 mili seconds
[http-9445-2] 05 May 2015 11:33:13 ERROR com.symantec.nbu.netbackup4j.http.NBHttpClient : Failed to parse NetBackup Error Code from the response due to JsonParseException: org.codehaus.jackson.JsonParseException: Unexpected character ('<' (code 60)): expected a valid value (number, String, array, object, 'true', 'false' or 'null')
 at [Source: java.io.StringReader@c1aa936; line: 1, column: 2]
[http-9445-2] 05 May 2015 11:33:13 ERROR RecoveryPortal : Application threw exception
java.lang.Exception: Failed to communicate with server using supplied auth token. Error: com.symantec.nbu.netbackup4j.model.NBException:  EC:0. Please verify that NetBackup Master Server name, port and auth token are valid
    at com.symantec.nbu.recoveryplugin.controller.NetBackupMgr.validateServer(Unknown Source)

Master - 7.6.1.1
vCenter server - 5.5
UTC date and correct on Master and Plug-in and vCenter server

it possible to advise in this situation?

PS previous version Plug-in 7.6.0.4 without any problems was registered

14 Replies
Highlighted

java.lang.Exception: Failed

java.lang.Exception: Failed to communicate with server using supplied auth token. Error: com.symantec.nbu.netbackup4j.model.NBException:  EC:0. Please verify that NetBackup Master Server name, port and auth token are valid

https://support.symantec.com/en_US/article.TECH217165.html

Create a new authentication token following procedure to "Create an Authentication Token" on Page 40 of the "Symantec NetBackup Plug-in for VMware vCenter Guide".

 
Highlighted

To create an authentication

To create an authentication token on the NetBackup master server
1
Enter the following on the master server:
Windows
install_path\NetBackup\wmc\bin\install\manageClientCerts.bat
-create vCenter_plugin_host
UNIX, Linux
/usr/openv/wmc/bin/install ./manageClientCerts -create
vCenter_plugin_host
where vCenter_plugin_host is the fully qualified domain name of the vCenter
where the plug-in is installed.
The manageClientCerts command returns the location of a compressed file
that contains the authentication token.
2
Provide the compressed file to the vCenter administrator.
Caution: Be sure to share or send the compressed file in a secure manner.
With the master server token, the plug-in can be authorized to restore virtual
machines.
See “ Au

 

Highlighted

Hello Thank you for your

Hello
Thank you for your attention to my problem

Of course, I performed ./manageClientCerts -create nbplugin_host_FQDN
and provide zip file to the vCenter client

nothing worked, the error remains

plugin reinstalled 3 times ... but all the same

Highlighted

We are having the exact same

We are having the exact same issue. We had Netbackup vCenter Plugin 7.6.0.3 running perfect and today we upgraded to 7.6.1.1. Everything is done according to guides and earlier upgrades. But we are not able to add the master server to the plugin "Add Servers" function. We have created the certificate/auth-token according to guidelines, and are adding an untouched zip-file, but nevertheless we get the "Failed to communicate" error, stating the connection was refused.

The plugin seems to work otherwise, and we get server backup status etc. But we cannot restore due to the lack of beeing able to add the master server.

We are using vCenter 5.1 U1

 

Highlighted

Hello if it is a bug, we

Hello
if it is a bug, we need to do something with it ...
may be notify support, they perhaps do not read this site.

Highlighted

Please raise support call to

Please raise support call to get more details and keep us posted for any updates

Highlighted

This technote might be

This technote might be relevant.

https://support.symantec.com/en_US/article.TECH227562.html

When executing manageClientCerts, ensure the correct hostname is used. It should be the hostname of the VM where the vCenter plugin is installed, which will not be the same as the vCenter host itself.

Highlighted

All possible methods of

All possible methods of solution do not allow to find out the reason is not possible to register a master server.
I have ended symantec tech support and they did not accept request.

the problem remains

Highlighted

Did you read through this

Did you read through this technote? https://support.symantec.com/en_US/article.TECH227562.html

It appears that error happens when you generate the cert with the wrong hostname.

Highlighted

hi everyone who is

hi everyone who is interested
I've updated the master server to version 7.6.1.2 and set Plug-in.
problem still exists
nothing works, I think something is wrong with the Plug-in...

Highlighted

Hello AndreyP5, I understand

Hello AndreyP5,

I understand that per the two suggestions above, you were attempting to recreate the server's certificates based on the following Veritas document:

Failure adding the master server to the vCenter plugin; com.symantec.nbu.netbackup4j.model.NBException, http://www.veritas.com/docs/000024411 (formerly TECH227562)

 

1. Are you still experiencing this issue, or do you have any updates?

2. Is the Windows hosting using a supported Java Runtime Environment (JRE) version? (1.7 update 55 or higher)

​3. Do you have consistent vCenter naming? (credentials, plug-in install, server install)

 

> When providing examples of the related servers...

4. Can you provide generic examples of servers/hostnames to ensure syntax is correct or any log messages can be referenced to the related server? (e.g. master.lab.local, vcenter1.lab.local, pluginhost.lab.local, etc)

 

> Referencing the admin guide...

NetBackup 7.6.1 Plug-in for VMware vSphere Web Client Guidehttp://www.veritas.com/docs/000004305

5. Can you confirm that you're not skipping any install steps in the admin guide? (page 13+)

6. Have you tried to fully uninstall the plugin, or any remnants? (page 27)

 

We look forward to your response! Thanks in advance!

JD | Veritas NetBackup Support
Highlighted

Re: Netbackup 7.6.1.1 Plug-in for VMware vCenter - auth token issues

Hello!
Thank you spotted my problem, it still remains.
But I do not put a plug-in for Web client, I put a plug-in for the usual vsphere client, based on the OVA template.
I tried 4 times to remove and install the plugin, exactly according to the documentation.
Registration is not obtained, the same error.
Examples logs and hostname will give later.

Highlighted

Re: Netbackup 7.6.1.1 Plug-in for VMware vCenter - auth token issues

This issue is already 6 months old.

Have you considered logging a Support call with Veritas?

Highlighted

Re: Netbackup 7.6.1.1 Plug-in for VMware vCenter - auth token issues

Hi
my support is over
I'm trying to solve the problem on their own
today i tried to install plugin on new vcenter server - the same problem