cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Netbackup error bpexpdate.exe -m idTape -d 0

Hello,

I have the bellow error when I try bpexpdate.exe -m idTape -d 0

there was a conflicting specification

I notice that I have 1 valid image on tape:

Media Status:                   FULL
Kilobytes:                      1164839106
Images:                         33
Valid Images:                   1
Retention Period:               8

but on Catalog search:

"INF - Status = found no images or media matching the selection criteria."

!!!!!!!!!!!!!!!!!!!!!!!!

 

 

Tags (2)
5 Replies
Highlighted

Re: Netbackup error bpexpdate.exe -m idTape -d 0

Hello

It's like something it's wrong between  catalog database and tape physical contents!!!

Media GUID: 64dfb937-8f85-4d47-bcae-9e8226257f63
Media ID: idTape
Partner: -
Media Type: HCART
Volume Group: 000_00000_TLD
Application: Netbackup
Media Flags: 1
Description: Added by Media Manager
Barcode: OSS587L4
Partner Barcode: --------
Last Write Host: buc-backup.evalue-ro.local
Created: 10/23/2015 11:05
Time Assigned: 09/24/2016 00:00
First Mount: 09/24/2016 00:01
Last Mount: 10/20/2016 16:36
Volume Expiration: -
Data Expiration: 09/29/2017 16:01
Last Written: 09/29/2016 16:01
Last Read: 10/20/2016 16:36
Robot Type: TLD
Robot Control Host: buc-backup.evalue-ro.local
Robot Number: 0
Slot: 17
Side/Face: -
Cleanings Remaining: -
Number of Mounts: 17
Maximum Mounts Allowed: 0
Media Status: FULL
Kilobytes: 1164839106
Images: 33
Valid Images: 1
Retention Period: 8
Number of Restores: 0
Optical Header Size Bytes: 1024
Optical Sector Size Bytes: 0
Optical Partition Size Bytes: 0
Last Header Offset: 15063068
Adamm Guid: 00000000-0000-0000-0000-000000000000
Rsm Guid: 00000000-0000-0000-0000-000000000000
Origin Host: NONE
Master Host: buc-backup.evalue-ro.local
Server Group: NO_SHARING_GROUP
Upgrade Conflicts Flag:
Pool Number: 6
Volume Pool: Monthly
Previous Pool Name: -
Vault Flags: -
Vault Container: -
Vault Name: -
Vault Slot: -
Session ID: -
Date Vaulted: -
Return Date: -
Media on Hold: 0
====================================================================
Command completed successfully.

Highlighted

Re: Netbackup error bpexpdate.exe -m idTape -d 0

I do not know what to do next...I tried ...but unfortunately..

bpimmedia -mediaid idTape -L
no entity was found

 

bpexpdate.exe -m idTape -d 0 -force
there was a conflicting specification

any help is welcome!!!!!!!!

Highlighted

Re: Netbackup error bpexpdate.exe -m idTape -d 0

Does the tape appear if you run 

bpmediaist -m <media id>

Highlighted

Re: Netbackup error bpexpdate.exe -m idTape -d 0

nbemmcmd shows 
Data Expiration: 09/29/2017 16:01

Are you using SLPs? Maybe there is an SLP operation that has 'gone wrong'. 
Anyhow, the images are gone from image database but something is preventing the tape from being deassigned. 

Image cleanup normally includes 'bpexpdate -deassignbyempty' to free up assigned status.

Is this the only tape that is affected?

Have you tried ' bpexpdate -deassignempty -force' ?

If 'deassign' does not work, then best to log a Support call with Veritas. 
They will probably need nbdb_unload output to troubleshoot. 

Highlighted

Re: Netbackup error bpexpdate.exe -m idTape -d 0

There seems to be one 'image' left ...

Images: 33
Valid Images: 1

Certainly it's a bit odd, the tape is assined (so should appear in bpmedialist) and the number of valid images (is actually the number of fragments, just to confuse things) - comes from the nbdb fragement table, so it seems at least some of the catalog info exists.

You might want to log a call with Support.  If post the case number back in this thread, I'll have a look.

What needs to be done, is:

1.  nbdb_unload

2.  Search the media ID in the image fragment table, from that, obtain the ImageKey value, 2nd field I think.

3.  Search for the ImageKey in the ImageCopy table

4. Search for the ImageKey in the Image table

What we're looking for here, is firstly to check if there is an enry in each of the 3 tables.  For a single image with only one copy and one fragment, there should be one line in each table.

If any of the lines are missing, that will be the issue.

If each line exists, theer may be some incorrect entry.  Personally, if you are trying to expire the tape anyway, it's just gong to be easier to delete the entry manually with SQL.