cancel
Showing results for 
Search instead for 
Did you mean: 

Netbackup java console wont load

Dollypee
Level 6
   VIP    Certified

Hello Team,

Can someone assist what could be happening here? Trying to launch Netbackup java console but stuck in " Determining peer installation type" window.  

2021-10-29_9-29-28.png

1 ACCEPTED SOLUTION

Accepted Solutions

Dollypee
Level 6
   VIP    Certified

I had to eventually bounce the environment all together. Finally got approval to upgrade to 8.3.0.1 

All is good now. Thanks @quebek  for chipping in. I appreciate the time and effort spent

View solution in original post

14 REPLIES 14

quebek
Level 6
   VIP    Certified

Hello

Symantec Netbackup - hmm really old NBU. Please create bpjava-msvc in the <installdir>\netbackup\logs and check out there what is going on, maybe it will point you for further investigation.

 

more info here https://www.veritas.com/support/en_US/article.100005318

 

Dollypee
Level 6
   VIP    Certified

@quebek - yes unfortunately this environment is still on 771

here's the bpjava-msvc logs. For security reason, I have changed the actual master server name to *master server name*

09:51:29.202 [9872.15332] <2> populateCertificatePath: Certificate to be used for SSL [C:\Program Files\Veritas\NetBackup\var\vxss\credentials\*master server name*]
09:51:29.202 [9872.15332] <4> command_SECURE_CHANNEL_INIT: Using certificate [C:\Program Files\Veritas\NetBackup\var\vxss\credentials\*master server name*] and Responding SECURE_CHANNEL_PROCEED.
09:51:29.264 [9872.15332] <4> session_secure_lookup: Initiating SSL Accept
09:51:29.264 [9872.15332] <2> populateCertificatePath: Certificate to be used for SSL [C:\Program Files\Veritas\NetBackup\var\vxss\credentials\*master server name*]
09:51:29.295 [9872.15332] <4> tls_accept: io.c.3330: SSL Channel established for fd[956]
09:51:29.295 [9872.15332] <4> session_secure_lookup: SSL Connection Accepted!
09:51:29.295 [9872.15332] <16> session_dispatch: Request count = 1 tag = 118
09:51:29.295 [9872.15332] <16> session_dispatch: Request count = 2 tag = 101
09:51:29.327 [9872.15332] <16> command_LOGON_TO_MSERVER: putenv(BPJAVA_MASTER_IPC_STRING=) failed
09:51:29.327 [9872.15332] <2> child_exec: Passing credential file >noUserCredentialsFile<
09:51:29.342 [9872.15332] <2> acquireTerminationToken: hJobToken bpjava-msvc_11284 = 0000000000000574 for pid = 11284
09:51:29.342 [9872.15332] <2> setUserServerTokens: server index = 0, hJobToken = 0000000000000574 for pid = 11284
09:51:29.827 [9872.15332] <16> fillReadBuff: ReadFile failed readStat = 109 = The pipe has been ended. , pLength = 0
09:57:11.276 [9872.15332] <16> readCharByChar: read failed(?), sockFd = 956, count = 0 (want = 3072), errno = 10054 = An existing connection was forcibly closed by the remote host.
09:57:11.276 [9872.15332] <16> session_dispatch: recv failed, sockFd = 956, errno = 10054 = An existing connection was forcibly closed by the remote host.
09:57:11.276 [9872.15332] <16> poll_listen: can't find file descriptor 00000000000003BC in polling table

quebek
Level 6
   VIP    Certified
Are you running it locally or from remote machnie? Is there any fw on Master?

Dollypee
Level 6
   VIP    Certified

Am running it locally on the master server itself. The server is master/media all in one box. No changes was recently made to the host as well.

quebek
Level 6
   VIP    Certified
I would try to:
Stop nbu
Stop pbx
Run ipconfig /flushdns
Bpclntcmd -cleat_host_cache
Start Pbx
Start nbu
From the other hand now i can manage nbu from cli :face_with_tears_of_joy:so would not be worried too much about non working Java ;p

quebek
Level 6
   VIP    Certified

Dollypee
Level 6
   VIP    Certified

hmmm...applied above steps,  issue still persisted 🤦‍:male_sign:

Hi @Dollypee 

Silly question, you said you were running this on the master/media itself - are you running the java GUI as administrator?

David

quebek
Level 6
   VIP    Certified
Check nbjlogs. Few weeks back i did have something similar it was related to at service and as far i do recall i ran something about certificate or some other command with - setup aster switch... Maybe i did Send email to team if So Will share more

Dollypee
Level 6
   VIP    Certified
@davidmoline - yes, running as administrator. It's been working for years until 2 days ago. I was informed no changes made to the server or nbu.

Dollypee
Level 6
   VIP    Certified
@quebek - I will greatly appreciate if you can share the fix you applied to your situation. Thank you

quebek
Level 6
   VIP    Certified

Hello 

@Dollypee I run this bpnbaz -ProvisionCert master.name

but I did a lot of log reviewing to check what was on internet available for me for this issue.

So this whole tech note I was following - I think we had similar issue as you... but I am not 100% sure

https://www.veritas.com/support/en_US/article.100032843

so be warned... not all solutions provided by me do work for all env.

Dollypee
Level 6
   VIP    Certified

@quebek  - Thanks for the effort. My issue appear to be different. Not related to certificate. But I really appreciate the effort.

I am finding a way to work with support at the moment at least at  my own risk since the code no longer support. Thanks again

Dollypee
Level 6
   VIP    Certified

I had to eventually bounce the environment all together. Finally got approval to upgrade to 8.3.0.1 

All is good now. Thanks @quebek  for chipping in. I appreciate the time and effort spent

View solution in original post