cancel
Showing results for 
Search instead for 
Did you mean: 

Netbackup restore a VM browsing shows only C drive

Hi,

Today, while I am trying to restore a single file from our 5 TB VM (Windows 2008 R2) file Server "Storage", it shows only Drive C, missing the 4.5 TB data Drive E.

The last time it was working (to restore single files like above) was about 6 months ago. After that, there has been no restore request from our users until now.

However, it doesn't mean the policy setting has been wrong all this time, though...

For example,  I've checked its VMware policy, under its "Exclude Disks", the only option selected is "No disks excluded". Also, when I select "Virtual Machine Backups" Restore type, the 4.5 TB VMDK of Drive E shows up. Not to mention that, the same policy setting works for another 2 VM file Servers (we do use one VMware policy for one VM file Server).

So, it seems to me, there is nothing wrong with the policy settings.

Giving that the weekend is coming so that we really want to have a good Full backup, so I'm wondering if anyone can point me to the right direction on this ?

Might be the case that the VM file Server itself needs to be restarted ? 

BTW, our Netbackup master Server is Windows 2012, Netbackup version is 8.2

Thanks,

Kelvin

Tags (2)
5 Replies

Re: Netbackup restore a VM browsing shows only C drive

Hey
Check on this vm if admins didnt enable file system deduplication on this volume. This isnt supported with vmware based backups and single file restore...

Re: Netbackup restore a VM browsing shows only C drive

Data Deduplication is not installed on this File Server.

Re: Netbackup restore a VM browsing shows only C drive

Hi @KelvinHBLi 

Is the E Drive marked as independant?

If so NetBackup will ignore this for backup (VMware snapshot limitation), but it still knows about it for VM restore (so will create an empty VMDK). If this is the case, then you either need to change that setting or use another method to back it up (such as install the agent). 

David

Re: Netbackup restore a VM browsing shows only C drive

Guess what ?

The problem was solved just after a simple reboot...

What worries me now is that how come Netbackup, while not backing up the E, didn’t show us any error messages ?

Kelvin

Re: Netbackup restore a VM browsing shows only C drive

Guess what ?

The problem was solved just after a simple reboot, no any other actions were taken - why was that ?

What worries me now is why Netbackup, while not backing up the E, didn’t show us any error messages ?

Kelvin