cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Netbackup service auto start on OS X 10.10.x

Hello,

I have installed NetBackup 7.6.1 agent (with 7.6.1.1 update) in several OS X 10.10.x systems and it seems to work, except for one problem.

It does not start automaticaly after a client reboot.

I searched for a solution for this problem and found this post from 15/April/2015 (https://www-secure.symantec.com/connect/forums/netbackup-service-auto-start-os-x-1010).

I am running NetBackup 7.6.1.1 and I can install the client on a Mac OS X 10.10.3 and 10.10.4.

After the client installation I am able to run a backup.

As soon as the client reboots, the NetBackup agent does not start automaticaly.

If I go to "/Library/StartupItems/netbackup/" and run "./netbackup start" on a terminal window with root privileges, then the agent start and I can perform backups again. Also works with a "sudo /usr/openv/netbackup/bin/bp.start_all".

How can I define the NetBackup agents to run automaticaly os OS X 10.10.x ??

I have already checked the folders and files:

Macintosh OSX
/Library/StartupItems/netbackup/Resources/netbackup
/Library/StartupItems/netbackup/StartupParameters.plist
/Library/StartupItems/netbackup/netbackup

How can I know that the "StartupParameters.plist" is correct?

Thanks in advance

José Roque

1 Solution

Accepted Solutions
Highlighted
Accepted Solution!

4) With base v7.6.1

4) With base v7.6.1 installed, then upgraded NetBackup to v7.6.1.1 - rebooted, and NBU services did not auto start.

5) With v7.6.1.1 installed, then patched to v7.6.1.2, rebooted, and the the NetBackup Client services did auto start.

6) Reverted VM to snaphot where it was running v7.6.1, booted, and services had not started, then upgraded from base v7.6.1 to v7.6.1.2, rebooted and NBU services had started.

.

So, it would seem that your quick solution is to patch the problem Mac OSX Yosemite 10.10.4 clients to v7.6.1.2.  It is generally accepted that it is ok to patch a client to a triple dot patch version higher than media and/or master within the same double dot minor version - but this does assume that there's nothing in the Mac v7.6.1.2 client which does actually require a v7.6.1.2 media or master.

I guess the next step would be for you to review the latest EEB version 8 listing for NetBackup v7.6.1.2 and see if anything has been added to v7.6.1.2 Client for Mac which requires a media server to also be v7.6.1.2.  The lastest EEB listing for v7.6.1.2 is here:

https://support.symantec.com/en_US/article.DOC6085.html

View solution in original post

19 Replies
Highlighted

Perhaps compare? NetBackup

Perhaps compare?

NetBackup Client 7.6.1.2 appears to start ok on my Mac OS 10.9.5.

Here's the contents of my startup files:

mbpro-wifi:/ root# cd /Library/
mbpro-wifi:Library root# cd StartupItems/
mbpro-wifi:StartupItems root# ls -lash
total 0
0 drwxr-xr-x   7 root  wheel   238B Jun  6 16:48 .
0 drwxr-xr-x+ 66 root  wheel   2.2K May 21  2014 ..
0 drwxr-xr-x   7 root  wheel   238B Nov 21  2012 HWPortDetect_driver
0 drwxr-xr-x   5 root  wheel   170B May  5  2013 netbackup
0 drwxr-xr-x   5 root  wheel   170B May 20  2012 tap
0 drwxr-xr-x   5 root  wheel   170B May 20  2012 tun
0 drwxr-xr-x   4 root  wheel   136B Jun  6 16:48 vxpbx_exchanged

mbpro-wifi:StartupItems root# ls -lash netbackup/
total 16
0 drwxr-xr-x  5 root  wheel   170B May  5  2013 .
0 drwxr-xr-x  7 root  wheel   238B Jun  6 16:48 ..
0 drwxr-xr-x  4 root  wheel   136B Jun  6 16:51 Resources
8 -rwxr-xr-x  1 root  wheel   293B Jun  6 16:51 StartupParameters.plist
8 -rwxr-xr-x  1 root  wheel   538B Jun  6 16:51 netbackup

mbpro-wifi:StartupItems root# ls -lash vxpbx_exchanged/
total 16
0 drwxr-xr-x  4 root  wheel   136B Jun  6 16:48 .
0 drwxr-xr-x  7 root  wheel   238B Jun  6 16:48 ..
8 -rw-r--r--  1 root  wheel   196B Jun  6 16:48 StartupParameters.plist
8 -rwxr-xr-x  1 root  wheel   266B Jun  6 16:48 vxpbx_exchanged

mbpro-wifi:StartupItems root# cat netbackup/StartupParameters.plist 
{
  Description     = "NetBackup";
  Provides        = ("NetBackup");
  Requires        = ("Network");
  Uses            = ("Network");
  OrderPreference = "Late";
  Messages =
  {
    restart = "Restarting NetBackup";
    start = "Starting NetBackup";
    stop = "Stopping NetBackup";
  };
}

mbpro-wifi:StartupItems root# cat vxpbx_exchanged/StartupParameters.plist 
{
  Description     = "Symantec Private Branch Exchange";
  Provides        = ("vxpbx_exchanged");
  Requires        = ("Network");
  Uses            = ("Network");
  OrderPreference = "Early";
}

 

Highlighted

Is MacOSX GateKeeper blocking

Is MacOSX GateKeeper blocking the programs from starting?

...an example:

http://blog.trendmicro.com/trendlabs-security-intelligence/gatekeeper-on-mac-os-x-10-9-mavericks/

 

Highlighted

Well, comparing with your

Well, comparing with your results, it seems to be all fine.

I will check the GateKeeper and will be back with more info.

Meanwhile, below, the contents already compared...

sh-3.2# cd /Library/
sh-3.2# cd StartupItems/
sh-3.2# ls -lash
total 0
0 drwxr-xr-x   5 root  wheel   170B Jul  6 15:30 .
0 drwxr-xr-x+ 64 root  wheel   2.1K Feb 25 17:13 ..
0 drwxr-xr-x   4 root  wheel   136B Feb 25 17:10 cma
0 drwxr-xr-x   5 root  wheel   170B Jul  6 15:30 netbackup
0 drwxr-xr-x   4 root  wheel   136B Jul  6 15:30 vxpbx_exchanged


sh-3.2# ls -lash netbackup/
total 16
0 drwxr-xr-x  5 root  wheel   170B Jul  6 15:30 .
0 drwxr-xr-x  5 root  wheel   170B Jul  6 15:30 ..
0 drwxr-xr-x  3 root  wheel   102B Jul  8 09:22 Resources
8 -rwxr-xr-x  1 root  wheel   293B Jul  8 09:22 StartupParameters.plist
8 -rwxr-xr-x  1 root  wheel   538B Jul  8 09:22 netbackup


sh-3.2# ls -lash vxpbx_exchanged/
total 16
0 drwxr-xr-x  4 root  wheel   136B Jul  6 15:30 .
0 drwxr-xr-x  5 root  wheel   170B Jul  6 15:30 ..
8 -rw-r--r--  1 root  wheel   196B Jul  6 15:30 StartupParameters.plist
8 -rwxr-xr-x  1 root  wheel   266B Jul  6 15:30 vxpbx_exchanged


sh-3.2# cat netbackup/StartupParameters.plist
{
  Description     = "NetBackup";
  Provides        = ("NetBackup");
  Requires        = ("Network");
  Uses            = ("Network");
  OrderPreference = "Late";
  Messages =
  {
    restart = "Restarting NetBackup";
    start = "Starting NetBackup";
    stop = "Stopping NetBackup";
  };
}


sh-3.2# cat vxpbx_exchanged/StartupParameters.plist
{
  Description     = "Symantec Private Branch Exchange";
  Provides        = ("vxpbx_exchanged");
  Requires        = ("Network");
  Uses            = ("Network");
  OrderPreference = "Early";
}

Highlighted

Well, thanks for your

Well, thanks for your suggestions.

I have compared your output with my system and everything seems to be equal.

I have also checked GateKeeper sugestion but it does not work. After all I can start the daemons by command line without any issue. They just don't start automaticaly.

Thanks for your help

Highlighted

On OS X 10.10.4, on a command

On OS X 10.10.4, on a command line:

sh-3.2# cd /Library/StartupItems/netbackup/
sh-3.2# ./netbackup start
Starting NetBackup
NetBackup network daemon started.
NetBackup client daemon started.
sh-3.2#

 

On the NetBackup master server:

C:\Users\pt_netbackup>bptestbpcd -host pt-fs60 -verbose
1 1 1
10.36.1.104:52664 -> 10.36.2.21:13724
10.36.1.104:52666 -> 10.36.2.21:13724
PEER_NAME = pt-bs101.xx.xxxx.net
HOST_NAME = pt-fs60.xx.xxxx.net
CLIENT_NAME = pt-fs60.xx.xxxx.net
VERSION = 0x07610000
PLATFORM = macosx10_6
PATCH_VERSION = 7.6.1.0
SERVER_PATCH_VERSION = -1.-1.-1.-1
MASTER_SERVER = pt-bs101.xx.xxxx.net
EMM_SERVER = pt-bs101.xx.xxxx.net
NB_MACHINE_TYPE = CLIENT

Highlighted

Don't know MAC OS X, but have

Don't know MAC OS X, but have had issues on other systems with the root user profile not being completely loaded so had to use su - c "command" to get startup/scheduled stuff to work

The standard questions: Have you checked: 1) What has changed. 2) The manual 3) If there are any tech notes or VOX posts regarding the issue
Highlighted

Hello, I tried to "su - root"

Hello,

I tried to "su - root" before installation and everything is installed corrctly without errors but the services won't start automaticaly upon a system reboot.

They only start manualy.

Opened a case with Symantec but untin now I got no answer.

Thanks for your answers.

Highlighted

On my Mac OSX 10.9.5, it was

On my Mac OSX 10.9.5, it was originally running NetBackup Client v7.5.0.7 which was probably installed when the Mac was on ML 10.8.x.  And, when I upgraded and installed NetBackup Client v7.6.1 and then patched to v7.6.1.2 it was running Mac OSX 10.9.5 - and I had to use:

# sudo su -

...because 'su - root' doesn't work for me.  I can't imagine that this makes a difference.  But maybe having a previous older installation of NetBackup Client already installed does make a difference.

I'll try to test a fresh install of NetBackup Client v7.6.1 and v7.6.1.2 on a fresh MacOSX 10.10.4.

Highlighted

Ok - installed a fresh new

Ok - installed a fresh new MacOSX Yosemite 10.10.4 virtual machine (in VMware Fusion Pro v7.1.2) from a base MacOSX 10.10.4 boot ISO, installed VMware tools, rebooted, then patched the Mac software/apps up to date (using App Store), rebooted, then did 'sudo su -' to switch to root, and installed just NetBackup Client v7.6.1 (base) for now, which installed ok and started NetBackup Client services ok.

Rebooted VM, and NetBackup Services have NOT started automatically.

I'll snapshot the VM, and see what happens after patching to v7.6.1.1 and v7.6.1.2.

Highlighted

Other things tried before

Other things tried before installing an NBU patch...

1) As 10.10.4 with NBU v7.6.1 (base), tried changing security setting to allow applications from any source to run, rebooted, and the NBU services still did not start.

2) Found firewall was off.  Turned firewall on, added bpcd, vnetd and pbx_exchange to allow incoming connections, rebooted, and the NBU services still did not start.  Started manually, and tested master to client comms ok using bptestbpcd.

3) Rebooted, and check VxPBX logs:

/opt/VRTSpbx/bin/vxlogview -o 103 -t 01:00:00

...but nothing seen, so it is not trying to start and failing.  It's just not being started.

Highlighted

Hello, thanks for your

Hello, thanks for your work!

Now you are exactly in the same point as I am.

I hope that you can find an answer Smiley Happy

Thanks again

Highlighted
Accepted Solution!

4) With base v7.6.1

4) With base v7.6.1 installed, then upgraded NetBackup to v7.6.1.1 - rebooted, and NBU services did not auto start.

5) With v7.6.1.1 installed, then patched to v7.6.1.2, rebooted, and the the NetBackup Client services did auto start.

6) Reverted VM to snaphot where it was running v7.6.1, booted, and services had not started, then upgraded from base v7.6.1 to v7.6.1.2, rebooted and NBU services had started.

.

So, it would seem that your quick solution is to patch the problem Mac OSX Yosemite 10.10.4 clients to v7.6.1.2.  It is generally accepted that it is ok to patch a client to a triple dot patch version higher than media and/or master within the same double dot minor version - but this does assume that there's nothing in the Mac v7.6.1.2 client which does actually require a v7.6.1.2 media or master.

I guess the next step would be for you to review the latest EEB version 8 listing for NetBackup v7.6.1.2 and see if anything has been added to v7.6.1.2 Client for Mac which requires a media server to also be v7.6.1.2.  The lastest EEB listing for v7.6.1.2 is here:

https://support.symantec.com/en_US/article.DOC6085.html

View solution in original post

Highlighted

Well, there it is on page 17,

Well, there it is on page 17, in the v7.6.1.2 updates section:

  1. Etrack Incident: 3725822

    • Associated Primary Etrack: 3743133

    • Associated Service Request Etrack(s): 3743129

    • Description:
      NetBackup and PBX failed to start after a reboot on Mac OS X 10.10 Yosemite. 

Highlighted

So, we've proven that the fix

So, we've proven that the fix works.

If you're unable to patch your clients to v7.6.1.2 then you could ask your Symantec Support engineer whether there are any notes against Etrack 3725822 (and its siblings) which would help you manually fix each of your clients.

Highlighted

And again on page

And again on page 19:

  1. Etrack Incident: 3751538

    • Associated Primary Etrack: 3743133

    • Associated Service Request Etrack(s): 3743129

    • Description:
      NetBackup and PBX failed to start after a reboot on Mac OS X 10.10 Yosemite. 

Highlighted

And there is another fix for

And there is another fix for Mac OSX contained within the v7.6.1.2 patch kit, listed on page 15:

Etrack: 3779907 Restoring files on Mac OS X did not restore Extended Attributes and Resource Forks. 

...so it would seem like it could be a good idea to patch your clients to v7.6.1.2.

.

(I like the EEB listings... so useful. Smiley Happy

Highlighted

It would seem there is one

It would seem there is one question remaining...

...you may need to find out from Symantec Support whether Etrack: 3779907 required changes at the master server and/or media server and/or client.  If the fix fot Etrack: 3779907 was only at the client layer, then you should be good to patch the clients to v7.6.1.2.

Highlighted

Ok, problem solved. Netbackup

Ok, problem solved.

Netbackup v7.6.1.2 is starting automaticaly on OS X 10.10.3 and 10.10.4.

Thanks for all the help.

Highlighted

No worries - was fun - glad

No worries - was fun - glad it helped.

The lesson for me in this, I think, is... remember to check the EEB listing!     Smiley Happy