cancel
Showing results for 
Search instead for 
Did you mean: 

Netbackup single file restore from linux

Jana_T
Level 4
Partner Accredited

Hi,

I am experiencing an issue while doing single file restore from Linux VM.

I am using the following:

Netbackup 7.6.0.2 on Windows 2008 server

Backup policy - VMware (enabled file recovery)

 

What i am trying to do is restore a single file using Backup, Archive and Restore client on my Master server. I know that restore on the linux VM doesn't work if i don't have an agent installed, that is why the destination of the restore is the master server itself.

Nevertheless, my restore is failing momentarily with errors 2820, 2817,2800. The error number depends on the restore policy I am using (VMware, Standard, Flashbackup).

VMware policy restore error (2820)

FlashBackup-Windows policy restore error (2817)

Standard policy restore error (2800)

 

Can anyone help me with this issue?

Regards,

Jana

1 ACCEPTED SOLUTION

Accepted Solutions

Will_Restore
Level 6

It would be easier to set up Linux VM than try to figure out how to make this restore work without one.

 

View solution in original post

6 REPLIES 6

RamNagalla
Moderator
Moderator
Partner    VIP    Certified

so are you saying client is linux VM and trying tor restore to windwos Master...? if yes.. it is not supported... you need to use the any Unix servers as destination..

however you can try giving the UNC path in the destination location in restroe window 2nd option , by selection the alternate location.

like \C\Restore

if its still failed with UNC path, provide the detail status of the faield job

Jana_T
Level 4
Partner Accredited

Hi,

i have tried the suggested path, and this is the job output

in restore window:

15:54:02 7/31/2015: Restore Started

15:54:03 (293114.xxx) Found (1,422,079) files in (1) images for Restore Job ID 293114.xxx
15:54:03 (293114.001) Restoring from copy 1 of image created 7/31/2015 1:09:58 AM from policy QSS-srv
15:54:09 (293114.001) Status of restore from copy 1 of image created 7/31/2015 1:09:58 AM = the restore failed to recover the requested files

15:54:09 (293114.001) The following files/folders were not restored:
15:54:09 (293114.001) UTF - /etc/lvm/profile/vg_srv9/lv_root/aksi.php

15:54:09 (293114.xxx) INF - Status = VMware policy restore error.

 

 

and in master server:

7/31/2015 3:54:02 PM - begin Restore

7/31/2015 3:54:02 PM - restoring image srv9.internet.ba_1438297798

7/31/2015 3:54:03 PM - Info bprd(pid=5504) Found (1,422,079) files in (1) images for Restore Job ID 293114.xxx

7/31/2015 3:54:03 PM - Info bprd(pid=5504) Restoring from copy 1 of image created 07/31/15 01:09:58 from policy QSS-srv

7/31/2015 3:54:03 PM - requesting resource @aaaab

7/31/2015 3:54:03 PM - granted resource MediaID=@aaaab;DiskVolume=PureDiskVolume;DiskPool=Deduplication;Path=PureDiskVolume;StorageServer=bkp.qssbh.com;MediaServer=bkp.qssbh.com

7/31/2015 3:54:09 PM - end Restore; elapsed time: 0:00:07

VMware policy restore error (2820)

 

As you can see it is the same error. Problem is that i don't have a machine with Linux agent.

I could swear this was working in previous Netbackup versions.

 

Regards,

Jana

 

RamNagalla
Moderator
Moderator
Partner    VIP    Certified

the media server that is allocated for restore is the same one that used for backup tooo? or the different one...?

if you see the Diffeent media server for restore job, use the below setting to use the same backup media server for restore and see how it goes..

create <install-path\veritas\netbackup\db\config\USE_BACKUP_MEDIA_SERVER_FOR_RESTORE 

make sure this file has no extenctions.

 

Jana_T
Level 4
Partner Accredited

Hi,

yes it is the same server for restore and backup.

Will_Restore
Level 6

It would be easier to set up Linux VM than try to figure out how to make this restore work without one.

 

I was able to restore a file from a redhat system to our master server which is windows 2016 using the following destination /C/Temp/<filename>