cancel
Showing results for 
Search instead for 
Did you mean: 

No cleaning tapes

Hendrikbez
Level 3

I am getting this error, when I need to clean my tape drivers on a IBM Tape library

I am doing the following

  1. Using the administrator console on my pc
  2. Go to device monitor
  3.  Right click on drive name
  4. Click on drive clean/clean now

No clean tape is define in the devies robot or 0 cleaning remaining (mm Status 4)

  1. On my media/volume pools/none
  2. There are 3 cln tapes in just put two new one in, a of them still have 100 cleaning available
  3. CLNU02/CLNU03/CLNU64

 

8. in robtest when I run s s it show cartridge=yes, but it does not show the barcode #

I cannot figure out why it does not see/use the cln tapes.

1 ACCEPTED SOLUTION

Accepted Solutions

Marianne
Level 6
Partner    VIP    Accredited Certified

Nope! 

Cleaning tape is still 1/2 inch cleaning tape media type.

It must match the hcart2 density of the drives.

So, you need to change the media type for the cleaning tapes to 1/2 inch cleaning tape 2.  

PLEASE note the 2

View solution in original post

19 REPLIES 19

Marianne
Level 6
Partner    VIP    Accredited Certified

It is possible that the density (media type) of the cleaning tapes in NBU do not match the density of the tape drives.

In NBU the densities/media type MUST match, even if the physical hardware types are perfectly compatible.

Please show us output of your drive config and cleaning tape config:

From cmd (<install-path>\veritas\volmgr\bin):

tpconfig -l

vmquery -m CLNU02

 

OH! Big problem!!!

in robtest when I run s s it show cartridge=yes, but it does not show the barcode #

Most robots will not mount a cleaning cartridge if it does not have the correct label. It seems that there is no label on this tape or the robot barcode reader cannot read the label.

Eject the tape and have a look at the label.

What about the other cleaning cartridges?

RamNagalla
Moderator
Moderator
Partner    VIP    Certified

What is the Model of the IBM library?

does it have the barcoad reader? and tapes are labled with the Barcode ?

Hendrikbez
Level 3

Marianne

Ok I see they have put tapes in with wrong cln type TL1 and not LT5

Thank you

Marianne
Level 6
Partner    VIP    Accredited Certified

Since there is no hcart5 type in NBU, can we assume that your drives are configured as the NBU default of hcart2?

If this is the case, just ensure that your cleaning tapes are configure as hcart2_cln (1/2 inch cleaning tape 2).

Hendrikbez
Level 3

I did go and look at my ohter libary, there the cleaning tape with L1 works, even if it uses normal Tapes L5

DId try to change it, but even if I try the new one, it still does not clean

Marianne
Level 6
Partner    VIP    Accredited Certified

I was referring to NBU config.  That is why I asked for tpconfig and vmquery output. (See my 1st reply above.)

Densities must match... 

Hendrikbez
Level 3

I did try to give info, but I am bateling to get this reply's saved, then Firefox restarted, here are the error's I cam getting, when I try what you ask for.

za.png

Marianne
Level 6
Partner    VIP    Accredited Certified

The commands are in <install-path>\veritas\volmgr\bin

 

Hendrikbez
Level 3

Yes on this server it is installed on the D:\

I did a search and did not find any other fileslike this.

Marianne
Level 6
Partner    VIP    Accredited Certified

So, cd to D:\Program Files\veritas\volmgr\bin 

You were in  D:\Program Files\veritas\volmgr folder. 

Hendrikbez
Level 3

z4.png

Ok here is the info.

Marianne
Level 6
Partner    VIP    Accredited Certified

So, you can see the cleaning tapes are configured as HC_CLN - 1/2 inch cleaning tape and the tape drives as hcart2.

This means that the cleaning tapes can only be used in drives configured as hcart.

You need to change the media type of the cleaning cartridges to HC2_CLN  - 1/2 inch cleaning tape 2.

This is what I was trying to explain about matching densities/media type....

Hendrikbez
Level 3

did change it, but still not working

 

a6.png

Marianne
Level 6
Partner    VIP    Accredited Certified

Nope! 

Cleaning tape is still 1/2 inch cleaning tape media type.

It must match the hcart2 density of the drives.

So, you need to change the media type for the cleaning tapes to 1/2 inch cleaning tape 2.  

PLEASE note the 2

Mark_Solutions
Level 6
Partner Accredited Certified

Marianne is spot on here and gave you the solution a while back

While you are in the volmgr\bin directory please run this command (using your Master servers name):

vmchange -h yourmasterservername -new_mt hcart2_clean -m CLNU02

Do this for each of your cleaning tapes

It should work then

Once done please mark Mariannes post as the solution

Thanks

mph999
Level 6
Employee Accredited

The density of the clweaning tape is wrong as Marianne has pointed out.

There different densities of cleaning tapes, you need to use the one that matches the drives, so 

 

Try this command 

vmchange -m CLNU02 -new_mt hcart2_clean

 

Marianne
Level 6
Partner    VIP    Accredited Certified

Thank you Mark and Martin!!

I was just looking up the command as well! (Godd to know that great minds think alike!)

You can change it from that same cmd as follows:

vmchange  -new_mt hcart2_clean -m CLNU02

Hendrikbez
Level 3

Thank you for your help on this Marianne, it is working now

Marianne
Level 6
Partner    VIP    Accredited Certified

Glad we could help!